Bug 322812 - Can't dock back undocked places panel
Summary: Can't dock back undocked places panel
Status: RESOLVED DUPLICATE of bug 322299
Alias: None
Product: dolphin
Classification: Unclassified
Component: panels: places (show other bugs)
Version: 2.2
Platform: Other Other
: NOR major (vote)
Target Milestone: ---
Assignee: KDE-Windows
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-07-25 12:01 UTC by Andrius
Modified: 2013-07-29 21:25 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrius 2013-07-25 12:01:17 UTC
After undocking places panel, it can't be docked back

Reproducible: Always

Steps to Reproduce:
1. Unlock panels
2. Undock places panel
3. Try docking it again
Actual Results:  
The only way to move the undocked panel is to have it focused, press Alt+Space, then select move. Even so it can't be docked back.

Expected Results:  
It should be possible to move the panel again with the mouse and be able to dock it back to dolphin window.

MinGW binaries from installer.
Comment 1 Patrick Spendrin 2013-07-25 12:10:20 UTC
also happens on msvc debug. There is no way to drag the (undocked) panels at all, it would be nice if somebody who knows more about that could tell us how this panel handling works and where to search for this bug.
Comment 2 Patrick Spendrin 2013-07-25 12:11:12 UTC
@dolphin-developers: Please help us to find the cause of this bug
Comment 3 Hannah von Reth 2013-07-25 12:14:14 UTC
Can also happen with  the dock widget in quassel or amarok
Comment 4 Frank Reininghaus 2013-07-25 12:55:34 UTC
Thanks for the report.

(In reply to comment #2)
> @dolphin-developers: Please help us to find the cause of this bug

Looks pretty much like a Qt bug to me. I'm afraid I don't really have much time right now to dig into Qt and find the cause of the bug :-(

I'm wondering if the possibility to drag panels out of the Dolphin window is useful at all. Maybe we should just disable this "feature" to work around this problem (and others that we cannot do anything about, like bug 288629).

*** This bug has been marked as a duplicate of bug 322299 ***
Comment 5 Hannah von Reth 2013-07-25 13:24:41 UTC
Its probably not a qt bug as it is working in the quassel standalone build without the kde support.
Comment 6 Frank Reininghaus 2013-07-25 13:33:33 UTC
OK, but I still cannot help with debugging this because I don't work with Windows at all. Sorry about that.

(In reply to comment #5)
> Its probably not a qt bug as it is working in the quassel standalone build
> without the kde support.

Then you might want to discuss this with the Quassel people. If they know what changes in their build process if you enable KDE support or not, then this might help to figure out what goes wrong.

Just a quick idea: maybe it has something to do with the style? Checking if choosing a different style on Windows fixes this issue is probably easy for you, right?
Comment 7 Hannah von Reth 2013-07-25 14:40:07 UTC
Hm your right starting quassel with the default style fixed the problem with dock widgets. It looks like if the boarder is not correctly drawn if the widget is dethatched.
Comment 8 Frank Reininghaus 2013-07-25 14:50:21 UTC
OK, then you should report this to the developers of the style that causes the problem (is that Oxygen?).
Comment 9 Andrius 2013-07-25 18:04:31 UTC
It works with plastique style.
Comment 10 Hannah von Reth 2013-07-25 18:20:55 UTC
(In reply to comment #9)
> It works with plastique style.

and with the windows style xD
Comment 11 Frank Reininghaus 2013-07-29 21:25:41 UTC
Git commit 5583fc635b1bfc96c096bce6c4fa2c28df4d279f by Frank Reininghaus.
Committed on 29/07/2013 at 21:22.
Pushed by freininghaus into branch 'master'.

Do not allow that panels are dragged out of the main window

This feature might have been useful in some cases, but it's most likely
not useful enough to justify that we accept the bugs that it causes.
Even though some of these bugs are not Dolphin's fault at all, they
cause serious problems for users in some cases.

I'm pushing this commit to master only because I prefer to not push such
behavior changes to 4.11 at this point of the release cycle.
Related: bug 288629, bug 322299
FIXED-IN: 4.12.0
REVIEW: 111692

M  +11   -3    dolphin/src/dolphindockwidget.cpp

http://commits.kde.org/kde-baseapps/5583fc635b1bfc96c096bce6c4fa2c28df4d279f