Bug 322299 - (Windows) Places/Info Panels can't be moved if separated
Summary: (Windows) Places/Info Panels can't be moved if separated
Status: RESOLVED UPSTREAM
Alias: None
Product: dolphin
Classification: Unclassified
Component: panels: places (show other bugs)
Version: 16.12.2
Platform: Microsoft Windows Other
: NOR major (vote)
Target Milestone: ---
Assignee: Dolphin Bug Assignee
URL:
Keywords:
: 322812 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-07-13 01:42 UTC by Travis G
Modified: 2013-07-29 21:25 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Travis G 2013-07-13 01:42:33 UTC
Panels separated from the main window can't be moved. This means they can't be moved back into the main window afaik. On Kubuntu I can click and drag the title bar but this doesn't work on windows.

Reproducible: Always

Steps to Reproduce:
1.Install Dolphin on Windows
2.With panels unlocked, click the 'separate' button it top-right of places/info
3. Try to click and drag title bar to move the new window
Comment 1 Frank Reininghaus 2013-07-14 09:27:56 UTC
Thanks for the bug report!

I'm not aware of anything unusual about our handling of the panels - basically, they are just QDockWidgets, so I assume that the problem must be in Qt. If you know other Qt/KDE apps where the handling of QDockWidgets works fine on Windows, feel free to reopen.

I can't really help more with this, sorry. I'm not aware of any Dolphin developer who works on a non-Linux system, so we can't really provide much support for Windows/Mac problems.
Comment 2 Frank Reininghaus 2013-07-25 12:55:34 UTC
*** Bug 322812 has been marked as a duplicate of this bug. ***
Comment 3 Frank Reininghaus 2013-07-25 13:02:36 UTC
Just for the record, if you want to make the panels work again, you have to delete Dolphin's configuration file, in which the positions of the panels are stored. It's called "dolphinrc" on Linux and is stored in the .kde/share/config in the user's home directory. That might be different on Windows though, I don't know.

I think we might just remove the possibility to move panels out of the window in the future. IMHO, this feature is not extremely useful, but it causes lots of trouble.
Comment 4 Frank Reininghaus 2013-07-29 21:25:41 UTC
Git commit 5583fc635b1bfc96c096bce6c4fa2c28df4d279f by Frank Reininghaus.
Committed on 29/07/2013 at 21:22.
Pushed by freininghaus into branch 'master'.

Do not allow that panels are dragged out of the main window

This feature might have been useful in some cases, but it's most likely
not useful enough to justify that we accept the bugs that it causes.
Even though some of these bugs are not Dolphin's fault at all, they
cause serious problems for users in some cases.

I'm pushing this commit to master only because I prefer to not push such
behavior changes to 4.11 at this point of the release cycle.
Related: bug 288629, bug 322812
FIXED-IN: 4.12.0
REVIEW: 111692

M  +11   -3    dolphin/src/dolphindockwidget.cpp

http://commits.kde.org/kde-baseapps/5583fc635b1bfc96c096bce6c4fa2c28df4d279f