Bug 322342 - kwallet tries to change keys after deleting the whole entry
Summary: kwallet tries to change keys after deleting the whole entry
Status: RESOLVED DUPLICATE of bug 299435
Alias: None
Product: kwalletmanager
Classification: Applications
Component: general (show other bugs)
Version: 1.10
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Michael Leupold
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-07-14 12:17 UTC by Per (phobie)
Modified: 2013-07-14 14:13 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Per (phobie) 2013-07-14 12:17:06 UTC
Application: kwalletmanager (1.10)
KDE Platform Version: 4.10.5
Qt Version: 4.8.4
Operating System: Linux 3.8.0-27-generic x86_64
Distribution: Ubuntu 13.04

-- Information about the crash:
- What I was doing when the application crashed:

1. Remove, add or change some keys from a entry
2. Remove the entry
3. kwallet asks if you really want to delete the entry.
4. Select yes!
5. kwallet asks if you want to save the changes from step 1
6. No matter if you select yes or no, kdewallet crashes every time

-- Backtrace:
Application: Dienstprogramm für digitale Brieftaschen (kwalletmanager), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f4c1ab3d7c0 (LWP 7544))]

Thread 2 (Thread 0x7f4c091ae700 (LWP 7545)):
#0  0x00007f4c17d9b3cd in poll () from /lib/x86_64-linux-gnu/libc.so.6
#1  0x00007f4c14c421dc in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f4c14c42304 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f4c18520036 in QEventDispatcherGlib::processEvents (this=0x7f4c040008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f4c184f038f in QEventLoop::processEvents (this=this@entry=0x7f4c091add90, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f4c184f0618 in QEventLoop::exec (this=this@entry=0x7f4c091add90, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f4c183f2410 in QThread::exec (this=this@entry=0x18638f0) at thread/qthread.cpp:542
#7  0x00007f4c184d1edf in QInotifyFileSystemWatcherEngine::run (this=0x18638f0) at io/qfilesystemwatcher_inotify.cpp:256
#8  0x00007f4c183f4bec in QThreadPrivate::start (arg=0x18638f0) at thread/qthread_unix.cpp:338
#9  0x00007f4c15114f8e in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#10 0x00007f4c17da7e1d in clone () from /lib/x86_64-linux-gnu/libc.so.6

Thread 1 (Thread 0x7f4c1ab3d7c0 (LWP 7544)):
[KCrash Handler]
#5  isEmpty (this=0x726168732f65649b) at ../../include/QtCore/../../src/corelib/tools/qlist.h:99
#6  isEmpty (this=0x726168732f65649b) at ../../include/QtCore/../../src/corelib/tools/qlist.h:152
#7  QTreeWidgetItem::~QTreeWidgetItem (this=0x1bf88c0, __in_chrg=<optimized out>) at itemviews/qtreewidget.cpp:1495
#8  0x0000000000429d99 in _start ()

Reported using DrKonqi
Comment 1 Christoph Feck 2013-07-14 14:13:51 UTC

*** This bug has been marked as a duplicate of bug 299435 ***