Bug 299435 - Crash when deleting a newly created entry
Summary: Crash when deleting a newly created entry
Status: RESOLVED WORKSFORME
Alias: None
Product: kwalletmanager
Classification: Applications
Component: general (show other bugs)
Version: 1.10
Platform: Debian stable Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Michael Leupold
URL:
Keywords:
: 322342 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-05-05 11:08 UTC by Alex Dănilă
Modified: 2013-09-02 21:12 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (4.87 KB, text/plain)
2012-08-02 13:33 UTC, Till Schäfer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Dănilă 2012-05-05 11:08:09 UTC
Application: kwalletmanager (1.8)
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.8.0
Operating System: Linux 3.3.0-trunk-amd64 x86_64
Distribution: Debian GNU/Linux 5.0.10 (lenny)

-- Information about the crash:
- What I was doing when the application crashed:
Creating a new password entry in the KDE wallet, and then decided to delete it.

The crash can be reproduced every time.

-- Backtrace:
Application: KDE Wallet Manager (kwalletmanager), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[KCrash Handler]
#7  isEmpty (this=0x7100000030) at ../../include/QtCore/../../src/corelib/tools/qlist.h:99
#8  isEmpty (this=0x7100000030) at ../../include/QtCore/../../src/corelib/tools/qlist.h:152
#9  QTreeWidgetItem::~QTreeWidgetItem (this=0x15aa7a0, __in_chrg=<optimized out>) at itemviews/qtreewidget.cpp:1495
#10 0x000000000042c629 in KWalletEntryItem::~KWalletEntryItem (this=0x15aa7a0, __in_chrg=<optimized out>) at ../../kwallet/allyourbase.cpp:152
#11 0x0000000000422a5e in KWalletEditor::deleteEntry (this=0x137ee80) at ../../kwallet/kwalleteditor.cpp:810
#12 0x0000000000426dbb in KWalletEditor::qt_metacall (this=0x137ee80, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff67dfeb10) at ./kwalleteditor.moc:134
#13 0x00007f2024383df9 in QMetaObject::activate (sender=0x1520030, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff67dfeb10) at kernel/qobject.cpp:3566
#14 0x00007f202500aa12 in QAction::triggered (this=<optimized out>, _t1=false) at .moc/release-shared/moc_qaction.cpp:277
#15 0x00007f202500abff in QAction::activate (this=0x1520030, event=<optimized out>) at kernel/qaction.cpp:1257
#16 0x00007f2025459279 in QMenuPrivate::activateCausedStack (this=0x14053c0, causedStack=..., action=0x1520030, action_e=QAction::Trigger, self=true) at widgets/qmenu.cpp:1028
#17 0x00007f202545f382 in QMenuPrivate::activateAction (this=0x14053c0, action=0x1520030, action_e=QAction::Trigger, self=true) at widgets/qmenu.cpp:1120
#18 0x00007f2025e306a0 in KMenu::mouseReleaseEvent (this=0x146b5a0, e=0x7fff67dff6e0) at ../../kdeui/widgets/kmenu.cpp:464
#19 0x00007f20250615f4 in QWidget::event (this=0x146b5a0, event=0x7fff67dff6e0) at kernel/qwidget.cpp:8361
#20 0x00007f202546091b in QMenu::event (this=0x146b5a0, e=0x7fff67dff6e0) at widgets/qmenu.cpp:2460
#21 0x00007f2025010ec4 in notify_helper (e=0x7fff67dff6e0, receiver=0x146b5a0, this=0x11d4010) at kernel/qapplication.cpp:4555
#22 QApplicationPrivate::notify_helper (this=0x11d4010, receiver=0x146b5a0, e=0x7fff67dff6e0) at kernel/qapplication.cpp:4527
#23 0x00007f2025016613 in QApplication::notify (this=<optimized out>, receiver=0x146b5a0, e=0x7fff67dff6e0) at kernel/qapplication.cpp:4098
#24 0x00007f2025d6eb26 in KApplication::notify (this=0x7fff67e00430, receiver=0x146b5a0, event=0x7fff67dff6e0) at ../../kdeui/kernel/kapplication.cpp:311
#25 0x00007f202436f80c in QCoreApplication::notifyInternal (this=0x7fff67e00430, receiver=0x146b5a0, event=0x7fff67dff6e0) at kernel/qcoreapplication.cpp:876
#26 0x00007f2025011e92 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#27 QApplicationPrivate::sendMouseEvent (receiver=0x146b5a0, event=0x7fff67dff6e0, alienWidget=0x0, nativeWidget=0x146b5a0, buttonDown=0x0, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3166
#28 0x00007f202508e901 in QETWidget::translateMouseEvent (this=0x146b5a0, event=<optimized out>) at kernel/qapplication_x11.cpp:4449
#29 0x00007f202508d11a in QApplication::x11ProcessEvent (this=0x7fff67e00430, event=0x7fff67dfffa0) at kernel/qapplication_x11.cpp:3641
#30 0x00007f20250b5852 in x11EventSourceDispatch (s=0x11d0530, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#31 0x00007f2020cb279a in g_main_dispatch (context=0x11d0400) at /tmp/buildd/glib2.0-2.32.1/./glib/gmain.c:2500
#32 g_main_context_dispatch (context=0x11d0400) at /tmp/buildd/glib2.0-2.32.1/./glib/gmain.c:3052
#33 0x00007f2020cb2b60 in g_main_context_poll (n_fds=5, fds=0x1, timeout=15554, context=0x11d0400, priority=<optimized out>) at /tmp/buildd/glib2.0-2.32.1/./glib/gmain.c:3420
#34 g_main_context_iterate (dispatch=1, block=<optimized out>, context=0x11d0400, self=<optimized out>) at /tmp/buildd/glib2.0-2.32.1/./glib/gmain.c:3118
#35 g_main_context_iterate (context=0x11d0400, block=<optimized out>, dispatch=1, self=<optimized out>) at /tmp/buildd/glib2.0-2.32.1/./glib/gmain.c:3060
#36 0x00007f2020cb2c24 in g_main_context_iteration (context=0x1577e20, may_block=1742726768) at /tmp/buildd/glib2.0-2.32.1/./glib/gmain.c:3177
#37 0x00007fff67e00430 in ?? ()
#38 0x00000000011d3760 in ?? ()
#39 0x0000000000000001 in ?? ()
#40 0x00007f202439ed8f in QEventDispatcherGlib::processEvents (this=0x11a44b0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#41 0x00007f20250b54de in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x00007f202436e5f2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#43 0x00007f202436e847 in QEventLoop::exec (this=0x7fff67e00340, flags=...) at kernel/qeventloop.cpp:204
#44 0x00007f20243738d7 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#45 0x0000000000419248 in main (argc=1, argv=0x7fff67e00878) at ../../kwallet/main.cpp:95

Reported using DrKonqi
Comment 1 Alex Dănilă 2012-05-05 11:12:43 UTC
Actual steps to reproduce:
-create a new entry under Password/passwords in the folder tree
-input some data into the newly created entry but don't save
-right click on the newly created item in the folder tree and select "Delete"
-in the dialog that asks to save unsaved data, press No.

Sorry for the confusion, the bug reporting application got me confused too.
Comment 2 Martin Koller 2012-07-20 21:28:51 UTC
Can confirm with current KDE/4.9 from git
Comment 3 Till Schäfer 2012-08-02 13:33:07 UTC
Created attachment 72903 [details]
New crash information added by DrKonqi

kwalletmanager (1.10) on KDE Platform 4.9.00 using Qt 4.8.2

- What I was doing when the application crashed:

same problem here: 
create a new entry, create a field like password, do not save the modified entry, delte the modified entry from tree, question diolog pops up and ask if i want to save the modified entry, klick no

-- Backtrace (Reduced):
#6  isEmpty (this=0x30) at ../../include/QtCore/../../src/corelib/tools/qlist.h:99
#7  isEmpty (this=0x30) at ../../include/QtCore/../../src/corelib/tools/qlist.h:152
#8  QTreeWidgetItem::~QTreeWidgetItem (this=0x285cc20, __in_chrg=<optimized out>) at itemviews/qtreewidget.cpp:1495
#9  0x000000000042d399 in KWalletEntryItem::~KWalletEntryItem (this=0x285cc20, __in_chrg=<optimized out>) at /var/tmp/portage/kde-base/kwallet-4.9.0/work/kwallet-4.9.0/allyourbase.cpp:152
#10 0x00000000004213a2 in KWalletEditor::deleteEntry (this=0x236e9e0) at /var/tmp/portage/kde-base/kwallet-4.9.0/work/kwallet-4.9.0/kwalleteditor.cpp:810
Comment 4 Christoph Feck 2013-07-14 14:13:51 UTC
*** Bug 322342 has been marked as a duplicate of this bug. ***
Comment 5 Valentin Rusu 2013-09-02 21:12:49 UTC
I think this is gone when I did the UI-refactoring.