Bug 321508 - KDE Power Management error message on startup
Summary: KDE Power Management error message on startup
Status: RESOLVED FIXED
Alias: None
Product: solid
Classification: Unclassified
Component: powermanagement (show other bugs)
Version: 4.10.97
Platform: Archlinux Packages Linux
: NOR normal with 61 votes (vote)
Target Milestone: ---
Assignee: Dario Freddi
URL:
Keywords:
: 322356 322865 323045 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-06-22 21:16 UTC by pressman57
Modified: 2013-08-11 11:23 UTC (History)
9 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description pressman57 2013-06-22 21:16:33 UTC
Whenever KDE starts I get the following error message:

KDE Power Management
The profile "AC" tried to activate DimDisplay, a non-existant action. This is usually due to an installation problem or a configuration problem.

AMD 64, GeForce 6150SE nForce 430 with 304.xx drivers

Reproducible: Always

Steps to Reproduce:
1. Start KDE from KDM
2.
3.
Comment 1 András Manţia 2013-07-11 06:22:12 UTC
Same here with master, actually there are two messages, the one above and a similar for BrightnessControl. This is a desktop machine.
Comment 2 Hrvoje Senjan 2013-07-14 23:13:04 UTC
*** Bug 322356 has been marked as a duplicate of this bug. ***
Comment 3 Eugene 2013-07-24 18:15:57 UTC
KDE: 4.10.95
OS: kubuntu 13.04
Kernel: 3.11RC2

Same taint every time during KDE start and also every time when pushing 'Defaults' in Systemsettings - Power.
Comment 4 Jekyll Wu 2013-07-27 05:39:52 UTC
*** Bug 322865 has been marked as a duplicate of this bug. ***
Comment 5 Jin-tong Hu 2013-07-28 02:25:27 UTC
Same here after upgrading KDE to v4.10.95.
OS: Mageia 3 w/ Cauldron pkgs
Kernel: 3.10.3

And same with Eugene's in Comment 3:
Same taint every time during KDE start and also every time when pushing 'Defaults' in Systemsettings - Power.
Comment 6 Mark 2013-07-28 12:12:10 UTC
Confirmed (arhlinux with KDE 4.11 RC2).
Comment 7 Alex Fiestas 2013-07-28 23:00:11 UTC
https://git.reviewboard.kde.org/r/111768/

Will be fixed before final.
Comment 8 Alex Fiestas 2013-07-28 23:01:20 UTC

*** This bug has been marked as a duplicate of bug 302846 ***
Comment 9 Alex Fiestas 2013-08-01 19:47:18 UTC
Git commit 4fb9668669c6bc789f0e0213e4ddbf67aa5dc797 by Àlex Fiestas.
Committed on 01/08/2013 at 19:32.
Pushed by afiestas into branch 'master'.

Replace Notification by kWarning on missing/unsupported actions

hat new behavior makes the notification "Action not found" deprecated
since now it is totally possible that a profile tries to load an
unsupported action such DimDisplay on most workstations.
Related: bug 322973, bug 302846

REVIEW:111768

M  +4    -4    powerdevil/daemon/powerdevilcore.cpp

http://commits.kde.org/kde-workspace/4fb9668669c6bc789f0e0213e4ddbf67aa5dc797
Comment 10 Alex Fiestas 2013-08-05 13:11:08 UTC
Git commit e352d07f33207959bdc13352cedd4322eb107a7e by Àlex Fiestas.
Committed on 01/08/2013 at 19:32.
Pushed by afiestas into branch 'KDE/4.11'.

Replace Notification by kWarning on missing/unsupported actions

hat new behavior makes the notification "Action not found" deprecated
since now it is totally possible that a profile tries to load an
unsupported action such DimDisplay on most workstations.
Related: bug 322973, bug 302846

REVIEW:111768
(cherry picked from commit 4fb9668669c6bc789f0e0213e4ddbf67aa5dc797)

M  +4    -4    powerdevil/daemon/powerdevilcore.cpp

http://commits.kde.org/kde-workspace/e352d07f33207959bdc13352cedd4322eb107a7e
Comment 11 Christoph Feck 2013-08-11 11:23:25 UTC
*** Bug 323045 has been marked as a duplicate of this bug. ***