Bug 302846 - warns about DPMS at login on a virtual machine
Summary: warns about DPMS at login on a virtual machine
Status: RESOLVED FIXED
Alias: None
Product: solid
Classification: Unclassified
Component: powermanagement (show other bugs)
Version: 4.8.80 (beta1)
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Dario Freddi
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-01 17:52 UTC by Oliver Henshaw
Modified: 2013-08-10 13:44 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.11


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Oliver Henshaw 2012-07-01 17:52:18 UTC
When I log into kde on a kvm install a grey notification box comes up saying

The profile "AC" tried to activate DPMSControl, a non existent action. This is usually due to an installation problem or to a configuration problem.

Obviously the virtual machine doesn't have dpms.

In .kde/share/config/powermanagementprofilesrc I see the snippet:

[AC][DPMSControl]
idleTime=600

This can be seen on the Fedora 17 kde live image, so this is the "default" configuration and not some local configuration. I double-checked, and the same thing happens with a newly created test user too.

First noticed on kde 4.8.3, confirmed still present on kde 4.8.4 and 4.8.95 (from http://lists.fedoraproject.org/pipermail/kde/2012-June/011659.html ) i.e. all of:

kde-workspace-4.8.3-3.fc17.x86_64 
kde-workspace-4.8.4-1.fc17.x86_64
kde-workspace-4.8.95-1.fc17.x86_64


Reproducible: Always




This reminded me of bug 201235.
Comment 1 Oliver Henshaw 2012-07-01 17:56:34 UTC
Actually, this might be the fault of qxl not implementing dpms.

with vnc/cirrus:
No warning
$ grep -i dpms /var/log/Xorg.0.log 
[    12.572] (II) Loading extension DPMS
[    14.142] (==) CIRRUS(0): DPMS enabled

with spice/qxl:
Warning about DPMS
$ grep -i dpms /var/log/Xorg.0.log 
[    12.633] (II) Loading extension DPMS
Comment 2 Oliver Henshaw 2012-07-01 17:58:33 UTC
(Forgot to note, I found a similar bug report in opensuse - https://bugzilla.novell.com/show_bug.cgi?id=765679 - not sure why it apparently fixed itself)
Comment 3 Oliver Henshaw 2012-07-01 18:07:09 UTC
I've filed https://bugzilla.redhat.com/show_bug.cgi?id=836819 about the xorg-x11-drv-qxl part of this.
Comment 4 Marco Parillo 2012-08-22 14:51:36 UTC
Similar behaviour on VMWare.
https://bugs.launchpad.net/ubuntu/+source/kde-workspace/+bug/1039582
Comment 5 Marco Parillo 2012-09-13 12:52:50 UTC
The warning stopped now that I have been updated to Platform Version 4.9.1.
Comment 6 Kai Uwe Broulik 2012-11-28 14:22:30 UTC
The problem about the DPMS thing getting in your powermanagementprofilesrc is that the profilegenerator (which runs on first start on an empty session) just adds it to the config file (to set some defaults) without watching if the action is supported (or even compiled!) and so PowerDevil tries to activate an action that doesn't exist and so emits that ugly notification.

So there are two things to do:
- Don't add the DPMS action if it is not supported or compiled. (Review pending)
- Make error handling saner, don't emit that notification on startup and everytime a profile changes … (Oliver Henshaw is working on that)
Comment 7 Kai Uwe Broulik 2012-11-28 20:35:47 UTC
Git commit bbe593dbb6fb954c718c268d8a6cc31d8fbedd6f by Kai Uwe Broulik.
Committed on 28/11/2012 at 21:33.
Pushed by broulik into branch 'master'.

Do not add DPMS action to the profile if it is not supported / not compiled.
This workarounds the error message about DPMS not loadable at least for fresh setups.

REVIEW: 107503

M  +16   -0    powerdevil/daemon/powerdevilprofilegenerator.cpp

http://commits.kde.org/kde-workspace/bbe593dbb6fb954c718c268d8a6cc31d8fbedd6f
Comment 8 Alex Fiestas 2013-03-03 17:25:03 UTC
What's the status of this?
Comment 9 Alex Fiestas 2013-03-20 12:29:02 UTC
Kai, should we set this as fixed?
Comment 10 Kai Uwe Broulik 2013-03-20 12:31:37 UTC
It's workarounded but the initial cause of the warning (powerdevil being too verbose about such minor problems) didn't make it into 4.10. Need to check the status on the patch on Review Board.
Comment 11 Alex Fiestas 2013-07-28 21:31:45 UTC
This is fixed now I take?

Also, I have submited a patch to remove the notification and replace it with a kWarning.

https://git.reviewboard.kde.org/r/111768/
Comment 12 Alex Fiestas 2013-07-28 23:01:20 UTC
*** Bug 321508 has been marked as a duplicate of this bug. ***
Comment 13 Alex Fiestas 2013-08-01 19:47:18 UTC
Git commit 4fb9668669c6bc789f0e0213e4ddbf67aa5dc797 by Àlex Fiestas.
Committed on 01/08/2013 at 19:32.
Pushed by afiestas into branch 'master'.

Replace Notification by kWarning on missing/unsupported actions

hat new behavior makes the notification "Action not found" deprecated
since now it is totally possible that a profile tries to load an
unsupported action such DimDisplay on most workstations.
Related: bug 322973, bug 321508

REVIEW:111768

M  +4    -4    powerdevil/daemon/powerdevilcore.cpp

http://commits.kde.org/kde-workspace/4fb9668669c6bc789f0e0213e4ddbf67aa5dc797
Comment 14 Alex Fiestas 2013-08-05 13:11:08 UTC
Git commit e352d07f33207959bdc13352cedd4322eb107a7e by Àlex Fiestas.
Committed on 01/08/2013 at 19:32.
Pushed by afiestas into branch 'KDE/4.11'.

Replace Notification by kWarning on missing/unsupported actions

hat new behavior makes the notification "Action not found" deprecated
since now it is totally possible that a profile tries to load an
unsupported action such DimDisplay on most workstations.
Related: bug 322973, bug 321508

REVIEW:111768
(cherry picked from commit 4fb9668669c6bc789f0e0213e4ddbf67aa5dc797)

M  +4    -4    powerdevil/daemon/powerdevilcore.cpp

http://commits.kde.org/kde-workspace/e352d07f33207959bdc13352cedd4322eb107a7e