Bug 321278 - KDE crash while trying to fix gamma
Summary: KDE crash while trying to fix gamma
Status: RESOLVED DUPLICATE of bug 292335
Alias: None
Product: systemsettings
Classification: Unclassified
Component: general (show other bugs)
Version: 1.0
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-17 15:39 UTC by zarebskidavid
Modified: 2013-06-17 21:30 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description zarebskidavid 2013-06-17 15:39:07 UTC
Application: systemsettings (1.0)
KDE Platform Version: 4.8.5 (4.8.5) "release 2"
Qt Version: 4.8.1
Operating System: Linux 3.4.42-2.28-desktop x86_64
Distribution: "openSUSE 12.2 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:
trying to change the gamma
- Unusual behavior I noticed:
I could not have any screen saver preview few before the crash

The crash can be reproduced some of the time.

-- Backtrace:
Application: Configuration du système (systemsettings), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[KCrash Handler]
#6  0x00007f0b27adc524 in QAbstractButton::isChecked (this=0x29c4a50) at widgets/qabstractbutton.cpp:774
#7  0x00007f0b06e4264d in ?? () from /usr/lib64/kde4/kcm_kgamma.so
#8  0x00007f0b284c7b79 in qt_static_metacall (_a=<optimized out>, _id=<optimized out>, _o=<optimized out>, _c=<optimized out>) at /usr/src/debug/kdelibs-4.8.5/build/kdeui/kcmodule.moc:66
#9  KCModule::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at /usr/src/debug/kdelibs-4.8.5/build/kdeui/kcmodule.moc:57
#10 0x00007f0b26abd0ae in QObject::event (this=0x2abbed0, e=<optimized out>) at kernel/qobject.cpp:1204
#11 0x00007f0b277736ea in QWidget::event (this=0x2abbed0, event=0x2acdc90) at kernel/qwidget.cpp:8821
#12 0x00007f0b2772474c in QApplicationPrivate::notify_helper (this=this@entry=0x1e862f0, receiver=receiver@entry=0x2abbed0, e=e@entry=0x2acdc90) at kernel/qapplication.cpp:4554
#13 0x00007f0b27728c7a in QApplication::notify (this=0x7fffb6d222a0, receiver=0x2abbed0, e=0x2acdc90) at kernel/qapplication.cpp:4415
#14 0x00007f0b28438006 in KApplication::notify (this=0x7fffb6d222a0, receiver=0x2abbed0, event=0x2acdc90) at /usr/src/debug/kdelibs-4.8.5/kdeui/kernel/kapplication.cpp:311
#15 0x00007f0b26aa873e in QCoreApplication::notifyInternal (this=0x7fffb6d222a0, receiver=receiver@entry=0x2abbed0, event=event@entry=0x2acdc90) at kernel/qcoreapplication.cpp:876
#16 0x00007f0b26aac091 in sendEvent (event=0x2acdc90, receiver=0x2abbed0) at kernel/qcoreapplication.h:231
#17 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x1e44380) at kernel/qcoreapplication.cpp:1500
#18 0x00007f0b26ad67a3 in sendPostedEvents () at kernel/qcoreapplication.h:236
#19 postEventSourceDispatch (s=0x1e79be0) at kernel/qeventdispatcher_glib.cpp:279
#20 0x00007f0b2397f3b5 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#21 0x00007f0b2397f6e8 in ?? () from /usr/lib64/libglib-2.0.so.0
#22 0x00007f0b2397f7a4 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#23 0x00007f0b26ad6936 in QEventDispatcherGlib::processEvents (this=0x1e49b80, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#24 0x00007f0b277c48ae in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#25 0x00007f0b26aa773f in QEventLoop::processEvents (this=this@entry=0x7fffb6d22180, flags=...) at kernel/qeventloop.cpp:149
#26 0x00007f0b26aa79c8 in QEventLoop::exec (this=0x7fffb6d22180, flags=...) at kernel/qeventloop.cpp:204
#27 0x00007f0b26aac3a8 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#28 0x000000000040b1ee in ?? ()
#29 0x00007f0b262a2455 in __libc_start_main () from /lib64/libc.so.6
#30 0x000000000040b245 in _start ()

This bug may be a duplicate of or related to bug 292335.

Possible duplicates by query: bug 307556.

Reported using DrKonqi
Comment 1 Christoph Feck 2013-06-17 21:30:24 UTC

*** This bug has been marked as a duplicate of bug 292335 ***