Bug 307556 - systemsettings: Crash while accessing Gamma with elevated privs.
Summary: systemsettings: Crash while accessing Gamma with elevated privs.
Status: RESOLVED DUPLICATE of bug 292335
Alias: None
Product: systemsettings
Classification: Unclassified
Component: kcm_kgamma (show other bugs)
Version: 4.8.4
Platform: Debian testing Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-09-29 04:50 UTC by David Smith
Modified: 2012-10-07 13:20 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Smith 2012-09-29 04:50:29 UTC
Package: systemsettings
Version: 4:4.8.4-3
Severity: important

Application: System Settings (systemsettings), signal: Segmentation fault
Using host libthread_db library "/lib/i386-linux-
gnu/i686/cmov/libthread_db.so.1".
[KCrash Handler]
#7  0xb6cd91d7 in QAbstractButton::isChecked (this=0x9ec9948) at
widgets/qabstractbutton.cpp:774
#8  0xb131913c in ?? () from /usr/lib/kde4/kcm_kgamma.so
#9  0xb74fba07 in qt_static_metacall (_a=0x9ee3cc0, _id=3, _o=0x9ecb630,
_c=<optimized out>) at ./kcmodule.moc:66
#10 KCModule::qt_static_metacall (_o=0x9ecb630,
_c=QMetaObject::InvokeMetaMethod, _id=3, _a=0x9ee3cc0) at ./kcmodule.moc:57
#11 0xb62b778a in QMetaCallEvent::placeMetaCall (this=0x9f13768,
object=0x9ecb630) at kernel/qobject.cpp:525
#12 0xb62bbccb in QObject::event (this=0x9ecb630, e=0x9f13768) at
kernel/qobject.cpp:1195
#13 0xb69134da in QWidget::event (this=0x9ecb630, event=0x9f13768) at
kernel/qwidget.cpp:8830
#14 0xb68ba47c in QApplicationPrivate::notify_helper (this=0x99a3898,
receiver=0x9ecb630, e=0x9f13768) at kernel/qapplication.cpp:4556
#15 0xb68bef24 in QApplication::notify (this=0x99a3898, receiver=0x9ecb630,
e=0x9f13768) at kernel/qapplication.cpp:4417
#16 0xb7455581 in KApplication::notify (this=0xbff72a9c, receiver=0x9ecb630,
event=0x9f13768) at ../../kdeui/kernel/kapplication.cpp:311
#17 0xb62a555e in QCoreApplication::notifyInternal (this=0xbff72a9c,
receiver=0x9ecb630, event=0x9f13768) at kernel/qcoreapplication.cpp:915
#18 0xb62a976d in sendEvent (event=<optimized out>, receiver=<optimized out>)
at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#19 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0,
data=0x9975c18) at kernel/qcoreapplication.cpp:1539
#20 0xb62a99ec in QCoreApplication::sendPostedEvents (receiver=0x0,
event_type=0) at kernel/qcoreapplication.cpp:1432
#21 0xb62d76c4 in sendPostedEvents () at
.../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#22 postEventSourceDispatch (s=0x9991d30) at
kernel/qeventdispatcher_glib.cpp:279
#23 0xb56d6633 in g_main_context_dispatch () from /lib/i386-linux-
gnu/libglib-2.0.so.0
#24 0xb56d69d0 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#25 0xb56d6ab1 in g_main_context_iteration () from /lib/i386-linux-
gnu/libglib-2.0.so.0
#26 0xb62d7841 in QEventDispatcherGlib::processEvents (this=0x9976780,
flags=...) at kernel/qeventdispatcher_glib.cpp:424
#27 0xb696d1fa in QGuiEventDispatcherGlib::processEvents (this=0x9976780,
flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#28 0xb62a402c in QEventLoop::processEvents (this=this@entry=0xbff729c8,
flags=...) at kernel/qeventloop.cpp:149
#29 0xb62a4321 in QEventLoop::exec (this=0xbff729c8, flags=...) at
kernel/qeventloop.cpp:204
#30 0xb62a9a9a in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1187
#31 0xb68b82f4 in QApplication::exec () at kernel/qapplication.cpp:3817
#32 0x08050d32 in main (argc=5, argv=0xbff72b84) at
.../../../systemsettings/app/main.cpp:49



-- System Information:
Debian Release: wheezy/sid
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: i386 (i686)

Kernel: Linux 3.2.0-3-686-pae (SMP w/1 CPU core)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages systemsettings depends on:
ii  kde-runtime      4:4.8.4-1
ii  libc6            2.13-35
ii  libfontconfig1   2.9.0-7
ii  libkcmutils4     4:4.8.4-3
ii  libkdecore5      4:4.8.4-3
ii  libkdeui5        4:4.8.4-3
ii  libkhtml5        4:4.8.4-3
ii  libkio5          4:4.8.4-3
ii  libknewstuff3-4  4:4.8.4-3
ii  libqt4-dbus      4:4.8.2+dfsg-2
ii  libqt4-xml       4:4.8.2+dfsg-2
ii  libqtcore4       4:4.8.2+dfsg-2
ii  libqtgui4        4:4.8.2+dfsg-2
ii  libstdc++6       4.7.1-7
ii  libx11-6         2:1.5.0-1

systemsettings recommends no packages.

systemsettings suggests no packages.

-- no debconf information

Reproducible: Always

Steps to Reproduce:

1. Edit your "System Settings" menu item: select "run as different user"
2. Start up System Settings, it prompts for root password, enter it.
3. Click on "Display and Monitor"
4. In the window that pops up, click on "Gamma" on the left.
5. SegFaults
Actual Results:  
SegFaults

Expected Results:  
The "Gamma" section of Display and Monitor should open correctly.

KWIN Desktop effects are enabled.  
X11/XRender is used in KWIN
Systemsettings launched as different user (eleveated privs).
Comment 1 Pino Toscano 2012-10-07 13:20:01 UTC

*** This bug has been marked as a duplicate of bug 292335 ***