Bug 308737 - IMAP setting up crashes
Summary: IMAP setting up crashes
Status: RESOLVED DUPLICATE of bug 312057
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: IMAP resource (show other bugs)
Version: 4.9
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Kevin Ottens
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-10-21 04:39 UTC by jrzabott
Modified: 2013-02-26 03:05 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jrzabott 2012-10-21 04:39:24 UTC
Application: akonadi_imap_resource (4.9)
KDE Platform Version: 4.9.2
Qt Version: 4.8.3
Operating System: Linux 3.5.0-17-generic i686
Distribution: Ubuntu 12.10

-- Information about the crash:
- What I was doing when the application crashed:

I was setting up my IMAP e-mail account on imap.ig.com.br when the problem occourred.

-- Backtrace:
Application: jrzabott@ig.com.br of type IMAP E-Mail Server (akonadi_imap_resource), signal: Segmentation fault
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0xb4a41740 (LWP 26962))]

Thread 3 (Thread 0xafe60b40 (LWP 26969)):
#0  0xb55249a6 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#1  0xb5524cb8 in g_mutex_unlock () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0xb54e3ba0 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb54e3e61 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb737c99f in QEventDispatcherGlib::processEvents (this=0xb0e0aa08, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#5  0xb734926c in QEventLoop::processEvents (this=this@entry=0xafe60228, flags=...) at kernel/qeventloop.cpp:149
#6  0xb7349561 in QEventLoop::exec (this=0xafe60228, flags=...) at kernel/qeventloop.cpp:204
#7  0xb723466c in QThread::exec (this=0x8642508) at thread/qthread.cpp:501
#8  0xb73277bd in QInotifyFileSystemWatcherEngine::run (this=0x8642508) at io/qfilesystemwatcher_inotify.cpp:248
#9  0xb7237a58 in QThreadPrivate::start (arg=0x8642508) at thread/qthread_unix.cpp:338
#10 0xb5610d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#11 0xb57abd3e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 2 (Thread 0xb21d8b40 (LWP 26971)):
#0  0xb5613d10 in pthread_mutex_unlock () from /lib/i386-linux-gnu/libpthread.so.0
#1  0xb57b98a4 in pthread_mutex_unlock () from /lib/i386-linux-gnu/libc.so.6
#2  0xb5524cc0 in g_mutex_unlock () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb54e37ba in g_main_context_check () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb54e3c92 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb54e3e61 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#6  0xb737c99f in QEventDispatcherGlib::processEvents (this=0xb087f208, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#7  0xb734926c in QEventLoop::processEvents (this=this@entry=0xb21d8238, flags=...) at kernel/qeventloop.cpp:149
#8  0xb7349561 in QEventLoop::exec (this=0xb21d8238, flags=...) at kernel/qeventloop.cpp:204
#9  0xb723466c in QThread::exec (this=0x850b038) at thread/qthread.cpp:501
#10 0xb6583649 in ?? () from /usr/lib/libkimap.so.4
#11 0xb7237a58 in QThreadPrivate::start (arg=0x850b038) at thread/qthread_unix.cpp:338
#12 0xb5610d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#13 0xb57abd3e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 1 (Thread 0xb4a41740 (LWP 26962)):
[KCrash Handler]
#6  0xb73627a9 in QObject::disconnect (sender=0x8330030, signal=0x80ac464 "2stateChanged(KIMAP::Session::State,KIMAP::Session::State)", receiver=0x831d008, method=0x80ac420 "1onSessionStateChanged(KIMAP::Session::State,KIMAP::Session::State)") at kernel/qobject.cpp:2891
#7  0x08099f2d in SessionPool::killSession (this=this@entry=0x831d008, session=0x8330030, termination=termination@entry=SessionPool::LogoutSession) at ../../../resources/imap/sessionpool.cpp:176
#8  0x0809a324 in SessionPool::disconnect (this=0x831d008, termination=SessionPool::LogoutSession) at ../../../resources/imap/sessionpool.cpp:117
#9  0x0805c113 in ImapResource::doSetOnline (this=0x8414e48, online=false) at ../../../resources/imap/imapresource.cpp:456
#10 0xb75921a8 in Akonadi::AgentBase::setOnline(bool) () from /usr/lib/libakonadi-kde.so.4
#11 0x0805a50f in ImapResource::reconnect (this=0x8414e48) at ../../../resources/imap/imapresource.cpp:483
#12 0xb76f12b7 in ?? () from /usr/lib/libakonadi-kde.so.4
#13 0xb76f139c in ?? () from /usr/lib/libakonadi-kde.so.4
#14 0xb74d26ae in QDBusConnectionPrivate::deliverCall (this=0x8349580, object=0x8413cf8, msg=..., metaTypes=..., slotIdx=1) at qdbusintegrator.cpp:947
#15 0xb74d3834 in QDBusConnectionPrivate::activateCall (this=0x8349580, object=0x8413cf8, flags=273, msg=...) at qdbusintegrator.cpp:857
#16 0xb74d3f12 in QDBusConnectionPrivate::activateObject (this=0x8349580, node=..., msg=..., pathStartPos=138412801) at qdbusintegrator.cpp:1423
#17 0xb74d4308 in QDBusActivateObjectEvent::placeMetaCall (this=0x8522f58) at qdbusintegrator.cpp:1537
#18 0xb7360eeb in QObject::event (this=0x8414e48, e=0x8522f58) at kernel/qobject.cpp:1195
#19 0xb683b39c in QApplicationPrivate::notify_helper (this=0x82cae28, receiver=0x8414e48, e=0x8522f58) at kernel/qapplication.cpp:4562
#20 0xb683fdaf in QApplication::notify (this=0x8522f58, receiver=0x8414e48, e=0x8522f58) at kernel/qapplication.cpp:3944
#21 0xb5e16e91 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#22 0xb734a78e in QCoreApplication::notifyInternal (this=0xbfbea9b4, receiver=0x8414e48, event=0x8522f58) at kernel/qcoreapplication.cpp:915
#23 0xb734e97d in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#24 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x82a6af0) at kernel/qcoreapplication.cpp:1539
#25 0xb734ec0c in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1432
#26 0xb737c804 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#27 postEventSourceDispatch (s=0x82c21c0) at kernel/qeventdispatcher_glib.cpp:279
#28 0xb54e39e3 in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#29 0xb54e3d80 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#30 0xb54e3e61 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#31 0xb737c981 in QEventDispatcherGlib::processEvents (this=0x82a7850, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#32 0xb68f19aa in QGuiEventDispatcherGlib::processEvents (this=0x82a7850, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#33 0xb734926c in QEventLoop::processEvents (this=this@entry=0xbfbea918, flags=...) at kernel/qeventloop.cpp:149
#34 0xb7349561 in QEventLoop::exec (this=0xbfbea918, flags=...) at kernel/qeventloop.cpp:204
#35 0xb734ecba in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1187
#36 0xb6838fc4 in QApplication::exec () at kernel/qapplication.cpp:3823
#37 0xb766e611 in Akonadi::ResourceBase::init(Akonadi::ResourceBase*) () from /usr/lib/libakonadi-kde.so.4
#38 0x0805ecbb in Akonadi::ResourceBase::init<ImapResource> (argc=argc@entry=3, argv=argv@entry=0xbfbeaa94) at /usr/include/akonadi/resourcebase.h:188
#39 0x0805896b in main (argc=3, argv=0xbfbeaa94) at ../../../resources/imap/imapresource.cpp:652

This bug may be a duplicate of or related to bug 288268.

Possible duplicates by query: bug 308641, bug 308602, bug 307673, bug 306819, bug 306040.

Reported using DrKonqi
Comment 1 Jekyll Wu 2013-02-26 03:05:25 UTC
See See https://bugs.kde.org/show_bug.cgi?id=312057#c2

*** This bug has been marked as a duplicate of bug 312057 ***