Bug 320624 - Kwin crash while viewing Okular(presentation mode)
Summary: Kwin crash while viewing Okular(presentation mode)
Status: RESOLVED DUPLICATE of bug 252817
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: 4.9.5
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-02 17:37 UTC by Drsnake_9
Modified: 2013-06-02 17:50 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Drsnake_9 2013-06-02 17:37:03 UTC
Application: kwin (4.9.5)
KDE Platform Version: 4.9.5
Qt Version: 4.8.3
Operating System: Linux 3.5.0-32-generic x86_64
Distribution: Ubuntu 12.10

-- Information about the crash:
- What I was doing when the application crashed:

Viewing a document in presentation mode. I was using Okular.

The crash can be reproduced every time.

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fc78b19f780 (LWP 15326))]

Thread 3 (Thread 0x7fc783527700 (LWP 15329)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fc79b144cd7 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#2  0x00007fc79b144d09 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#3  0x00007fc793248e9a in start_thread (arg=0x7fc783527700) at pthread_create.c:308
#4  0x00007fc79e21bccd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fc781490700 (LWP 15336)):
#0  0x00007fc79e215033 in select () at ../sysdeps/unix/syscall-template.S:82
#1  0x00007fc799ec3023 in qt_safe_select (nfds=16, fdread=0x7fc778000ac8, fdwrite=0x7fc778000d60, fdexcept=0x7fc778000ff8, orig_timeout=0x0) at kernel/qcore_unix.cpp:83
#2  0x00007fc799ec79e4 in QEventDispatcherUNIXPrivate::doSelect (this=this@entry=0x7fc778000910, flags=..., timeout=0x0) at kernel/qeventdispatcher_unix.cpp:223
#3  0x00007fc799ec8572 in QEventDispatcherUNIX::processEvents (this=0x7fc7780008f0, flags=...) at kernel/qeventdispatcher_unix.cpp:926
#4  0x00007fc799e962bf in QEventLoop::processEvents (this=this@entry=0x7fc78148fdd0, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fc799e96548 in QEventLoop::exec (this=0x7fc78148fdd0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007fc799d97b10 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007fc799e769af in QInotifyFileSystemWatcherEngine::run (this=0x1c211b0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007fc799d9aaec in QThreadPrivate::start (arg=0x1c211b0) at thread/qthread_unix.cpp:338
#9  0x00007fc793248e9a in start_thread (arg=0x7fc781490700) at pthread_create.c:308
#10 0x00007fc79e21bccd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fc78b19f780 (LWP 15326)):
[KCrash Handler]
#6  brw_update_renderbuffer_surface (brw=0x2543b00, rb=0x1857320, unit=0) at brw_wm_surface_state.c:1165
#7  0x00007fc7800bcd50 in brw_update_renderbuffer_surfaces (brw=0x2543b00) at brw_wm_surface_state.c:1261
#8  0x00007fc7800a6e92 in brw_upload_state (brw=brw@entry=0x2543b00) at brw_state_upload.c:500
#9  0x00007fc7800943d7 in brw_try_draw_prims (max_index=3, min_index=174717416, ib=<optimized out>, nr_prims=<optimized out>, prim=0x7fff0a69f9d0, arrays=<optimized out>, ctx=0x2543b00) at brw_draw.c:493
#10 brw_draw_prims (ctx=0x2543b00, prim=0x7fff0a69f9d0, nr_prims=<optimized out>, ib=<optimized out>, index_bounds_valid=<optimized out>, min_index=0, max_index=3, tfb_vertcount=0x0) at brw_draw.c:589
#11 0x00007fc773ba6d44 in vbo_draw_arrays (ctx=0x2543b00, mode=mode@entry=6, start=start@entry=0, count=count@entry=4, numInstances=numInstances@entry=1, baseInstance=baseInstance@entry=0) at ../../../../../src/mesa/vbo/vbo_exec_array.c:645
#12 0x00007fc773ba6e51 in vbo_exec_DrawArrays (mode=mode@entry=6, start=start@entry=0, count=count@entry=4) at ../../../../../src/mesa/vbo/vbo_exec_array.c:675
#13 0x00007fc773ba70b5 in _mesa_DrawArrays (mode=mode@entry=6, first=first@entry=0, count=count@entry=4) at ../../../../../src/mesa/vbo/vbo_exec_array.c:1441
#14 0x00007fc773c4e028 in _mesa_meta_glsl_Clear (ctx=ctx@entry=0x2543b00, buffers=buffers@entry=2) at ../../../../../src/mesa/drivers/common/meta.c:2091
#15 0x00007fc780089503 in brw_clear (mask=0, ctx=0x2543b00) at brw_clear.c:239
#16 brw_clear (ctx=0x2543b00, mask=<optimized out>) at brw_clear.c:208
#17 0x00007fc79e5a746c in KWin::SceneOpenGL::paintBackground (this=this@entry=0x185d0e0, region=...) at ../../kwin/scene_opengl.cpp:186
#18 0x00007fc79e5963ff in KWin::Scene::paintGenericScreen (this=0x185d0e0, orig_mask=32) at ../../kwin/scene.cpp:200
#19 0x00007fc79e5a322b in KWin::SceneOpenGL::paintGenericScreen (this=0x185d0e0, mask=32, data=...) at ../../kwin/scene_opengl.cpp:173
#20 0x00007fc79e594fca in KWin::Scene::finalPaintScreen (this=0x185d0e0, mask=32, region=..., data=...) at ../../kwin/scene.cpp:190
#21 0x00007fc79e5b45b3 in KWin::EffectsHandlerImpl::paintScreen (this=0x2801680, mask=mask@entry=32, region=..., data=...) at ../../kwin/effects.cpp:246
#22 0x00007fc79ca06bf7 in KWin::Effect::paintScreen (this=this@entry=0x2b1cd90, mask=mask@entry=32, region=..., data=...) at ../../../kwin/libkwineffects/kwineffects.cpp:142
#23 0x00007fc79e5b455b in KWin::EffectsHandlerImpl::paintScreen (this=0x2801680, mask=mask@entry=32, region=..., data=...) at ../../kwin/effects.cpp:243
#24 0x00007fc79ca06bf7 in KWin::Effect::paintScreen (this=this@entry=0x2bc52a0, mask=mask@entry=32, region=..., data=...) at ../../../kwin/libkwineffects/kwineffects.cpp:142
#25 0x00007fc79e5b455b in KWin::EffectsHandlerImpl::paintScreen (this=0x2801680, mask=mask@entry=32, region=..., data=...) at ../../kwin/effects.cpp:243
#26 0x00007fc79ca06bf7 in KWin::Effect::paintScreen (this=this@entry=0x28a2740, mask=mask@entry=32, region=..., data=...) at ../../../kwin/libkwineffects/kwineffects.cpp:142
#27 0x00007fc79e5b455b in KWin::EffectsHandlerImpl::paintScreen (this=0x2801680, mask=mask@entry=32, region=..., data=...) at ../../kwin/effects.cpp:243
#28 0x00007fc79ca06bf7 in KWin::Effect::paintScreen (this=this@entry=0x2b196f0, mask=mask@entry=32, region=..., data=...) at ../../../kwin/libkwineffects/kwineffects.cpp:142
#29 0x00007fc79e5b455b in KWin::EffectsHandlerImpl::paintScreen (this=0x2801680, mask=32, region=..., data=...) at ../../kwin/effects.cpp:243
#30 0x00007fc79e5965bb in KWin::Scene::paintScreen (this=0x185d0e0, mask=0x7fff0a6a023c, region=0x7fff0a6a02e0) at ../../kwin/scene.cpp:146
#31 0x00007fc79e5ab17d in KWin::SceneOpenGL::paint (this=0x185d0e0, damage=..., toplevels=...) at ../../kwin/scene_opengl_glx.cpp:499
#32 0x00007fc79e5902b8 in KWin::Workspace::performCompositing (this=0x17c37d0) at ../../kwin/composite.cpp:443
#33 0x00007fc799eac26c in QObject::event (this=0x17c37d0, e=<optimized out>) at kernel/qobject.cpp:1157
#34 0x00007fc79923ee9c in QApplicationPrivate::notify_helper (this=this@entry=0x168f6e0, receiver=receiver@entry=0x17c37d0, e=e@entry=0x7fff0a6a09c0) at kernel/qapplication.cpp:4562
#35 0x00007fc79924330a in QApplication::notify (this=0x7fff0a6a1000, receiver=0x17c37d0, e=0x7fff0a6a09c0) at kernel/qapplication.cpp:4423
#36 0x00007fc79dd0a1f6 in KApplication::notify (this=0x7fff0a6a1000, receiver=0x17c37d0, event=0x7fff0a6a09c0) at ../../kdeui/kernel/kapplication.cpp:311
#37 0x00007fc799e9756e in QCoreApplication::notifyInternal (this=0x7fff0a6a1000, receiver=0x17c37d0, event=0x7fff0a6a09c0) at kernel/qcoreapplication.cpp:915
#38 0x00007fc799ec8462 in sendEvent (event=0x7fff0a6a09c0, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#39 QTimerInfoList::activateTimers (this=0x1690298) at kernel/qeventdispatcher_unix.cpp:611
#40 0x00007fc799ec84c0 in QEventDispatcherUNIX::activateTimers (this=this@entry=0x1623ad0) at kernel/qeventdispatcher_unix.cpp:868
#41 0x00007fc799ec8618 in QEventDispatcherUNIX::processEvents (this=0x1623ad0, flags=...) at kernel/qeventdispatcher_unix.cpp:930
#42 0x00007fc7992e4a3f in QEventDispatcherX11::processEvents (this=0x1623ad0, flags=...) at kernel/qeventdispatcher_x11.cpp:152
#43 0x00007fc799e962bf in QEventLoop::processEvents (this=this@entry=0x7fff0a6a0d10, flags=...) at kernel/qeventloop.cpp:149
#44 0x00007fc799e96548 in QEventLoop::exec (this=0x7fff0a6a0d10, flags=...) at kernel/qeventloop.cpp:204
#45 0x00007fc799e9b708 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1187
#46 0x00007fc79e549ec4 in kdemain (argc=3, argv=0x7fff0a6a1148) at ../../kwin/main.cpp:545
#47 0x00007fc79e14976d in __libc_start_main (main=0x4006a0 <main(int, char**)>, argc=3, ubp_av=0x7fff0a6a1148, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff0a6a1138) at libc-start.c:226
#48 0x00000000004006d1 in _start ()

Possible duplicates by query: bug 319758, bug 319007, bug 317796, bug 317761, bug 317594.

Reported using DrKonqi
Comment 1 Thomas Lübking 2013-06-02 17:50:01 UTC
driver bug.
to workaround, run "kcmshell4 kwincompositing" and on the third tab disable "suspend compositing for fullscreen window" (which is very likely the inducing action)

*** This bug has been marked as a duplicate of bug 252817 ***