Bug 317594 - Не включается OpenGL для рабочего стола
Summary: Не включается OpenGL для рабочего стола
Status: RESOLVED DUPLICATE of bug 252817
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: 4.9.2
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-30 09:50 UTC by Karelin Pavel
Modified: 2013-03-30 10:15 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Karelin Pavel 2013-03-30 09:50:16 UTC
Application: kwin (4.9.2)
KDE Platform Version: 4.9.2
Qt Version: 4.8.3
Operating System: Linux 3.5.0-17-generic x86_64
Distribution: Ubuntu 12.10

-- Information about the crash:
Не включается OpenGL для рабочего стола. При этом наблюдается сильное подтормаживание при перерисовке окон. После перезагрузки системы - настройки сбрасываются в режим XRender. Так же система выдает информационное сообщение о невозможности задействовать OpenGL.

The crash can be reproduced every time.

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[KCrash Handler]
#6  0x00007ffabb97f0ef in brw_update_renderbuffer_surface (brw=0x26b2a90, rb=0x2556650, unit=0) at brw_wm_surface_state.c:1111
#7  0x00007ffabb97eaa0 in intel_renderbuffer (rb=0xf000200) at ../../../../../../../src/mesa/drivers/dri/intel/intel_fbo.h:94
#8  brw_update_renderbuffer_surfaces (brw=0x26b2a90) at brw_wm_surface_state.c:1204
#9  0x00007ffabb968ae2 in check_state (b=0x18, a=0x26c90fc) at brw_state_upload.c:295
#10 brw_upload_state (brw=0x26b2a90) at brw_state_upload.c:497
#11 0x00007ffabb9561d7 in trim (length=40670288, prim=0) at brw_draw.c:141
#12 brw_emit_prim (hw_prim=<optimized out>, prim=0x7fffb68a9a50, brw=0x26b2a90) at brw_draw.c:173
#13 brw_try_draw_prims (max_index=119, min_index=3062536808, ib=<optimized out>, nr_prims=<optimized out>, prim=0x7fffb68a9a50, arrays=<optimized out>, ctx=0x26b2a90) at brw_draw.c:499
#14 brw_draw_prims (ctx=0x26b2a90, prim=0x7fffb68a9a50, nr_prims=<optimized out>, ib=<optimized out>, index_bounds_valid=<optimized out>, min_index=0, max_index=119, tfb_vertcount=0x0) at brw_draw.c:589
#15 0x00007ffabb4d5b54 in ?? ()
#16 0x00007ffa00000077 in ?? ()
#17 0x0000000000000000 in ?? ()

This bug may be a duplicate of or related to bug 252817.

Possible duplicates by query: bug 252817.

Reported using DrKonqi
Comment 1 Martin Flöser 2013-03-30 10:15:26 UTC

*** This bug has been marked as a duplicate of bug 252817 ***