Bug 320557 - Kontact crash on restart
Summary: Kontact crash on restart
Status: RESOLVED UNMAINTAINED
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.10.3
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-31 22:39 UTC by rjwgnr27
Modified: 2017-01-07 22:48 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (9.68 KB, text/plain)
2013-09-26 01:49 UTC, Socceroos
Details

Note You need to log in before you can comment on or make changes to this bug.
Description rjwgnr27 2013-05-31 22:39:40 UTC
Application: kontact (4.10.3)
KDE Platform Version: 4.10.3
Qt Version: 4.8.4
Operating System: Linux 3.8.13-100.fc17.x86_64 x86_64
Distribution: "Fedora release 17 (Beefy Miracle)"

-- Information about the crash:
After crashing due to 320556, unable to restart. Attempted twice, each time resulting in kontact crashing.

The crash can be reproduced sometimes.

-- Backtrace:
Application: Kontact (kontact), signal: Aborted
Using host libthread_db library "/lib64/libthread_db.so.1".
82	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[Current thread is 1 (Thread 0x7ffd20ff4880 (LWP 23312))]

Thread 3 (Thread 0x7ffd17145700 (LWP 23313)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:166
#1  0x00007ffd2289fa5d in WTF::TCMalloc_PageHeap::scavengerThread (this=0x7ffd23289ce0) at wtf/FastMalloc.cpp:2495
#2  0x00007ffd2289fb69 in WTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at wtf/FastMalloc.cpp:1618
#3  0x0000003cc1c07d14 in start_thread (arg=0x7ffd17145700) at pthread_create.c:309
#4  0x0000003cc10f168d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 2 (Thread 0x7ffd16844700 (LWP 23314)):
#0  0x0000003cc10e8bdf in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x0000003cc2c47af4 in g_main_context_poll (n_fds=1, fds=0x7ffd100029c0, timeout=8595, context=0x7ffd100009a0, priority=<optimized out>) at gmain.c:3440
#2  g_main_context_iterate (context=context@entry=0x7ffd100009a0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3141
#3  0x0000003cc2c47c14 in g_main_context_iteration (context=0x7ffd100009a0, may_block=1) at gmain.c:3207
#4  0x00000032a8da5eb6 in QEventDispatcherGlib::processEvents (this=0x7ffd100008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#5  0x00000032a8d7651f in QEventLoop::processEvents (this=this@entry=0x7ffd16843d00, flags=...) at kernel/qeventloop.cpp:149
#6  0x00000032a8d767a8 in QEventLoop::exec (this=0x7ffd16843d00, flags=...) at kernel/qeventloop.cpp:204
#7  0x00000032a8c78970 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:542
#8  0x00000032a8c7b94c in QThreadPrivate::start (arg=0x16951f0) at thread/qthread_unix.cpp:338
#9  0x0000003cc1c07d14 in start_thread (arg=0x7ffd16844700) at pthread_create.c:309
#10 0x0000003cc10f168d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 1 (Thread 0x7ffd20ff4880 (LWP 23312)):
[KCrash Handler]
#6  0x0000003cc1035935 in __GI_raise (sig=sig@entry=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#7  0x0000003cc10370e8 in __GI_abort () at abort.c:91
#8  0x0000003cc1074e8b in __libc_message (do_abort=do_abort@entry=2, fmt=fmt@entry=0x3cc1178928 "*** glibc detected *** %s: %s: 0x%s ***\n") at ../sysdeps/unix/sysv/linux/libc_fatal.c:198
#9  0x0000003cc107c00e in malloc_printerr (ptr=0x22caef0, str=0x3cc1178a38 "free(): invalid next size (fast)", action=3) at malloc.c:5027
#10 _int_free (av=0x3cc13b0720, p=0x22caee0, have_lock=0) at malloc.c:3948
#11 0x00000032a9623a75 in free (alignment=8, x=<optimized out>) at ../../src/corelib/tools/qvector.h:99
#12 free (x=<optimized out>, this=<optimized out>) at ../../src/corelib/tools/qvector.h:468
#13 operator= (v=..., this=0x2259850) at ../../src/corelib/tools/qvector.h:395
#14 clear (this=0x2259850) at ../../src/corelib/tools/qvector.h:348
#15 QTextEngine::clearLineData (this=0x2259850) at text/qtextengine.cpp:1483
#16 0x00000032a966c58d in QTextDocumentLayout::documentChanged (this=0x1dd8300, from=0, oldLength=0, length=1839) at text/qtextdocumentlayout.cpp:2869
#17 0x00000032a982ea4c in QTextEditPrivate::relayoutDocument (this=this@entry=0x2553480) at widgets/qtextedit.cpp:1438
#18 0x00000032a982f259 in QTextEdit::resizeEvent (this=<optimized out>, e=0x7fff8cd4d1c0) at widgets/qtextedit.cpp:1397
#19 0x00000032a941a0f5 in QWidget::event (this=0x241d820, event=0x7fff8cd4d1c0) at kernel/qwidget.cpp:8540
#20 0x00000032a97c46e6 in QFrame::event (this=0x241d820, e=0x7fff8cd4d1c0) at widgets/qframe.cpp:557
#21 0x00000032a8d779d6 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<optimized out>, receiver=0x1fb58e0, event=0x7fff8cd4d1c0) at kernel/qcoreapplication.cpp:1059
#22 0x00000032a93ca57c in QApplicationPrivate::notify_helper (this=this@entry=0x16875f0, receiver=receiver@entry=0x1fb58e0, e=e@entry=0x7fff8cd4d1c0) at kernel/qapplication.cpp:4558
#23 0x00000032a93cea2a in QApplication::notify (this=0x7fff8cd4f6d0, receiver=0x1fb58e0, e=0x7fff8cd4d1c0) at kernel/qapplication.cpp:4423
#24 0x0000003491646f06 in KApplication::notify (this=0x7fff8cd4f6d0, receiver=0x1fb58e0, event=0x7fff8cd4d1c0) at /usr/src/debug/kdelibs-4.10.3/kdeui/kernel/kapplication.cpp:311
#25 0x00000032a8d7786e in QCoreApplication::notifyInternal (this=0x7fff8cd4f6d0, receiver=0x1fb58e0, event=0x7fff8cd4d1c0) at kernel/qcoreapplication.cpp:949
#26 0x00000032a94146c6 in sendEvent (event=0x7fff8cd4d1c0, receiver=0x1fb58e0) at ../../src/corelib/kernel/qcoreapplication.h:231
#27 QWidgetPrivate::sendPendingMoveAndResizeEvents (this=this@entry=0x22479a0, recursive=recursive@entry=false, disableUpdates=<optimized out>, disableUpdates@entry=false) at kernel/qwidget.cpp:7445
#28 0x00000032a941c061 in QWidgetPrivate::show_helper (this=this@entry=0x22479a0) at kernel/qwidget.cpp:7496
#29 0x00000032a941c462 in QWidget::setVisible (this=0x1fb58e0, visible=<optimized out>) at kernel/qwidget.cpp:7777
#30 0x00000032a941bffe in show (this=0x1fb58e0) at ../../src/gui/kernel/qwidget.h:494
#31 QWidgetPrivate::showChildren (this=this@entry=0x2553480, spontaneous=spontaneous@entry=false) at kernel/qwidget.cpp:7865
#32 0x00000032a941c07d in QWidgetPrivate::show_helper (this=this@entry=0x2553480) at kernel/qwidget.cpp:7502
#33 0x00000032a941c462 in QWidget::setVisible (this=0x241d820, visible=<optimized out>) at kernel/qwidget.cpp:7777
#34 0x00000032a941bffe in show (this=0x241d820) at ../../src/gui/kernel/qwidget.h:494
#35 QWidgetPrivate::showChildren (this=this@entry=0x1f97100, spontaneous=spontaneous@entry=false) at kernel/qwidget.cpp:7865
#36 0x00000032a941c07d in QWidgetPrivate::show_helper (this=this@entry=0x1f97100) at kernel/qwidget.cpp:7502
#37 0x00000032a941c462 in QWidget::setVisible (this=0x2145510, visible=<optimized out>) at kernel/qwidget.cpp:7777
#38 0x00000032a941bffe in show (this=0x2145510) at ../../src/gui/kernel/qwidget.h:494
#39 QWidgetPrivate::showChildren (this=this@entry=0x2145240, spontaneous=spontaneous@entry=false) at kernel/qwidget.cpp:7865
#40 0x00000032a941c07d in QWidgetPrivate::show_helper (this=this@entry=0x2145240) at kernel/qwidget.cpp:7502
#41 0x00000032a941c462 in QWidget::setVisible (this=0x1f1c9a0, visible=<optimized out>) at kernel/qwidget.cpp:7777
#42 0x00000032a941bffe in show (this=0x1f1c9a0) at ../../src/gui/kernel/qwidget.h:494
#43 QWidgetPrivate::showChildren (this=this@entry=0x1fc2680, spontaneous=spontaneous@entry=false) at kernel/qwidget.cpp:7865
#44 0x00000032a941c07d in QWidgetPrivate::show_helper (this=this@entry=0x1fc2680) at kernel/qwidget.cpp:7502
#45 0x00000032a941c462 in QWidget::setVisible (this=0x226bab0, visible=<optimized out>) at kernel/qwidget.cpp:7777
#46 0x00000032a941bffe in show (this=0x226bab0) at ../../src/gui/kernel/qwidget.h:494
#47 QWidgetPrivate::showChildren (this=this@entry=0x1f1c760, spontaneous=spontaneous@entry=false) at kernel/qwidget.cpp:7865
#48 0x00000032a941c07d in QWidgetPrivate::show_helper (this=this@entry=0x1f1c760) at kernel/qwidget.cpp:7502
#49 0x00000032a941c462 in QWidget::setVisible (this=0x2019390, visible=<optimized out>) at kernel/qwidget.cpp:7777
#50 0x00000032a941bffe in show (this=0x2019390) at ../../src/gui/kernel/qwidget.h:494
#51 QWidgetPrivate::showChildren (this=this@entry=0x1f23190, spontaneous=spontaneous@entry=false) at kernel/qwidget.cpp:7865
#52 0x00000032a941c07d in QWidgetPrivate::show_helper (this=this@entry=0x1f23190) at kernel/qwidget.cpp:7502
#53 0x00000032a941c462 in QWidget::setVisible (this=0x1a8d070, visible=<optimized out>) at kernel/qwidget.cpp:7777
#54 0x00000032a941bffe in show (this=0x1a8d070) at ../../src/gui/kernel/qwidget.h:494
#55 QWidgetPrivate::showChildren (this=this@entry=0x2019160, spontaneous=spontaneous@entry=false) at kernel/qwidget.cpp:7865
#56 0x00000032a941c07d in QWidgetPrivate::show_helper (this=this@entry=0x2019160) at kernel/qwidget.cpp:7502
#57 0x00000032a941c462 in QWidget::setVisible (this=0x1f9dbf0, visible=<optimized out>) at kernel/qwidget.cpp:7777
#58 0x00007ffccf4619b5 in KMKernel::recoverDeadLetters() () from /lib64/libkmailprivate.so.4
#59 0x00007ffccf7a4828 in ?? () from /usr/lib64/kde4/kmailpart.so
#60 0x00007ffccf7a5b8f in ?? () from /usr/lib64/kde4/kmailpart.so
#61 0x0000003493213285 in KPluginFactory::create (this=0x1ca1f40, iface=0x3490444340 "KParts::ReadOnlyPart", parentWidget=0x17d4d90, parent=0x17d4d90, args=..., keyword=...) at /usr/src/debug/kdelibs-4.10.3/kdecore/util/kpluginfactory.cpp:203
#62 0x000000349560f32f in create<KParts::ReadOnlyPart> (args=..., parent=0x17d4d90, this=<optimized out>) at /usr/include/kde4/kpluginfactory.h:507
#63 KontactInterface::Core::createPart (this=0x17d4d90, libname=0x1c699d8 "kmailpart") at /usr/src/debug/kdepimlibs-4.10.3/kontactinterface/core.cpp:87
#64 0x00007ffd14568750 in ?? () from /usr/lib64/kde4/kontact_kmailplugin.so
#65 0x0000003495611939 in KontactInterface::Plugin::part (this=0x1c4c070) at /usr/src/debug/kdepimlibs-4.10.3/kontactinterface/plugin.cpp:192
#66 0x00007ffd21052d1a in Kontact::MainWindow::selectPlugin(KontactInterface::Plugin*) () from /lib64/libkontactprivate.so.4
#67 0x00007ffd2104fdb4 in Kontact::MainWindow::loadSettings() () from /lib64/libkontactprivate.so.4
#68 0x00007ffd21052163 in Kontact::MainWindow::initObject() () from /lib64/libkontactprivate.so.4
#69 0x00007ffd2105277a in Kontact::MainWindow::MainWindow() () from /lib64/libkontactprivate.so.4
#70 0x0000000000403f84 in _start ()

This bug may be a duplicate of or related to bug 314682.

Possible duplicates by query: bug 320556, bug 320526, bug 320344, bug 320128, bug 319465.

Reported using DrKonqi
Comment 1 rjwgnr27 2013-05-31 22:55:14 UTC
The crash appears to be a result of kmail attempting to reopen the file from the original crash. Every attempt to restart kontact or kmail would result in this crash.

Deleting the recovery file in $HOME/.kde/share/apps/kmail2/autosave/\{*, I was able to successfully start kontact.
Comment 2 Socceroos 2013-09-26 01:49:05 UTC
Created attachment 82493 [details]
New crash information added by DrKonqi

kontact (4.11.1) on KDE Platform 4.11.1 using Qt 4.8.4

- What I was doing when the application crashed:

Exactly the same as described above. First crashed when trying to forward an email. Then every time I tried to restart Kontact it would crash.

-- Backtrace (Reduced):
#6  operator= (v=..., this=0x0) at ../../include/QtCore/../../src/corelib/tools/qvector.h:394
#7  clear (this=0x0) at ../../include/QtCore/../../src/corelib/tools/qvector.h:348
#8  QTextEngine::clearLineData (this=0x0) at text/qtextengine.cpp:1483
#9  0x00007f3f3a12b9d8 in QTextLayout::clearLayout (this=<optimized out>) at text/qtextlayout.cpp:658
#10 0x00007f3f3a13da5c in QTextBlock::clearLayout (this=this@entry=0x7fff5c64f6d0) at text/qtextobject.cpp:1084
Comment 3 Denis Kurz 2016-09-24 19:27:54 UTC
This bug has only been reported for versions before 4.14, which have been unsupported for at least two years now. Can anyone tell if this bug still present?

If noone confirms this bug for a Framework-based version of kontact (version 5.0 or later, as part of KDE Applications 15.08 or later), it gets closed in about three months.
Comment 4 Denis Kurz 2017-01-07 22:48:05 UTC
Just as announced in my last comment, I close this bug. If you encounter it again in a recent version (at least 5.0 aka 15.08), please open a new one unless it already exists. Thank you for all your input.