Bug 320556 - Kontact crash on forwarding an e-mail
Summary: Kontact crash on forwarding an e-mail
Status: RESOLVED UNMAINTAINED
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.10.3
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-31 22:33 UTC by rjwgnr27
Modified: 2017-01-07 22:22 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description rjwgnr27 2013-05-31 22:33:38 UTC
Application: kontact (4.10.3)
KDE Platform Version: 4.10.3
Qt Version: 4.8.4
Operating System: Linux 3.8.13-100.fc17.x86_64 x86_64
Distribution: "Fedora release 17 (Beefy Miracle)"

-- Information about the crash:
Attempted to forward an e-mail, using the 'f' key. Immediately upon pressing the 'f', kontact crashed.

-- Backtrace:
Application: Kontact (kontact), signal: Aborted
Using host libthread_db library "/lib64/libthread_db.so.1".
82	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[Current thread is 1 (Thread 0x7f9c5ec98880 (LWP 4607))]

Thread 4 (Thread 0x7f9c54bcd700 (LWP 4608)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:166
#1  0x00007f9c64f1ba5d in WTF::TCMalloc_PageHeap::scavengerThread (this=0x7f9c65905ce0) at wtf/FastMalloc.cpp:2495
#2  0x00007f9c64f1bb69 in WTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at wtf/FastMalloc.cpp:1618
#3  0x0000003cc1c07d14 in start_thread (arg=0x7f9c54bcd700) at pthread_create.c:309
#4  0x0000003cc10f168d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 3 (Thread 0x7f9c542cc700 (LWP 4609)):
#0  0x0000003cc2c47228 in g_main_context_prepare (context=context@entry=0x7f9c4c0009a0, priority=priority@entry=0x7f9c542cbba8) at gmain.c:2770
#1  0x0000003cc2c47a1b in g_main_context_iterate (context=context@entry=0x7f9c4c0009a0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3126
#2  0x0000003cc2c47c14 in g_main_context_iteration (context=0x7f9c4c0009a0, may_block=1) at gmain.c:3207
#3  0x00000032a8da5eb6 in QEventDispatcherGlib::processEvents (this=0x7f9c4c0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00000032a8d7651f in QEventLoop::processEvents (this=this@entry=0x7f9c542cbd00, flags=...) at kernel/qeventloop.cpp:149
#5  0x00000032a8d767a8 in QEventLoop::exec (this=0x7f9c542cbd00, flags=...) at kernel/qeventloop.cpp:204
#6  0x00000032a8c78970 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:542
#7  0x00000032a8c7b94c in QThreadPrivate::start (arg=0x98c9f0) at thread/qthread_unix.cpp:338
#8  0x0000003cc1c07d14 in start_thread (arg=0x7f9c542cc700) at pthread_create.c:309
#9  0x0000003cc10f168d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 2 (Thread 0x7f9bfaf8e700 (LWP 14663)):
#0  0x00007fff6a7fe70c in ?? ()
#1  0x00007fff6a7feac9 in clock_gettime ()
#2  0x0000003cc200410d in __GI_clock_gettime (clock_id=<optimized out>, tp=<optimized out>) at ../sysdeps/unix/clock_gettime.c:116
#3  0x00000032a8cd1884 in do_gettime (frac=0x7f9bfaf8da38, sec=0x7f9bfaf8da30) at tools/qelapsedtimer_unix.cpp:123
#4  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#5  0x00000032a8da67bd in QTimerInfoList::updateCurrentTime (this=this@entry=0x7f9bec002650) at kernel/qeventdispatcher_unix.cpp:354
#6  0x00000032a8da6b03 in QTimerInfoList::timerWait (this=0x7f9bec002650, tm=...) at kernel/qeventdispatcher_unix.cpp:461
#7  0x00000032a8da556c in timerSourcePrepareHelper (src=<optimized out>, timeout=0x7f9bfaf8db2c) at kernel/qeventdispatcher_glib.cpp:136
#8  0x00000032a8da5615 in timerSourcePrepare (source=source@entry=0x7f9bec0025f0, timeout=timeout@entry=0x7f9bfaf8db2c) at kernel/qeventdispatcher_glib.cpp:169
#9  0x0000003cc2c4732f in g_main_context_prepare (context=context@entry=0x7f9bec002c00, priority=priority@entry=0x7f9bfaf8db78) at gmain.c:2836
#10 0x0000003cc2c47a1b in g_main_context_iterate (context=context@entry=0x7f9bec002c00, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3126
#11 0x0000003cc2c47c14 in g_main_context_iteration (context=0x7f9bec002c00, may_block=1) at gmain.c:3207
#12 0x00000032a8da5eb6 in QEventDispatcherGlib::processEvents (this=0x7f9bec002460, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#13 0x00000032a8d7651f in QEventLoop::processEvents (this=this@entry=0x7f9bfaf8dcd0, flags=...) at kernel/qeventloop.cpp:149
#14 0x00000032a8d767a8 in QEventLoop::exec (this=0x7f9bfaf8dcd0, flags=...) at kernel/qeventloop.cpp:204
#15 0x00000032a8c78970 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:542
#16 0x00000032a8d56d3f in QInotifyFileSystemWatcherEngine::run (this=0x533db60) at io/qfilesystemwatcher_inotify.cpp:256
#17 0x00000032a8c7b94c in QThreadPrivate::start (arg=0x533db60) at thread/qthread_unix.cpp:338
#18 0x0000003cc1c07d14 in start_thread (arg=0x7f9bfaf8e700) at pthread_create.c:309
#19 0x0000003cc10f168d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 1 (Thread 0x7f9c5ec98880 (LWP 4607)):
[KCrash Handler]
#6  0x0000003cc1035935 in __GI_raise (sig=sig@entry=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#7  0x0000003cc10370e8 in __GI_abort () at abort.c:91
#8  0x0000003cc1074e8b in __libc_message (do_abort=do_abort@entry=2, fmt=fmt@entry=0x3cc1178928 "*** glibc detected *** %s: %s: 0x%s ***\n") at ../sysdeps/unix/sysv/linux/libc_fatal.c:198
#9  0x0000003cc107c00e in malloc_printerr (ptr=0x937d210, str=0x3cc1178a38 "free(): invalid next size (fast)", action=3) at malloc.c:5027
#10 _int_free (av=0x3cc13b0720, p=0x937d200, have_lock=0) at malloc.c:3948
#11 0x00000032a9623a75 in free (alignment=8, x=<optimized out>) at ../../src/corelib/tools/qvector.h:99
#12 free (x=<optimized out>, this=<optimized out>) at ../../src/corelib/tools/qvector.h:468
#13 operator= (v=..., this=0x94f8fb0) at ../../src/corelib/tools/qvector.h:395
#14 clear (this=0x94f8fb0) at ../../src/corelib/tools/qvector.h:348
#15 QTextEngine::clearLineData (this=0x94f8fb0) at text/qtextengine.cpp:1483
#16 0x00000032a966c58d in QTextDocumentLayout::documentChanged (this=0xa282e80, from=0, oldLength=0, length=1839) at text/qtextdocumentlayout.cpp:2869
#17 0x00000032a982ea4c in QTextEditPrivate::relayoutDocument (this=this@entry=0x9a88130) at widgets/qtextedit.cpp:1438
#18 0x00000032a982edfa in _q_adjustScrollbars (this=0x9a88130) at widgets/qtextedit.cpp:297
#19 QTextEditPrivate::_q_adjustScrollbars (this=0x9a88130) at widgets/qtextedit.cpp:258
#20 0x00000032a9831640 in qt_static_metacall (_a=<optimized out>, _id=<optimized out>, _o=<optimized out>, _c=<optimized out>) at .moc/release-shared/moc_qtextedit.cpp:212
#21 QTextEdit::qt_static_metacall (_o=0x11ff, _c=4607, _id=6, _a=0xffffffffffffffff) at .moc/release-shared/moc_qtextedit.cpp:165
#22 0x00000032a8d8cc8f in QMetaObject::activate (sender=0x963a0f0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff6a6a6fa0) at kernel/qobject.cpp:3539
#23 0x00000032a960e4a5 in QTextControl::documentSizeChanged (this=<optimized out>, _t1=...) at .moc/release-shared/moc_qtextcontrol_p.cpp:308
#24 0x00000032a9614f2d in qt_static_metacall (_a=<optimized out>, _id=<optimized out>, _o=<optimized out>, _c=<optimized out>) at .moc/release-shared/moc_qtextcontrol_p.cpp:139
#25 QTextControl::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qtextcontrol_p.cpp:124
#26 0x00000032a8d8cc8f in QMetaObject::activate (sender=0xa282e80, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff6a6a7110) at kernel/qobject.cpp:3539
#27 0x00000032a965c625 in QAbstractTextDocumentLayout::documentSizeChanged (this=<optimized out>, _t1=...) at .moc/release-shared/moc_qabstracttextdocumentlayout.cpp:136
#28 0x00000032a966c989 in QTextDocumentLayout::documentChanged (this=0xa282e80, from=<optimized out>, oldLength=1, length=0) at text/qtextdocumentlayout.cpp:2914
#29 0x00000032a964c404 in QTextDocumentPrivate::finishEdit (this=0x963a2a0) at text/qtextdocument_p.cpp:1220
#30 0x00000032a9672285 in removeSelectedText (this=<optimized out>) at text/qtextcursor.cpp:1662
#31 QTextCursor::removeSelectedText (this=0x7fff6a6a72e0) at text/qtextcursor.cpp:1655
#32 0x00007f9c60ab42a8 in KPIMTextEdit::TextEdit::loadImage (this=0xa27cf20, image=..., matchName=..., resourceName=...) at /usr/src/debug/kdepimlibs-4.10.3/kpimtextedit/textedit.cpp:517
#33 0x00007f9c09706588 in Message::ComposerViewBase::collectImages(KMime::Content*) () from /lib64/libmessagecomposer.so.4
#34 0x00007f9c0970e259 in Message::ComposerViewBase::setMessage(boost::shared_ptr<KMime::Message> const&) () from /lib64/libmessagecomposer.so.4
#35 0x00007f9c0a2dde17 in ?? () from /lib64/libkmailprivate.so.4
#36 0x00007f9c0a2e14f7 in ?? () from /lib64/libkmailprivate.so.4
#37 0x00007f9c0a2e24df in ?? () from /lib64/libkmailprivate.so.4
#38 0x00007f9c0a2792dd in KMForwardCommand::createComposer(Akonadi::Item const&) () from /lib64/libkmailprivate.so.4
#39 0x00007f9c0a27e8ba in KMForwardCommand::execute() () from /lib64/libkmailprivate.so.4
#40 0x00007f9c0a279cd1 in KMCommand::slotPostTransfer(KMCommand::Result) () from /lib64/libkmailprivate.so.4
#41 0x00000032a8d8cc8f in QMetaObject::activate (sender=0x29b18f0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff6a6a8460) at kernel/qobject.cpp:3539
#42 0x00007f9c0a279ade in KMCommand::messagesTransfered(KMCommand::Result) () from /lib64/libkmailprivate.so.4
#43 0x00007f9c0a27e03c in KMCommand::slotJobFinished() () from /lib64/libkmailprivate.so.4
#44 0x00000032a8d8cc8f in QMetaObject::activate (sender=0x1345aa0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff6a6a8610) at kernel/qobject.cpp:3539
#45 0x00007f9c61c634e2 in KJob::result (this=this@entry=0x1345aa0, _t1=_t1@entry=0x1345aa0) at /usr/src/debug/kdelibs-4.10.3/x86_64-redhat-linux-gnu/kdecore/kjob.moc:207
#46 0x00007f9c61c63520 in KJob::emitResult (this=0x1345aa0) at /usr/src/debug/kdelibs-4.10.3/kdecore/jobs/kjob.cpp:318
#47 0x00000032a8d8c16e in QObject::event (this=0x1345aa0, e=<optimized out>) at kernel/qobject.cpp:1194
#48 0x00000032a93ca5ac in QApplicationPrivate::notify_helper (this=this@entry=0x9815f0, receiver=receiver@entry=0x1345aa0, e=e@entry=0x5e16a40) at kernel/qapplication.cpp:4562
#49 0x00000032a93cea2a in QApplication::notify (this=0x7fff6a6a90b0, receiver=0x1345aa0, e=0x5e16a40) at kernel/qapplication.cpp:4423
#50 0x00007f9c62247f06 in KApplication::notify (this=0x7fff6a6a90b0, receiver=0x1345aa0, event=0x5e16a40) at /usr/src/debug/kdelibs-4.10.3/kdeui/kernel/kapplication.cpp:311
#51 0x00000032a8d7786e in QCoreApplication::notifyInternal (this=0x7fff6a6a90b0, receiver=receiver@entry=0x1345aa0, event=event@entry=0x5e16a40) at kernel/qcoreapplication.cpp:949
#52 0x00000032a8d7b321 in sendEvent (event=0x5e16a40, receiver=0x1345aa0) at kernel/qcoreapplication.h:231
#53 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x9444c0) at kernel/qcoreapplication.cpp:1573
#54 0x00000032a8da5d03 in sendPostedEvents () at kernel/qcoreapplication.h:236
#55 postEventSourceDispatch (s=s@entry=0x971c70) at kernel/qeventdispatcher_glib.cpp:279
#56 0x0000003cc2c47825 in g_main_dispatch (context=0x982d00) at gmain.c:2539
#57 g_main_context_dispatch (context=context@entry=0x982d00) at gmain.c:3075
#58 0x0000003cc2c47b58 in g_main_context_iterate (context=context@entry=0x982d00, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3146
#59 0x0000003cc2c47c14 in g_main_context_iteration (context=0x982d00, may_block=1) at gmain.c:3207
#60 0x00000032a8da5e96 in QEventDispatcherGlib::processEvents (this=0x945da0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#61 0x00000032a946a5ee in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:207
#62 0x00000032a8d7651f in QEventLoop::processEvents (this=this@entry=0x7fff6a6a8f20, flags=...) at kernel/qeventloop.cpp:149
#63 0x00000032a8d767a8 in QEventLoop::exec (this=0x7fff6a6a8f20, flags=...) at kernel/qeventloop.cpp:204
#64 0x00000032a8d7b638 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1221
#65 0x0000000000403439 in ?? ()
#66 0x0000003cc1021735 in __libc_start_main (main=0x402c40, argc=1, ubp_av=0x7fff6a6a91f8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff6a6a91e8) at libc-start.c:226
#67 0x00000000004039a1 in _start ()

This bug may be a duplicate of or related to bug 319465.

Possible duplicates by query: bug 320526, bug 320344, bug 320128, bug 319465, bug 318653.

Reported using DrKonqi
Comment 1 Denis Kurz 2016-09-24 19:23:47 UTC
This bug has only been reported for versions before 4.14, which have been unsupported for at least two years now. Can anyone tell if this bug still present?

If noone confirms this bug for a Framework-based version of kontact (version 5.0 or later, as part of KDE Applications 15.08 or later), it gets closed in about three months.
Comment 2 Denis Kurz 2017-01-07 22:22:05 UTC
Just as announced in my last comment, I close this bug. If you encounter it again in a recent version (at least 5.0 aka 15.08), please open a new one unless it already exists. Thank you for all your input.