Bug 320016 - Full-screen options are not applied after restarting digikam
Summary: Full-screen options are not applied after restarting digikam
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Usability-FullScreen (show other bugs)
Version: 3.2.0
Platform: openSUSE RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-19 16:12 UTC by Romain Henriet
Modified: 2017-08-04 12:14 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 3.3.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Romain Henriet 2013-05-19 16:12:56 UTC
When opening digikam and switching to full-screen view, side bars and toolbar are shown and thumbnail bar is hidden, despite what is checked in configuration dialog.
If you (un)check one of the "Hide ..." box of "Full-screen options", then full-screen view is like you want.

Reproducible: Always

Steps to Reproduce:
1. Run Digikam
2. Open Configuration dialog
3. In Album View, check "Hide toolbars" and "Hide sidebars", and uncheck "Hide thumbbar"
4. Close dialog
5. Open full-screen view : Toolbars are hidden, sidebars are hidden, thumbbar is shown :-)
6. Restart Digikam
7. Open full-screen view : Toolbars are shown, sidebars are shown, thumbbar is hidden :-(
Actual Results:  
Full-screen view is different from what is checked in configuration dialog
Comment 1 caulier.gilles 2013-05-19 16:21:55 UTC
It's probably due to changes in the way that settings is now stored in config file.

When you start a new session, problem disappear ?

It's not reproducible here...

Gilles Caulier
Comment 2 Romain Henriet 2013-05-19 18:04:57 UTC
Yes I created a new user and there is the same problem.
The configuration is saved correctly as the checkboxes are in the same state as I leaved them before restarting digikam. But it is simply not applied...
Comment 3 caulier.gilles 2013-05-19 18:16:12 UTC
Ah the problem is different. Settings is stored and restored between session. But you want to see digiKam started in fullscreen mode as well ?

If yes, as i rewritten and factored all code relevant to fullscreen mode, i see a lots of GUI problem to start in fullscreen mode directly an application. Especially under OSX, digiKam GUI is completely broken. Under Linux, it's less catastrophic but not perfect.

So i removed the way to quit digiKam in fullscreen mode and to restore it as well in this mode.

Gilles Caulier
Comment 4 Romain Henriet 2013-05-19 21:49:01 UTC
Je vais utiliser le français, je crois que ce sera plus simple.

1. En fait j'ai coché les cases "Hide toolbars", "Hide sidebars" et "Hide thumbbar" dans la fenêtre de configuration, 
2. Ainsi quand je bascule en plein écran, seule l'image est affichée (aucune barre d'outil/latérale, ça correspond bien à ce qui est coché).
3. Ensuite, je reviens en vue normale, je ferme digikam et je le relance. 
4. J'arrive alors sur la vue normale, jusque là ok, 
5. mais quand je demande un affichage en plein écran, les barres d'outils et les barre latérales s'affichent autour de l'image
6. Je reviens alors en vue normale et ouvre la fenêtre de configuration. Les 3 cases citées ci-dessus sont bien cochées, comme je les avais laissées
7. Je ne modifie donc rien et clique sur ok pour fermer la fenêtre de configuration
8. Et là si j'ouvre à nouveau le mode plein écran, j'obtiens bien l'affichage de l'étape 2

La configuration est donc bien conservée entre 2 lancements de digikam. D'ailleurs mon fichier digikamrc contient les 3 lignes "FullScreen Hide SideBars=true", "FullScreen Hide ThumbBar=true", "FullScreen Hide ToolBars=true". Par contre j'ai l'impression que ces paramètres ne sont pas appliqués automatiquement au lancement de l'application, et qu'il faut revalider la configuration avec le bouton Ok pour qu'ils soient pris en compte.
Comment 5 Alexander Stein 2013-05-20 10:15:02 UTC
(In reply to comment #3)
> Ah the problem is different. Settings is stored and restored between
> session. But you want to see digiKam started in fullscreen mode as well ?
> 
> If yes, as i rewritten and factored all code relevant to fullscreen mode, i
> see a lots of GUI problem to start in fullscreen mode directly an
> application. Especially under OSX, digiKam GUI is completely broken. Under
> Linux, it's less catastrophic but not perfect.

I think the problem is slightly different as you describe here.
My current settings for full-screen view:
[ ] Hide toolbars
[x] hide thumbbar
[x] hide sidebars

1. Start digikam ( get into album view from my select ed album)
2. enter full-screen view:
 * sidebars are shown and opened
 * toolbar is shown
 * thumbbar is hidden
3. quit fullscreen & enter digikam configuration
4. change nothing (!) and press 'OK'
5. enter full-screen again:
 * sidebars hidden
 * toolbar is shown
 * thumbbar is hidden

The effects a smaller than the ones Romain described in comment #1 because my toolbar and thumbbar settings match the ones digikam picks. But the sidebar setting is wrong after startup until i store/set a new one in the configuration.
It appears to me that digikam doesn't load the saved configuration properly.
Noticed this on Digikam 3.2.0 on Gentoo, while Digikam 3.1.0 in Arch doesn't show this behavior. Might be caused by the fact that full-screen settings just came with 3.2.
Comment 6 caulier.gilles 2013-05-20 10:28:10 UTC
As the full screen settings is managed in a common way now with 3.2.0 (it's not the case with previous version), can you check if other main digiKam windows give the same dysfunction, as :

-Light Table
-Image Editor
-Batch Queue Manager

Gilles Caulier
Comment 7 Romain Henriet 2013-05-20 15:51:30 UTC
Light table in full-screen view : toolbar, thumbbar and (In reply to comment #5)
> (In reply to comment #3)
> > Ah the problem is different. Settings is stored and restored between
> > session. But you want to see digiKam started in fullscreen mode as well ?
> > 
> > If yes, as i rewritten and factored all code relevant to fullscreen mode, i
> > see a lots of GUI problem to start in fullscreen mode directly an
> > application. Especially under OSX, digiKam GUI is completely broken. Under
> > Linux, it's less catastrophic but not perfect.
> 
> I think the problem is slightly different as you describe here.
> My current settings for full-screen view:
> [ ] Hide toolbars
> [x] hide thumbbar
> [x] hide sidebars
> 
> 1. Start digikam ( get into album view from my select ed album)
> 2. enter full-screen view:
>  * sidebars are shown and opened
>  * toolbar is shown
>  * thumbbar is hidden
> 3. quit fullscreen & enter digikam configuration
> 4. change nothing (!) and press 'OK'
> 5. enter full-screen again:
>  * sidebars hidden
>  * toolbar is shown
>  * thumbbar is hidden
> 
> The effects a smaller than the ones Romain described in comment #1 because
> my toolbar and thumbbar settings match the ones digikam picks. But the
> sidebar setting is wrong after startup until i store/set a new one in the
> configuration.
> It appears to me that digikam doesn't load the saved configuration properly.
> Noticed this on Digikam 3.2.0 on Gentoo, while Digikam 3.1.0 in Arch doesn't
> show this behavior. Might be caused by the fact that full-screen settings
> just came with 3.2.

Yes that's exactly the same for me, I may not have been clear enough in #1
Comment 8 Romain Henriet 2013-05-20 16:06:48 UTC
For me, full-screen settings don't seem to be applied for other windows, even after reloading configuration.
Comment 9 nucleo 2013-05-20 22:25:10 UTC
See also bug 319876 about panels and fullscreen mode.
Comment 10 caulier.gilles 2013-05-28 12:05:54 UTC
Git commit 439316380574b6dc8b3c3ed37efa1e74656c342f by Gilles Caulier.
Committed on 28/05/2013 at 14:01.
Pushed by cgilles into branch 'master'.

factoring everywhere Genreal config group used to store main windows settings in RC file
Ensure that full screen settings is loaded at initialization of AlbumGUI.
Related: bug 320371, bug 319876

M  +11   -9    digikam/main/digikamapp.cpp
M  +6    -6    digikam/utils/albumsettings.cpp
M  +1    -1    digikam/utils/albumsettings.h
M  +4    -4    utilities/setup/setupalbumview.cpp

http://commits.kde.org/digikam/439316380574b6dc8b3c3ed37efa1e74656c342f