Bug 319876 - Panels state changed after exit from full screen mode
Summary: Panels state changed after exit from full screen mode
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Usability-FullScreen (show other bugs)
Version: 3.2.0
Platform: Fedora RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-15 17:59 UTC by nucleo
Modified: 2017-08-04 12:13 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 3.3.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description nucleo 2013-05-15 17:59:58 UTC
Left and right side panels such as albums browser and file properties always opened after exit from full screen mode even if they was closed before switching to full screen.

Reproducible: Always

Steps to Reproduce:
1. Start digiKam.
2. Open Album.
3. Close Albums browser panel at left and File properties at right.
4. Switch to full screen mode Ctrl+Shift+F
5. Switch back with Ctrl+Shift+F
Actual Results:  
Album and file properties panel opened after exit from full screen.

Expected Results:  
Panels state after exit from fullscreen mode should be the same as before switching to full screen.

In digiKam 3.1.0 fullscreen mode was with closed left and right side panels, but in 3.2.0 if panels was opened before full screen they stay opened also after Ctrl+Shift+F.
Comment 1 nucleo 2013-05-15 18:09:35 UTC
The same problem in showFoto, file properties always opened after fullscreen.
Comment 2 caulier.gilles 2013-05-28 12:05:54 UTC
Git commit 439316380574b6dc8b3c3ed37efa1e74656c342f by Gilles Caulier.
Committed on 28/05/2013 at 14:01.
Pushed by cgilles into branch 'master'.

factoring everywhere Genreal config group used to store main windows settings in RC file
Ensure that full screen settings is loaded at initialization of AlbumGUI.
Related: bug 320371, bug 320016

M  +11   -9    digikam/main/digikamapp.cpp
M  +6    -6    digikam/utils/albumsettings.cpp
M  +1    -1    digikam/utils/albumsettings.h
M  +4    -4    utilities/setup/setupalbumview.cpp

http://commits.kde.org/digikam/439316380574b6dc8b3c3ed37efa1e74656c342f
Comment 3 nucleo 2013-05-28 12:09:58 UTC
Commit from Comment 2 fixes problem in showFoto?
Comment 4 caulier.gilles 2013-05-28 12:16:11 UTC
No, you have right. I take a look..

Can you confirm that problem is fixed in digiKam ?

Gilles Caulier
Comment 5 caulier.gilles 2013-05-28 12:22:11 UTC
Well, Showfoto full screen settings is always read at startup through readSettings() method. 
The problem do not must present in Showfoto...

Gilles Caulier
Comment 6 caulier.gilles 2013-05-28 12:25:33 UTC
Problem not reproducible in digiKam and Showfoto, as explained in original report...

Gilles Caulier
Comment 7 nucleo 2013-05-28 17:55:34 UTC
This bug still not fixed.
If "Hide sidebars" option unchecked in digiKam and showFoto and I close sidebars and then go to fullscrenn and then back sidebars again became opened.
But if "Hide sidebars" enabled then no such problem.
Comment 8 caulier.gilles 2013-05-28 21:45:15 UTC
Right reproducible now.
Comment 9 caulier.gilles 2013-05-29 09:19:03 UTC
Damned, on my second computer (32 bits) running in VirtualBox, with same Linux distro, the bug is not reproducible...

Gilles Caulier
Comment 10 caulier.gilles 2013-05-29 09:21:24 UTC
Note : it's not reproducible in digiKam Album GUI, but reproducible in Showfoto.

Gilles Caulier
Comment 11 caulier.gilles 2013-05-29 09:23:19 UTC
It's also reproducible in digiKam Image Editor.

It's sound logic, because Showfoto and IE share same code...

Gilles Caulier
Comment 12 caulier.gilles 2013-05-29 09:24:22 UTC
It's also reproducible in Light Table...
Comment 13 caulier.gilles 2013-05-29 09:26:31 UTC
Its' reproducible in ImportUI too...
Comment 14 caulier.gilles 2013-05-29 11:35:56 UTC
Git commit b8f20122e42acb5424cba7aff034101f068c5a90 by Gilles Caulier.
Committed on 29/05/2013 at 13:33.
Pushed by cgilles into branch 'master'.

Sidebar: manage  properly shrink state when backup() and restore() are called.
DXmlGuiWindow: call sidebar restore method only if FS option is turn on.

M  +2    -1    libs/widgets/common/dxmlguiwindow.cpp
M  +12   -9    libs/widgets/common/sidebar.cpp
M  +1    -1    libs/widgets/common/sidebar.h

http://commits.kde.org/digikam/b8f20122e42acb5424cba7aff034101f068c5a90
Comment 15 nucleo 2013-05-29 14:45:21 UTC
Now all fullscreen and sidebar problems fixed.
Comment 16 nucleo 2013-05-29 20:53:32 UTC
There is old similar bug with Thumbbar.
If enabled option "Hide thumbbar" and I switch to fullscreen from  "Thumbnails view" mode,  then switch to "Preview image" mode, then exit fullscreen mode then Thumbbar will be not shown above "Preview image".
Comment 17 caulier.gilles 2013-05-30 08:29:14 UTC
Point #16 Fixed with commit this commit :

http://commits.kde.org/digikam/4f892fb62241940fd2a0ceeffa1d2302576611d8

Gilles Caulier
Comment 18 nucleo 2013-05-30 12:45:17 UTC
(In reply to comment #17)
> Point #16 Fixed with commit this commit :
> 
> http://commits.kde.org/digikam/4f892fb62241940fd2a0ceeffa1d2302576611d8
> 
> Gilles Caulier

With this patch thumbbar shown after exit from fullscreen mode not only with preview mode but also with thumbnails view mode.
Comment 19 nucleo 2013-05-30 21:38:07 UTC
Thumbbar not needed in Thumbnails view mode, so fix in comment 17 incomplete.
Comment 20 caulier.gilles 2013-05-31 11:36:45 UTC
Git commit 0cad3cfd24c841acc56eb11f4c548c3bcdc6193e by Gilles Caulier.
Committed on 31/05/2013 at 13:29.
Pushed by cgilles into branch 'master'.

during FullScreen, disable option to switch on/off bars managed by Full-screen settings (menubar, statusbar, thumbbar, toolsbar)
if view mode has changed during a FS session (icon-view/preview, maps, table), check if thumbbar can be restored as initialy

M  +66   -46   digikam/main/digikamapp.cpp
M  +2    -0    digikam/main/digikamapp.h
M  +139  -136  digikam/views/digikamview.cpp
M  +3    -1    digikam/views/digikamview.h
M  +17   -17   digikam/views/stackedview.h
M  +16   -3    libs/widgets/common/dxmlguiwindow.cpp
M  +4    -2    libs/widgets/common/dxmlguiwindow.h
M  +0    -6    showfoto/main/showfoto.cpp
M  +19   -8    utilities/imageeditor/editor/editorwindow.cpp
M  +1    -1    utilities/imageeditor/editor/editorwindow.h
M  +0    -6    utilities/imageeditor/main/imagewindow.cpp
M  +48   -26   utilities/importui/main/importui.cpp
M  +2    -0    utilities/importui/main/importui.h
M  +12   -12   utilities/importui/views/importstackedview.cpp
M  +2    -2    utilities/importui/views/importstackedview.h
M  +76   -72   utilities/importui/views/importview.cpp
M  +2    -0    utilities/importui/views/importview.h
M  +10   -2    utilities/lighttable/lighttablewindow.cpp
M  +2    -1    utilities/lighttable/lighttablewindow.h
M  +2    -2    utilities/lighttable/lighttablewindow_p.h
M  +7    -0    utilities/queuemanager/main/queuemgrwindow.cpp
M  +1    -0    utilities/queuemanager/main/queuemgrwindow.h

http://commits.kde.org/digikam/0cad3cfd24c841acc56eb11f4c548c3bcdc6193e
Comment 21 nucleo 2013-05-31 14:51:04 UTC
With last commit Thumbbar shown after exiting from FS in Preview mode, but if I exit from FS in Thumbnails view mode and then switch to Preview mode Thumbbar not shown.
Comment 22 caulier.gilles 2013-05-31 14:56:06 UTC
It can be a side effect of old settings. I cannot reproduce it here...

Also this depend of AlbumGUI FS setup of course. Try to check all cases and to be more explicit

Gilles Caulier
Comment 23 nucleo 2013-05-31 15:13:37 UTC
I removed all digikam settings (digikamrc and apps/digikam).
Digikam started in Thumbnails view mode, then in this mode I switched FS, then exited FS, then switched to Preview mode but Thumbbar not shown, in Settings menu show thimbar option enabled.
Comment 25 caulier.gilles 2013-06-24 12:29:35 UTC
Git commit 71dead6039bb137c8fa87286ea957097edf36e4d by Gilles Caulier.
Committed on 24/06/2013 at 12:27.
Pushed by cgilles into branch 'master'.

Force to reload current Stack view mode to set thumbbar visibility after full screen.
Handle thumbbar visibility in MediaPlayer mode.
This patch fix AlbumGUI and ImportUI

M  +2    -1    digikam/main/digikamapp.cpp
M  +3    -0    digikam/views/digikamview.cpp
M  +2    -1    utilities/importui/main/importui.cpp
M  +3    -0    utilities/importui/views/importview.cpp

http://commits.kde.org/digikam/71dead6039bb137c8fa87286ea957097edf36e4d