Bug 319921 - SCAN : Audio files are ignored [patch]
Summary: SCAN : Audio files are ignored [patch]
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Database-Scan (show other bugs)
Version: 4.2.0
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-16 20:22 UTC by Michael G. Hansen
Modified: 2017-07-25 10:50 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.11.0


Attachments
Directory with audio files in dolphin and digikam. (244.63 KB, image/png)
2013-05-16 20:23 UTC, Michael G. Hansen
Details
imagescanner.patch (388 bytes, patch)
2015-06-07 10:53 UTC, Maik Qualmann
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael G. Hansen 2013-05-16 20:22:14 UTC
Both digikam 3.1.0 and digikam git master do not display audio files on my system. I tried flac, wav and mp3 files. In the album tree, however, the item count still counts these files. See the attached screenshot showing both digikam`s icon view and dolphin. digikam git and 3.1.0 run on different user profiles, and the git version is compiled against exiv2 trunk.

Michael

Reproducible: Always
Comment 1 Michael G. Hansen 2013-05-16 20:23:18 UTC
Created attachment 79918 [details]
Directory with audio files in dolphin and digikam.
Comment 2 Michael G. Hansen 2013-05-16 20:24:10 UTC
digiKam version 3.3.0-beta1
Exiv2 can write to Jp2: Yes
Exiv2 can write to Jpeg: Yes
Exiv2 can write to Pgf: Yes
Exiv2 can write to Png: Yes
Exiv2 can write to Tiff: Yes
Exiv2 supports XMP metadata: Yes
LibCImg: 130
LibExiv2: 0.23
LibJPEG: 80
LibJasper: 1.900.1
LibKDE: 4.10.1
LibKExiv2: 2.3.1
LibKGeoMap: 2.0.0
LibKdcraw: 2.3.0
LibLCMS: 119
LibPGF: 6.12.27 - internal library
LibPNG: 1.2.49
LibQt: 4.8.3
LibRaw: 0.15.0-Beta3
LibTIFF: LIBTIFF, Version 4.0.2 Copyright (c) 1988-1996 Sam Leffler Copyright (c) 1991-1996 Silicon Graphics, Inc.
Marble Widget: 0.15.1 (stable version)
Parallelized PGF codec: No
Parallelized demosaicing: No
RawSpeed codec support: No
Database backend: QSQLITE
Kipi-Plugins: unavailable
LibGphoto2: 2.4.14
LibKface: 3.0.0
LibKipi: 2.1.0
LibOpenCV: 2.3.1
Libface: 0.3
Comment 3 Peter Albrecht 2014-08-22 09:17:06 UTC
This bug is still present in digiKam 4.2.0 (KDE 4.12.5).

"Settings" -> "Configure digiKam" -> "MIME Types" says: Default "Audio Files" = mp3, ogg, wav, wma

But after deleting my digiKam database (to intentionally rebuild a fresh, clean one from image metadata), no more *.mp3 or *.wav files show up in "album view".

Although in the "album tree side view" on the left side, they add to counter in braces. E.g. "Funny Animals Sounds (23)", which is a directory, containing 23 mp3 files.

On the other hand "Help" -> "Database Statistics" does not show *.mp3 or *.wav items. Although they were present with my old digiKam database created with digiKam < 3.5.0.
In "calender view" they also don't show up using my new, rebuild digiKam database, while they show up, using my old digiKam database.

So I guess, "adding audio files to digiKam database" got broken at digiKam <= 3.5.0 and is broken up to 4.2.0.
Taking the original bug description into account, digiKam got broken at <= 3.1.0.

"Adding movie files to digiKam database" works well without problems.


Bug #330579 seems to be a duplicate of this one and was confirmed by Gilles Caulier, as beeing "Reproducible with 4.0.0-beta3".
Comment 4 caulier.gilles 2014-08-22 10:46:59 UTC
*** Bug 330579 has been marked as a duplicate of this bug. ***
Comment 5 caulier.gilles 2014-08-22 10:48:49 UTC
I do not confirm dysfunction through bug #330579. It's just a question in comment #1 in fact.

Which kind of database type you use ? MySQL or SQlite ?

Gilles Caulier
Comment 6 caulier.gilles 2014-08-22 10:59:38 UTC
I confirm the bug. I Drop a mp3 file from dophin into and empty digiKam album, and count of item in album have been increased from 0 to 1, but icon view still empty.

I suspect a problem in items filter, not in database.

Gilles Caulier
Comment 7 caulier.gilles 2014-08-22 11:30:15 UTC
After some testing, i can see that filters is not responsible of this dysfunction.

Database do not register audio files, that all...

Gilles Caulier
Comment 8 Peter Albrecht 2014-08-23 18:34:14 UTC
(In reply to Gilles Caulier from comment #5)
> Which kind of database type you use ? MySQL or SQlite ?

I use a SQLite datebase.
Comment 9 caulier.gilles 2015-05-10 18:48:48 UTC
Marcel, Maik,

I can confirm this problem. audio type mime are completely ignored from scan process.

Gilles
Comment 10 Maik Qualmann 2015-06-07 10:53:55 UTC
Created attachment 93048 [details]
imagescanner.patch

With this patch, new audio files are visible again. The problem are the old audio files in the album. They contain no image information and are therefore not visible. The maintenance tool can not help. At the moment I see as the only option in the metadata settings the new option "Rescan file when files are modified" to enabled and to change the modification date of audio file with "touch".

Maik
Comment 11 caulier.gilles 2015-06-07 12:13:53 UTC
tested. The patch work fine for new audio files.

For older one the problem is about files already registered in DB and marked as ignored. The only solution is to rebuild DB from scratch.
Comment 12 Maik Qualmann 2015-06-07 16:57:09 UTC
Git commit 5e7167e24c00383f25907c9d00116775cadf1de1 by Maik Qualmann.
Committed on 07/06/2015 at 16:48.
Pushed by mqualmann into branch 'master'.

apply patch #93048 to resolve image scanner to add new audio files in the DB
FIXED-IN: 4.11.0

M  +2    -1    NEWS
M  +1    -1    libs/database/imagescanner.cpp

http://commits.kde.org/digikam/5e7167e24c00383f25907c9d00116775cadf1de1
Comment 13 caulier.gilles 2015-06-07 18:22:03 UTC
Git commit 2b1ce8cdbc3c58ca416e3dbce10047f9d76e0541 by Gilles Caulier.
Committed on 07/06/2015 at 18:21.
Pushed by cgilles into branch 'frameworks'.

backport commit #5e7167e24c00383f25907c9d00116775cadf1de1 from git/master to frameworks branch

M  +1    -1    libs/database/item/imagescanner.cpp

http://commits.kde.org/digikam/2b1ce8cdbc3c58ca416e3dbce10047f9d76e0541