Bug 319674 - Digikam crashed
Summary: Digikam crashed
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: ColorManagement-Backend (show other bugs)
Version: 3.1.0
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-11 16:35 UTC by jonathan_zaccaria
Modified: 2022-02-01 11:23 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 5.7.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jonathan_zaccaria 2013-05-11 16:35:07 UTC
Application: digikam (3.1.0)
KDE Platform Version: 4.10.2
Qt Version: 4.8.4
Operating System: Linux 3.8.0-19-generic i686
Distribution: Ubuntu 13.04

-- Information about the crash:
I was using ubuntu quantal 12.10 and Digikam 2.8 (installed from ubuntu software center) : no worries.
Afer upgrading ubuntu to 13.04, I restarted my laptop and then I saw that DIgikam version was 3.xx.
Since then, I cannot start digikam anymore. It crashes everytime I want to start it. I rebooted my laptop, no change. I am going to uninstall digikam and try to install it again...

The crash can be reproduced every time.

-- Backtrace:
Application: digiKam (digikam), signal: Segmentation fault
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0xac32b900 (LWP 4206))]

Thread 4 (Thread 0xab3ffb40 (LWP 4210)):
#0  0xb773b424 in __kernel_vsyscall ()
#1  0xb4ac8dcb in poll () from /lib/i386-linux-gnu/libc.so.6
#2  0xb30842db in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb30756d0 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb3075c2b in g_main_loop_run () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xaeb2ebca in ?? () from /usr/lib/i386-linux-gnu/libgio-2.0.so.0
#6  0xb309afc3 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#7  0xb340dd78 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#8  0xb4ad83de in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 3 (Thread 0xa9e98b40 (LWP 4211)):
#0  0xb773b424 in __kernel_vsyscall ()
#1  0xb341184b in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0xb4ae5d7c in pthread_cond_wait () from /lib/i386-linux-gnu/libc.so.6
#3  0xb4dca0f0 in wait (time=4294967295, this=0xa40e998) at thread/qwaitcondition_unix.cpp:86
#4  QWaitCondition::wait (this=0xa40e904, mutex=0xa40e900, time=4294967295) at thread/qwaitcondition_unix.cpp:158
#5  0x08209f16 in Digikam::ScanController::run (this=0xa3f39d8) at /build/buildd/digikam-3.1.0/core/digikam/database/scancontroller.cpp:705
#6  0xb4dc9b18 in QThreadPrivate::start (arg=0xa3f39d8) at thread/qthread_unix.cpp:338
#7  0xb340dd78 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#8  0xb4ad83de in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 2 (Thread 0xa94ffb40 (LWP 4212)):
#0  0xb773b424 in __kernel_vsyscall ()
#1  0xb4ac6c9b in read () from /lib/i386-linux-gnu/libc.so.6
#2  0xb30b7d4e in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb30751e3 in g_main_context_check () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb3075662 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb3075831 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#6  0xb4f0ec3f in QEventDispatcherGlib::processEvents (this=0xa415c90, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#7  0xb4edb3ec in QEventLoop::processEvents (this=this@entry=0xa94ff068, flags=...) at kernel/qeventloop.cpp:149
#8  0xb4edb6e1 in QEventLoop::exec (this=this@entry=0xa94ff068, flags=...) at kernel/qeventloop.cpp:204
#9  0xb4dc6fec in QThread::exec (this=this@entry=0xa40fd90) at thread/qthread.cpp:542
#10 0xb4ebaf2d in QInotifyFileSystemWatcherEngine::run (this=0xa40fd90) at io/qfilesystemwatcher_inotify.cpp:256
#11 0xb4dc9b18 in QThreadPrivate::start (arg=0xa40fd90) at thread/qthread_unix.cpp:338
#12 0xb340dd78 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#13 0xb4ad83de in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 1 (Thread 0xac32b900 (LWP 4206)):
[KCrash Handler]
#7  0xb3446332 in ?? () from /usr/lib/i386-linux-gnu/liblcms2.so.2
#8  0xb3446bec in cmsMLUgetASCII () from /usr/lib/i386-linux-gnu/liblcms2.so.2
#9  0xb6878690 in dkCmsTakeProductDesc (hProfile=0xa6098d8) at /build/buildd/digikam-3.1.0/core/libs/dklcms/digikam-lcms.cpp:377
#10 0xb68f325e in Digikam::IccProfile::description (this=0xa2ef828) at /build/buildd/digikam-3.1.0/core/libs/dimg/filters/icc/iccprofile.cpp:389
#11 0xb68fd825 in Digikam::IccSettings::loadAllProfilesProperties (this=0xa39f7e8) at /build/buildd/digikam-3.1.0/core/libs/dimg/filters/icc/iccsettings.cpp:577
#12 0x081cbb95 in Digikam::DigikamApp::DigikamApp (this=0xa44d090, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at /build/buildd/digikam-3.1.0/core/digikam/main/digikamapp.cpp:228
#13 0x080b9c5d in main (argc=5, argv=0xbf8a2a14) at /build/buildd/digikam-3.1.0/core/digikam/main/main.cpp:189

Reported using DrKonqi
Comment 1 caulier.gilles 2013-05-11 16:51:44 UTC

*** This bug has been marked as a duplicate of bug 318721 ***
Comment 2 caulier.gilles 2017-07-23 12:52:31 UTC
Since digiKam 5.0.0, we use drop lcms version 1.x in favor of lcms version 2.x. This problem will not reproducible.