Bug 318640 - Face detection crash
Summary: Face detection crash
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Faces-Detection (show other bugs)
Version: 3.1.0
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-04-20 16:23 UTC by Peter
Modified: 2019-12-23 07:35 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 7.0.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Peter 2013-04-20 16:23:46 UTC
Application: digikam (3.1.0)
KDE Platform Version: 4.10.2
Qt Version: 4.8.4
Operating System: Linux 3.8.4-102.fc17.i686.PAE i686
Distribution (Platform): Fedora RPMs

-- Information about the crash:
- What I was doing when the application crashed:
I was scanning for faces in my collection and after about 20% it crashed. This can be reproduced any time.

The crash can be reproduced every time.

-- Backtrace:
Application: digiKam (digikam), signal: Aborted
Using host libthread_db library "/lib/libthread_db.so.1".
[Current thread is 1 (Thread 0xb7754900 (LWP 2706))]

Thread 11 (Thread 0xb5201b40 (LWP 2707)):
#0  0xb77a8424 in __kernel_vsyscall ()
#1  0x448a012c in pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/i386/i486/pthread_cond_wait.S:172
#2  0x4175eb58 in wait (time=4294967295, this=0x8b6f478) at thread/qwaitcondition_unix.cpp:86
#3  QWaitCondition::wait (this=0x8b6f3e4, mutex=0x8b6f3e0, time=4294967295) at thread/qwaitcondition_unix.cpp:158
#4  0x0820b96e in Digikam::ScanController::run (this=0x8b6a3c8) at /usr/src/debug/digikam-3.1.0/core/digikam/database/scancontroller.cpp:705
#5  0x4175e55a in QThreadPrivate::start (arg=0x8b6a3c8) at thread/qthread_unix.cpp:338
#6  0x4489cadf in start_thread (arg=0xb5201b40) at pthread_create.c:309
#7  0x447cf42e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:133

Thread 10 (Thread 0xb48ffb40 (LWP 2708)):
#0  0x44967e8d in g_main_context_check () from /lib/libglib-2.0.so.0
#1  0x44968372 in ?? () from /lib/libglib-2.0.so.0
#2  0x44968542 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#3  0x418a6a8f in QEventDispatcherGlib::processEvents (this=0xb3f00468, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x41872add in QEventLoop::processEvents (this=this@entry=0xb48ff068, flags=...) at kernel/qeventloop.cpp:149
#5  0x41872dd9 in QEventLoop::exec (this=0xb48ff068, flags=...) at kernel/qeventloop.cpp:204
#6  0x4175b0cc in QThread::exec (this=0x8b70748) at thread/qthread.cpp:542
#7  0x41850a7e in QInotifyFileSystemWatcherEngine::run (this=0x8b70748) at io/qfilesystemwatcher_inotify.cpp:256
#8  0x4175e55a in QThreadPrivate::start (arg=0x8b70748) at thread/qthread_unix.cpp:338
#9  0x4489cadf in start_thread (arg=0xb48ffb40) at pthread_create.c:309
#10 0x447cf42e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:133

Thread 9 (Thread 0xaccefb40 (LWP 2716)):
#0  0xb77a8424 in __kernel_vsyscall ()
#1  0x447c4f34 in __GI___poll (fds=0xab3fad8, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#2  0x44976f5c in g_poll () from /lib/libglib-2.0.so.0
#3  0x449683e0 in ?? () from /lib/libglib-2.0.so.0
#4  0x44968542 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#5  0x418a6a8f in QEventDispatcherGlib::processEvents (this=0x9dd07f8, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x41872add in QEventLoop::processEvents (this=this@entry=0xaccef060, flags=...) at kernel/qeventloop.cpp:149
#7  0x41872dd9 in QEventLoop::exec (this=0xaccef060, flags=...) at kernel/qeventloop.cpp:204
#8  0x49faadcd in Digikam::WorkerObjectRunnable::run (this=0xa69ded8) at /usr/src/debug/digikam-3.1.0/core/libs/threads/threadmanager.cpp:196
#9  0x4175105c in QThreadPoolThread::run (this=0x9dd7888) at concurrent/qthreadpool.cpp:107
#10 0x4175e55a in QThreadPrivate::start (arg=0x9dd7888) at thread/qthread_unix.cpp:338
#11 0x4489cadf in start_thread (arg=0xaccefb40) at pthread_create.c:309
#12 0x447cf42e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:133

Thread 8 (Thread 0xac4eeb40 (LWP 2717)):
#0  0x448e2dad in __GI_clock_gettime (clock_id=1, tp=0xac4eddb8) at ../sysdeps/unix/clock_gettime.c:116
#1  0x417bdce6 in do_gettime (frac=0xac4eddb0, sec=0xac4edda8) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x418a75af in QTimerInfoList::updateCurrentTime (this=0xac4ede38) at kernel/qeventdispatcher_unix.cpp:354
#4  0xb35145e0 in ?? ()
#5  0x00000000 in ?? ()

Thread 7 (Thread 0xab4ecb40 (LWP 2719)):
#0  0x449a9206 in ?? () from /lib/libglib-2.0.so.0
#1  0x449a94e9 in g_mutex_lock () from /lib/libglib-2.0.so.0
#2  0x449679b7 in g_main_context_prepare () from /lib/libglib-2.0.so.0
#3  0x449682df in ?? () from /lib/libglib-2.0.so.0
#4  0x44968542 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#5  0x418a6a8f in QEventDispatcherGlib::processEvents (this=0xa9952c48, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x41872add in QEventLoop::processEvents (this=this@entry=0xab4ec060, flags=...) at kernel/qeventloop.cpp:149
#7  0x41872dd9 in QEventLoop::exec (this=0xab4ec060, flags=...) at kernel/qeventloop.cpp:204
#8  0x49faadcd in Digikam::WorkerObjectRunnable::run (this=0xa69dfe8) at /usr/src/debug/digikam-3.1.0/core/libs/threads/threadmanager.cpp:196
#9  0x4175105c in QThreadPoolThread::run (this=0x9dcf6d8) at concurrent/qthreadpool.cpp:107
#10 0x4175e55a in QThreadPrivate::start (arg=0x9dcf6d8) at thread/qthread_unix.cpp:338
#11 0x4489cadf in start_thread (arg=0xab4ecb40) at pthread_create.c:309
#12 0x447cf42e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:133

Thread 6 (Thread 0xa90feb40 (LWP 2723)):
#0  0x4489e8a0 in __pthread_mutex_lock (mutex=0xa9b00550) at pthread_mutex_lock.c:96
#1  0x449a94f1 in g_mutex_lock () from /lib/libglib-2.0.so.0
#2  0x44967e9d in g_main_context_check () from /lib/libglib-2.0.so.0
#3  0x44968372 in ?? () from /lib/libglib-2.0.so.0
#4  0x44968542 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#5  0x418a6a8f in QEventDispatcherGlib::processEvents (this=0xa9b00468, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x41872add in QEventLoop::processEvents (this=this@entry=0xa90fe060, flags=...) at kernel/qeventloop.cpp:149
#7  0x41872dd9 in QEventLoop::exec (this=0xa90fe060, flags=...) at kernel/qeventloop.cpp:204
#8  0x49faadcd in Digikam::WorkerObjectRunnable::run (this=0xb503980) at /usr/src/debug/digikam-3.1.0/core/libs/threads/threadmanager.cpp:196
#9  0x4175105c in QThreadPoolThread::run (this=0x9dd0118) at concurrent/qthreadpool.cpp:107
#10 0x4175e55a in QThreadPrivate::start (arg=0x9dd0118) at thread/qthread_unix.cpp:338
#11 0x4489cadf in start_thread (arg=0xa90feb40) at pthread_create.c:309
#12 0x447cf42e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:133

Thread 5 (Thread 0xa44f9b40 (LWP 2732)):
#0  0x449a9219 in ?? () from /lib/libglib-2.0.so.0
#1  0x449a9529 in g_mutex_unlock () from /lib/libglib-2.0.so.0
#2  0x44967fa9 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#3  0x44968460 in ?? () from /lib/libglib-2.0.so.0
#4  0x44968542 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#5  0x418a6a8f in QEventDispatcherGlib::processEvents (this=0x9dd3458, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x41872add in QEventLoop::processEvents (this=this@entry=0xa44f9060, flags=...) at kernel/qeventloop.cpp:149
#7  0x41872dd9 in QEventLoop::exec (this=0xa44f9060, flags=...) at kernel/qeventloop.cpp:204
#8  0x49faadcd in Digikam::WorkerObjectRunnable::run (this=0x9ea5fe8) at /usr/src/debug/digikam-3.1.0/core/libs/threads/threadmanager.cpp:196
#9  0x4175105c in QThreadPoolThread::run (this=0x9dd3008) at concurrent/qthreadpool.cpp:107
#10 0x4175e55a in QThreadPrivate::start (arg=0x9dd3008) at thread/qthread_unix.cpp:338
#11 0x4489cadf in start_thread (arg=0xa44f9b40) at pthread_create.c:309
#12 0x447cf42e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:133

Thread 4 (Thread 0xa18ffb40 (LWP 2766)):
[KCrash Handler]
#7  0xb77a8424 in __kernel_vsyscall ()
#8  0x4470994f in __GI_raise (sig=sig@entry=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#9  0x4470b2a3 in __GI_abort () at abort.c:91
#10 0x44c3ba15 in __gnu_cxx::__verbose_terminate_handler () at ../../../../libstdc++-v3/libsupc++/vterminate.cc:95
#11 0x44c39604 in __cxxabiv1::__terminate (handler=0x44c3b8c0 <__gnu_cxx::__verbose_terminate_handler()>) at ../../../../libstdc++-v3/libsupc++/eh_terminate.cc:40
#12 0x44c39640 in std::terminate () at ../../../../libstdc++-v3/libsupc++/eh_terminate.cc:50
#13 0x44c3a483 in __cxxabiv1::__cxa_pure_virtual () at ../../../../libstdc++-v3/libsupc++/pure.cc:50
#14 0x4906b9d6 in tbb::internal::custom_scheduler<tbb::internal::IntelSchedulerTraits>::local_wait_for_all (this=0xa1adbe00, parent=..., child=0xa1a8f020) at ../../src/tbb/custom_scheduler.h:449
#15 0x490678a5 in tbb::internal::arena::process (this=0xa1a93780, s=...) at ../../src/tbb/arena.cpp:99
#16 0x4906695c in tbb::internal::market::process (this=0xa1af3f00, j=...) at ../../src/tbb/market.cpp:393
#17 0x49064095 in tbb::internal::rml::private_worker::run (this=this@entry=0xa1aebf00) at ../../src/tbb/private_server.cpp:263
#18 0x4906430c in tbb::internal::rml::private_worker::thread_routine (arg=0xa1aebf00) at ../../src/tbb/private_server.cpp:231
#19 0x4489cadf in start_thread (arg=0xa18ffb40) at pthread_create.c:309
#20 0x447cf42e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:133

Thread 3 (Thread 0xa16feb40 (LWP 2767)):
#0  0xb77a8424 in __kernel_vsyscall ()
#1  0x447cb627 in syscall () at ../sysdeps/unix/sysv/linux/i386/syscall.S:30
#2  0x490642d8 in futex_wait (comparand=2, futex=0xa1aebf98) at ../../include/tbb/machine/linux_common.h:67
#3  P (this=0xa1aebf98) at ../../src/tbb/semaphore.h:212
#4  commit_wait (c=<synthetic pointer>, this=0xa1aebf90) at ../../src/rml/server/thread_monitor.h:209
#5  tbb::internal::rml::private_worker::run (this=this@entry=0xa1aebf80) at ../../src/tbb/private_server.cpp:270
#6  0x4906430c in tbb::internal::rml::private_worker::thread_routine (arg=0xa1aebf80) at ../../src/tbb/private_server.cpp:231
#7  0x4489cadf in start_thread (arg=0xa16feb40) at pthread_create.c:309
#8  0x447cf42e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:133

Thread 2 (Thread 0xa02ffb40 (LWP 2768)):
#0  0xb77a8424 in __kernel_vsyscall ()
#1  0x447cb627 in syscall () at ../sysdeps/unix/sysv/linux/i386/syscall.S:30
#2  0x490642d8 in futex_wait (comparand=2, futex=0xa1aebe98) at ../../include/tbb/machine/linux_common.h:67
#3  P (this=0xa1aebe98) at ../../src/tbb/semaphore.h:212
#4  commit_wait (c=<synthetic pointer>, this=0xa1aebe90) at ../../src/rml/server/thread_monitor.h:209
#5  tbb::internal::rml::private_worker::run (this=this@entry=0xa1aebe80) at ../../src/tbb/private_server.cpp:270
#6  0x4906430c in tbb::internal::rml::private_worker::thread_routine (arg=0xa1aebe80) at ../../src/tbb/private_server.cpp:231
#7  0x4489cadf in start_thread (arg=0xa02ffb40) at pthread_create.c:309
#8  0x447cf42e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:133

Thread 1 (Thread 0xb7754900 (LWP 2706)):
#0  0xb77a8424 in __kernel_vsyscall ()
#1  0x448a012c in pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/i386/i486/pthread_cond_wait.S:172
#2  0x4175eb58 in wait (time=4294967295, this=0x8bb5998) at thread/qwaitcondition_unix.cpp:86
#3  QWaitCondition::wait (this=0x8cb9f90, mutex=0x8cb9f7c, time=4294967295) at thread/qwaitcondition_unix.cpp:158
#4  0x41750873 in QThreadPoolPrivate::waitForDone (this=0x8cb9f30, msecs=msecs@entry=-1) at concurrent/qthreadpool.cpp:298
#5  0x4175233d in QThreadPool::~QThreadPool (this=0x8ba04b8, __in_chrg=<optimized out>) at concurrent/qthreadpool.cpp:440
#6  0x417523a3 in QThreadPool::~QThreadPool (this=0x8ba04b8, __in_chrg=<optimized out>) at concurrent/qthreadpool.cpp:442
#7  0x418881ea in QObjectPrivate::deleteChildren (this=this@entry=0x8c9cf58) at kernel/qobject.cpp:1907
#8  0x4188c2cc in QObject::~QObject (this=0x8c98e70, __in_chrg=<optimized out>) at kernel/qobject.cpp:926
#9  0x49faa359 in Digikam::ThreadManager::~ThreadManager (this=0x8c98e70, __in_chrg=<optimized out>) at /usr/src/debug/digikam-3.1.0/core/libs/threads/threadmanager.cpp:257
#10 0x49faa45a in ~ThreadManagerCreator (this=0x8c98e70, __in_chrg=<optimized out>) at /usr/src/debug/digikam-3.1.0/core/libs/threads/threadmanager.cpp:236
#11 destroy () at /usr/src/debug/digikam-3.1.0/core/libs/threads/threadmanager.cpp:241
#12 0x49db09ba in KCleanUpGlobalStatic::~KCleanUpGlobalStatic (this=0x4a1e248c, __in_chrg=<optimized out>) at /usr/include/kde4/kglobal.h:62
#13 0x4470ccd1 in __run_exit_handlers (status=status@entry=1, listp=0x448893c4, run_list_atexit=run_list_atexit@entry=true) at exit.c:78
#14 0x4470cd5d in __GI_exit (status=1) at exit.c:100
#15 0x4936fe49 in qt_xio_errhandler () at kernel/qapplication_x11.cpp:772
#16 0x42840bea in KApplication::xioErrhandler (this=0xbfbd1e88, dpy=dpy@entry=0x8a4a720) at /usr/src/debug/kdelibs-4.10.2/kdeui/kernel/kapplication.cpp:419
#17 0x42840c25 in kde_xio_errhandler (dpy=0x8a4a720) at /usr/src/debug/kdelibs-4.10.2/kdeui/kernel/kapplication.cpp:126
#18 0x43b124e5 in _XIOError () from /lib/libX11.so.6
#19 0x43b0fccf in _XEventsQueued () from /lib/libX11.so.6
#20 0x43b00500 in XEventsQueued () from /lib/libX11.so.6
#21 0x493ab48b in x11EventSourceCheck (s=0x8a37c28) at kernel/qguieventdispatcher_glib.cpp:85
#22 0x44967e8f in g_main_context_check () from /lib/libglib-2.0.so.0
#23 0x44968372 in ?? () from /lib/libglib-2.0.so.0
#24 0x44968542 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#25 0x418a6a72 in QEventDispatcherGlib::processEvents (this=0x89e3710, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#26 0x493ab69b in QGuiEventDispatcherGlib::processEvents (this=0x89e3710, flags=...) at kernel/qguieventdispatcher_glib.cpp:207
#27 0x41872add in QEventLoop::processEvents (this=this@entry=0xbfbd1c88, flags=...) at kernel/qeventloop.cpp:149
#28 0x41872dd9 in QEventLoop::exec (this=0xbfbd1c88, flags=...) at kernel/qeventloop.cpp:204
#29 0x4187831b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1218
#30 0x492f6ed5 in QApplication::exec () at kernel/qapplication.cpp:3823
#31 0x080ba1b6 in main (argc=5, argv=0xbfbd1fe4) at /usr/src/debug/digikam-3.1.0/core/digikam/main/main.cpp:235

This bug may be a duplicate of or related to bug 309027, bug 312440, bug 301611.

Possible duplicates by query: bug 312440, bug 311745, bug 309027, bug 308801, bug 306218.

Reported using DrKonqi
Comment 1 caulier.gilles 2013-04-21 10:45:59 UTC

*** This bug has been marked as a duplicate of bug 309027 ***
Comment 2 caulier.gilles 2019-12-23 07:35:25 UTC
Problem is fixed with new 7.0.0-beta1 through this long story from this bug

https://bugs.kde.org/show_bug.cgi?id=399923

You can test digiKam 7.0.0-beta1 with bundle available here:

https://download.kde.org/unstable/digikam/

Don't hesitate to give us a fresh feedback about his entry.

Thanks in advance

Gilles Caulier