Bug 311745 - crash on importing
Summary: crash on importing
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Applications
Component: Import-IconView (show other bugs)
Version: 2.9.0
Platform: Debian unstable Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-15 20:19 UTC by ejovrh
Modified: 2017-08-16 09:48 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 5.1.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ejovrh 2012-12-15 20:19:59 UTC
Application: digikam (2.9.0)
KDE Platform Version: 4.8.4 (4.8.4)
Qt Version: 4.8.2
Operating System: Linux 2.6.32-5-686 i686
Distribution (Platform): Debian unstable

-- Information about the crash:
- What I was doing when the application crashed:

windows machine was uploading onto linux running digikam
i was having the folder open into which said machine was copying images (tif, nef, jpeg) into.

The crash can be reproduced every time.

-- Backtrace:
Application: digiKam (digikam), signal: Aborted
Using host libthread_db library "/lib/i386-linux-gnu/i686/cmov/libthread_db.so.1".
[Current thread is 1 (Thread 0xaea958c0 (LWP 5483))]

Thread 6 (Thread 0xac771b70 (LWP 5484)):
#0  0xb77db424 in __kernel_vsyscall ()
#1  0xb359520a in __pthread_cond_wait (cond=0x9624858, mutex=0x9624840) at pthread_cond_wait.c:153
#2  0xb484187d in __pthread_cond_wait (cond=0x9624858, mutex=0x9624840) at forward.c:139
#3  0xb4ae0470 in wait (time=4294967295, this=0x9624840) at thread/qwaitcondition_unix.cpp:86
#4  QWaitCondition::wait (this=0x96247ac, mutex=0x96247a8, time=4294967295) at thread/qwaitcondition_unix.cpp:158
#5  0x0820fb3e in Digikam::ScanController::run (this=0x9624690) at /build/buildd-digikam_2.9.0-3-i386-CXznwk/digikam-2.9.0/core/digikam/database/scancontroller.cpp:698
#6  0xb4adff00 in QThreadPrivate::start (arg=0x9624690) at thread/qthread_unix.cpp:307
#7  0xb3590c39 in start_thread (arg=0xac771b70) at pthread_create.c:304
#8  0xb483478e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 5 (Thread 0xabf70b70 (LWP 5485)):
#0  0xb30bbe11 in *__GI_clock_gettime (clock_id=1, tp=0xabf6fe58) at ../sysdeps/unix/clock_gettime.c:116
#1  0xb4b3ea35 in do_gettime (frac=0xabf6fe50, sec=0xabf6fe48) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0xb4c2421e in QTimerInfoList::updateCurrentTime (this=0x96283b4) at kernel/qeventdispatcher_unix.cpp:343
#4  0x09628060 in ?? ()
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

Thread 4 (Thread 0xab76fb70 (LWP 5495)):
#0  0xb77db424 in __kernel_vsyscall ()
#1  0xb359520a in __pthread_cond_wait (cond=0x97a9130, mutex=0x97a9118) at pthread_cond_wait.c:153
#2  0xb484187d in __pthread_cond_wait (cond=0x97a9130, mutex=0x97a9118) at forward.c:139
#3  0xb4ae0470 in wait (time=4294967295, this=0x97a9118) at thread/qwaitcondition_unix.cpp:86
#4  QWaitCondition::wait (this=0x9716090, mutex=0x971608c, time=4294967295) at thread/qwaitcondition_unix.cpp:158
#5  0xb6af9a4c in Digikam::ParkingThread::run (this=0x9716080) at /build/buildd-digikam_2.9.0-3-i386-CXznwk/digikam-2.9.0/core/libs/threads/threadmanager.cpp:119
#6  0xb4adff00 in QThreadPrivate::start (arg=0x9716080) at thread/qthread_unix.cpp:307
#7  0xb3590c39 in start_thread (arg=0xab76fb70) at pthread_create.c:304
#8  0xb483478e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 3 (Thread 0xa66ffb70 (LWP 5516)):
[KCrash Handler]
#7  0xb77db424 in __kernel_vsyscall ()
#8  0xb4789941 in *__GI_raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#9  0xb478cd72 in *__GI_abort () at abort.c:92
#10 0xb495628d in __gnu_cxx::__verbose_terminate_handler() () from /usr/lib/i386-linux-gnu/libstdc++.so.6
#11 0xb4953ef3 in ?? () from /usr/lib/i386-linux-gnu/libstdc++.so.6
#12 0xb4953f2f in std::terminate() () from /usr/lib/i386-linux-gnu/libstdc++.so.6
#13 0xb4954225 in __cxa_rethrow () from /usr/lib/i386-linux-gnu/libstdc++.so.6
#14 0xb4ad2ae2 in QThreadPoolThread::run (this=0x17177a98) at concurrent/qthreadpool.cpp:114
#15 0xb4adff00 in QThreadPrivate::start (arg=0x17177a98) at thread/qthread_unix.cpp:307
#16 0xb3590c39 in start_thread (arg=0xa66ffb70) at pthread_create.c:304
#17 0xb483478e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 2 (Thread 0xa54ffb70 (LWP 5519)):
#0  0xb3713d02 in sys_futex0 (val=52, op=<optimized out>, addr=0xa67e4c54) at ../../../src/libgomp/config/linux/x86/futex.h:90
#1  futex_wait (val=52, addr=0xa67e4c54) at ../../../src/libgomp/config/linux/x86/futex.h:120
#2  do_wait (val=52, addr=0xa67e4c54) at ../../../src/libgomp/config/linux/wait.h:64
#3  gomp_barrier_wait_end (bar=0xa67e4c50, state=52) at ../../../src/libgomp/config/linux/bar.c:47
#4  0xb3713db8 in gomp_barrier_wait (bar=bar@entry=0xa67e4c50) at ../../../src/libgomp/config/linux/bar.c:55
#5  0xb371243c in gomp_thread_start (xdata=0xa66fe4d0) at ../../../src/libgomp/team.c:120
#6  0xb3590c39 in start_thread (arg=0xa54ffb70) at pthread_create.c:304
#7  0xb483478e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 1 (Thread 0xaea958c0 (LWP 5483)):
#0  0xb77db424 in __kernel_vsyscall ()
#1  0xb359520a in __pthread_cond_wait (cond=0x9bb6ca0, mutex=0x9bb6c88) at pthread_cond_wait.c:153
#2  0xb484187d in __pthread_cond_wait (cond=0x9bb6ca0, mutex=0x9bb6c88) at forward.c:139
#3  0xb4ae0470 in wait (time=4294967295, this=0x9bb6c88) at thread/qwaitcondition_unix.cpp:86
#4  QWaitCondition::wait (this=0x9bb4974, mutex=0x9bb4970, time=4294967295) at thread/qwaitcondition_unix.cpp:158
#5  0xb6afbbd4 in Digikam::DynamicThread::wait (this=this@entry=0x9bb6c20, locker=...) at /build/buildd-digikam_2.9.0-3-i386-CXznwk/digikam-2.9.0/core/libs/threads/dynamicthread.cpp:351
#6  0xb6afbe89 in Digikam::DynamicThread::shutDown (this=0x9bb6c20) at /build/buildd-digikam_2.9.0-3-i386-CXznwk/digikam-2.9.0/core/libs/threads/dynamicthread.cpp:222
#7  0xb6abd988 in Digikam::ManagedLoadSaveThread::shutDown (this=0x9bb6c20) at /build/buildd-digikam_2.9.0-3-i386-CXznwk/digikam-2.9.0/core/libs/threadimageio/managedloadsavethread.cpp:94
#8  0xb6adc291 in Digikam::ThumbnailLoadThread::~ThumbnailLoadThread (this=0x9bb6c20, __in_chrg=<optimized out>) at /build/buildd-digikam_2.9.0-3-i386-CXznwk/digikam-2.9.0/core/libs/threadimageio/thumbnailloadthread.cpp:174
#9  0xb6adc402 in Digikam::ThumbnailLoadThread::~ThumbnailLoadThread (this=0x9bb6c20, __in_chrg=<optimized out>) at /build/buildd-digikam_2.9.0-3-i386-CXznwk/digikam-2.9.0/core/libs/threadimageio/thumbnailloadthread.cpp:177
#10 0xb6ad9da2 in destroy () at /build/buildd-digikam_2.9.0-3-i386-CXznwk/digikam-2.9.0/core/libs/threadimageio/thumbnailloadthread.cpp:150
#11 0xb68f2f59 in KCleanUpGlobalStatic::~KCleanUpGlobalStatic (this=0xb6d2ae64, __in_chrg=<optimized out>) at /usr/include/kglobal.h:62
#12 0xb478e50f in __run_exit_handlers (status=1, listp=0xb48be324, run_list_atexit=true) at exit.c:78
#13 0xb478e57f in *__GI_exit (status=1) at exit.c:100
#14 0xb51fc668 in qt_xio_errhandler () at kernel/qapplication_x11.cpp:770
#15 0xb5d20289 in KApplication::xioErrhandler (this=0xbf85cce8, dpy=dpy@entry=0x9529830) at ../../kdeui/kernel/kapplication.cpp:419
#16 0xb5d202c4 in kde_xio_errhandler (dpy=0x9529830) at ../../kdeui/kernel/kapplication.cpp:126
#17 0xb4372cc4 in _XIOError () from /usr/lib/i386-linux-gnu/libX11.so.6
#18 0xb43705bf in _XEventsQueued () from /usr/lib/i386-linux-gnu/libX11.so.6
#19 0xb43610c0 in XEventsQueued () from /usr/lib/i386-linux-gnu/libX11.so.6
#20 0xb5238ffa in x11EventSourceCheck (s=s@entry=0x9526940) at kernel/qguieventdispatcher_glib.cpp:85
#21 0xb32514bf in g_main_context_check (context=context@entry=0x95265b0, max_priority=<optimized out>, fds=fds@entry=0x16ee8690, n_fds=n_fds@entry=17) at /build/buildd-glib2.0_2.33.12+really2.32.4-3-i386-Z8T5T2/glib2.0-2.33.12+really2.32.4/./glib/gmain.c:3023
#22 0xb3251982 in g_main_context_iterate (context=context@entry=0x95265b0, block=block@entry=1, dispatch=dispatch@entry=1, self=<error reading variable: Unhandled dwarf expression opcode 0xfa>) at /build/buildd-glib2.0_2.33.12+really2.32.4-3-i386-Z8T5T2/glib2.0-2.33.12+really2.32.4/./glib/gmain.c:3143
#23 0xb3251b51 in g_main_context_iteration (context=0x95265b0, may_block=1) at /build/buildd-glib2.0_2.33.12+really2.32.4-3-i386-Z8T5T2/glib2.0-2.33.12+really2.32.4/./glib/gmain.c:3207
#24 0xb4c23831 in QEventDispatcherGlib::processEvents (this=0x94e27c8, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#25 0xb52391fa in QGuiEventDispatcherGlib::processEvents (this=0x94e27c8, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#26 0xb4bf001c in QEventLoop::processEvents (this=this@entry=0xbf85cae8, flags=...) at kernel/qeventloop.cpp:149
#27 0xb4bf0311 in QEventLoop::exec (this=0xbf85cae8, flags=...) at kernel/qeventloop.cpp:204
#28 0xb4bf5a8a in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1187
#29 0xb51842f4 in QApplication::exec () at kernel/qapplication.cpp:3817
#30 0x080c2fb8 in main (argc=5, argv=0xbf85ce54) at /build/buildd-digikam_2.9.0-3-i386-CXznwk/digikam-2.9.0/core/digikam/main/main.cpp:232

This bug may be a duplicate of or related to bug 311135.

Possible duplicates by query: bug 311280, bug 311135, bug 310950, bug 310163, bug 309560.

Reported using DrKonqi
Comment 1 caulier.gilles 2012-12-16 09:09:53 UTC
There is no digiKam code relevant in your trace. Run digiKam in GDB and try to get a better backtrace.

Gilles Caulier
Comment 2 caulier.gilles 2015-06-27 13:47:23 UTC
New digiKam 4.11.0 is available :

https://www.digikam.org/node/740

Can you reproduce the problem with this release ?

Gilles caulier
Comment 3 caulier.gilles 2015-08-21 07:05:17 UTC
digiKam 4.12.0 is out :

https://www.digikam.org/node/741

We need a fresh feedback using this release please...
Thanks in advance.
Comment 4 caulier.gilles 2016-07-09 15:57:21 UTC
This problem is not reproducible with last 5.0.0.
I close this file now. Don't hesitate to re-open it if necessary.
Gilles Caulier