Bug 318602 - Unable to exclude $HOME/Music from Local Collection
Summary: Unable to exclude $HOME/Music from Local Collection
Status: RESOLVED DUPLICATE of bug 316216
Alias: None
Product: amarok
Classification: Unclassified
Component: Collections/Local (show other bugs)
Version: 2.7.0
Platform: Ubuntu Packages Linux
: NOR normal (vote)
Target Milestone: 2.8
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-04-19 17:15 UTC by Alex
Modified: 2013-04-19 18:59 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alex 2013-04-19 17:15:43 UTC
It seems like Amarok is only able to add files to Collection and never removes them if the source folder is not selected in Local Collection settings anymore. Even after 'Full rescan'

When Amarok was first started it used $HOME/Music folder as Local Collection. But my collection is stored in /media/Music so I unchecked $HOME/Music and checked /media/Music in Settings->Local_Collection. After using 'Full rescan' option I noticed that all the media files from my $HOME folder are still in collection. 
I tried to remove amarokrc file in $HOME/.kde/share/config/ and the library folder was switched to my $HOME/Music again, but this time all the files from /media/Music are still stayed in my collection.

I believe it is possible to cleanup the library using the advice from this ticket https://bugs.kde.org/show_bug.cgi?id=191073  - by removing Amarok's  database, but anway I think the current behavior of Local Collection is not quite good :)
Comment 1 Myriam Schweingruber 2013-04-19 17:45:33 UTC
As mentioned on the Launchpad report: I can't reproduce this here, using Amarok from git v2.7.0-234-g541a484 on KDE 4.10.2, Kubuntu 13.04 beta2
Comment 2 Alex 2013-04-19 17:57:47 UTC
Forgot to mention...
I am using Kubuntu 12.04 64bit  + kubuntu-backports
Comment 3 Matěj Laitl 2013-04-19 18:11:41 UTC
I think this is a duplicate of bug 316216. Can you please follow the discussion between me and Rudolf there and report whether you have the same behaviour on the bug 316216?

*** This bug has been marked as a duplicate of bug 316216 ***
Comment 4 Alex 2013-04-19 18:22:34 UTC
I think Rudolf's bug actually consists of two:
 1) root folder is being added to local collection after CD rip is crashed;
 2) unable to remove junk files (even if the collection folder is changed in settings) unless .kde/share/apps/amarok/mysqle is removed (the problem I do have)
Comment 5 Matěj Laitl 2013-04-19 18:59:45 UTC
(In reply to comment #4)
> I think Rudolf's bug actually consists of two:
>  1) root folder is being added to local collection after CD rip is crashed;
>  2) unable to remove junk files (even if the collection folder is changed in
> settings) unless .kde/share/apps/amarok/mysqle is removed (the problem I do
> have)

No need to analyse Rudolf's problem, just please do what instructed to do, on bug 316216. (not here)