Bug 318493 - File open/save dialog does not show thumbnails for all file types that Dolphin does
Summary: File open/save dialog does not show thumbnails for all file types that Dolphi...
Status: RESOLVED FIXED
Alias: None
Product: frameworks-kio
Classification: Frameworks and Libraries
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR normal
Target Milestone: ---
Assignee: David Faure
URL:
Keywords: usability
: 196065 220191 313498 315859 (view as bug list)
Depends on:
Blocks: extramile
  Show dependency treegraph
 
Reported: 2013-04-17 08:33 UTC by Cyrille Dunant
Modified: 2018-04-22 17:49 UTC (History)
9 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cyrille Dunant 2013-04-17 08:33:51 UTC
Certain file types, notably PDFs and EPS are not shown as inline previews in the file dialog. This is despite the fact that the plugins which the plasma folder view or dolphin use are installed and work.

Reproducible: Always

Steps to Reproduce:
This is a usability issue/wishlist
Actual Results:  
Some files cannot be seen as inline previews even is the aside preview works.

Expected Results:  
I wish to be able to configure which files should be seen as inline thumbnails. Alternatively, this should follow Dolphin's preferences.
Comment 1 Christoph Feck 2013-04-17 11:18:25 UTC
*** Bug 315859 has been marked as a duplicate of this bug. ***
Comment 2 Christoph Feck 2013-04-22 11:22:14 UTC
To work around this issue:
- configure the list of previews you want to see in the file dialog using Dolphin
- locate configuration files in .kde/share/config in a text editor
- in section [PreviewSettings] copy the "Plugins=" line from dolphinrc to the application's rc file (e.g. kolourpaintrc) or to kdeglobals (for all other applications)
Comment 3 Maarten De Meyer 2013-05-07 21:37:31 UTC
*** Bug 196065 has been marked as a duplicate of this bug. ***
Comment 4 Maarten De Meyer 2013-05-07 21:41:42 UTC
*** Bug 220191 has been marked as a duplicate of this bug. ***
Comment 5 Maarten De Meyer 2013-05-07 23:16:16 UTC
*** Bug 313498 has been marked as a duplicate of this bug. ***
Comment 6 DE LEO Francesco 2013-05-17 17:32:51 UTC
This workaround works to me.
Comment 7 Dániel Simon 2013-09-03 06:52:58 UTC
In 4.11, KDE open file dialog does not show preview thumbnails of certain* jpeg images, whereas Dolphin does. The above workaround does not work for me.

*Usually the ones which are taken with a DSLR or compact camera. Others, e. g. which are taken with my phone, or randomly downloaded from internet, those are shown correctly in open file dialog.
Comment 8 Nate Graham 2018-04-22 17:18:48 UTC
Git commit b9a2ec685e7fb231d92cd7348b7aedae698ad218 by Nathaniel Graham, on behalf of Alex Nemeth.
Committed on 22/04/2018 at 17:18.
Pushed by ngraham into branch 'master'.

Filepicker reads thumbs preview from Dolphin settings

Summary:
Open/Save dialog uses the settings from Dolphin to determine what to show in the thumbnails.
Also now supports much more file types.

Test Plan: {F5815497}

Reviewers: #frameworks, #vdg, ngraham, #dolphin

Reviewed By: #vdg, ngraham

Subscribers: elvisangelaccio, alexeymin, ngraham, #frameworks

Tags: #frameworks

Maniphest Tasks: T8552

Differential Revision: https://phabricator.kde.org/D12389

M  +1    -1    src/filewidgets/kfilepreviewgenerator.cpp

https://commits.kde.org/kio/b9a2ec685e7fb231d92cd7348b7aedae698ad218
Comment 9 David REVOY 2018-04-22 17:49:32 UTC
Thank you for the fix. I was following this item since long time. I'll finally see the *.kra (Krita files) preview in Open/Save dialog.