Bug 317999 - set timeserver change timezone to UTC
Summary: set timeserver change timezone to UTC
Status: RESOLVED FIXED
Alias: None
Product: systemsettings
Classification: Applications
Component: kcm_clock (show other bugs)
Version: 4.10.2
Platform: Other Linux
: NOR major with 40 votes (vote)
Target Milestone: ---
Assignee: Paul Campbell
URL:
Keywords:
: 319304 325073 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-04-07 23:49 UTC by FabiB
Modified: 2016-04-08 17:44 UTC (History)
10 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
sorry, send for mistake to the wrong bug (93.44 KB, image/png)
2016-04-08 17:42 UTC, mariopr25
Details

Note You need to log in before you can comment on or make changes to this bug.
Description FabiB 2013-04-07 23:49:20 UTC
My normal Timezone is UTC+2 (Berlin)

default output 'date':
Mo 8. Apr 00:44:15 CEST 2013

Now i go to systemsettings > Date & time
enable timeserver syncro and set the timeserver to one of the presettet or some other server. Next i click 'OK'

now 'date' will say 
So 7. Apr 22:47:46 UTC 2013


in the category 'timezone' i have set Berlin.
to get in the right timezone again i have to use the debian way 
sudo dpkg-reconfigure tzdata 
after that date ist again 
Mo 8. Apr 00:54:51 CEST 2013


ireally dont know if there is some configuration missing here or its a bug. happens on all 3 computers with KDE SC 4.10.1/2

Reproducible: Always

Steps to Reproduce:
1. go to systemsettings > date & time
2. set a timeserver
3. activate it ans look to the clock
Actual Results:  
of you dont life in GMT-timezone your systemtime will change to UTC

Expected Results:  
you should stay in our timezone
Comment 1 René 2013-04-18 20:22:16 UTC
I have a very similair behaviour here. Since the change from winter to sommer time this year (a few weeks ago) my clock is 2 hours late. There might be a problem with the time zone: I live in Switzerland, so my time zone is 'Europe/Switzerland' (which was 2 hours late = GMT+0). But when I change it to 'Europe/Berlin', the time is displayed correctly (GMT+2).
Of course, Switzerland and Germany are in the same time zone, so there shouldn't be any difference...

The system time and the hardware clock ran always correctly (UTC), therefore I believe this has something to do with KDE / Date & Clock.

I'm using Ubuntu 13.04 Beta, KDE 4.10.2, amd64. Default locale is American English.

Regards,
René
Comment 2 Lorenzo 2013-04-26 13:40:22 UTC
First,
sorry for may very bad english.
I'm using Kubuntu 13.04 , KDE 4.10.2, amd64. Default locale is Italian and Timezone is Rome.
The clock always display the UTC time.
I find the file "/etc/localtime" is corrupted. It's  linked to a wrong position.
So i remake "/etc/localtime" to link at "usr/share/zoneinfo/posix/Europe/Rome" and now the clock display correct time.
If i change the localtime trough Systemsetting / Date and Time then clock display UTC time and the file "etc/localtime" is again corrupted.

Regards,
Lorenzo
Comment 3 Jakub Liput 2013-05-02 07:42:14 UTC
I'm using Kubuntu 13.04 (KDE 4.10.2, amd64) and have the same problem with Europe/Warsaw.
Symlink /etc/timezone links to "../Poland" (which of course doesn't exists).

Can someone check, if this bug is present on other distros? Maybe it's (K)ubuntu issue only?

Regards,
Jakub
(sorry for English mistakes - not native speaker)
Comment 4 mariopr25 2013-05-22 14:45:35 UTC
Hello. I have a similar problem.
I'm using KUbuntu 13.04 x86_64 (KDE 4.10.2) and the digital clock displays also always (or almost) UTC time when my timezone is Europe/Spain (Madrid).
I'm trying to change timezone in " adjust date and time"  of the  digital clock and in "digital clock settings" and i have gotten to show the time correctly but i have to do the following:
1. In "adjust date and time" i set a timezone differente of mine (for example "Pacific/American Samoa (Pago Pago) (LMT)").  Its changes the digital clock time to another very different of mine. 
2. Now in "digital clock settings" i set Europe/Madrid timezone and change "clocks defaults to:" from "Local" to "Europe/Madrid" and the time changes again and now it is right.

If I reset  the timezone to "Europe/Spain (Madrid)" in "adjust date and time" the digital clock displays UTC time again. 

Also if I set others timezones in "adjust date and time" (for example "America/Canada (Rainy River) , the "Local" option in "clock defaults to" option of "digital clock settings" many times (but not always, for example America/American Samoa (Pago Pago) does it right) it shows UTC time. 

So i think that there is a problem with the timezone in "adjust date and time" (but in "digital clock settings it seems to be right) that  sometimes causes that the "Local" timezone to display UTC time when it is wrong.

A temporal "SOLUTION" for users may be:  change  timezone in "adjust date and time" to another one (for example America/American Samoa (Pago Pago) and in "digital clock settings select this timezone in "clock defaults to" option instead of "Local"

Sorry for my bad english.
Comment 5 mariopr25 2013-05-22 15:00:38 UTC
I'm sorry, there is a mistake in the explication of my "temporal solution" .
The right steps are:
1. Select  another timezone in "adjust date and time", for example America/American Samoa (Pago Pago) seems to be fine and confirm.
2. Select in "digital clock setting" your timezone and change the option "clock defaults to" from "Local" to your timezone and confirm.

Thanks. Regards.
Comment 6 Lukas ThyWalls 2013-06-23 22:32:02 UTC
I have KUbuntu 13.04 32Bits (KDE 4.10.3) And have the same problem. I can't properly set the time zone without problems. I'm in Europe/Madrid (UTC+2 with summer +1 addition) and i can't set this time zone, if i set UTC or set Europe/Madrid (UTC+2) time zone i have the same automatic sync time, and if i choose Europe/Madrid (UTC+2) and manually set the time, when i restart the system it's again in UTC, but the time zone is Europe/Madrid.

The only manner to view my time zone clock is choose UTC time zone, and in digital clock set Europe/Madrid as default time zone. But really Gmail (and other applications) thinks i'm in UTC, and in clock settings is UTC time and UTC time zone. This isn't a solution. (http://img600.imageshack.us/img600/4306/wk6.png)

Testing some things, i view /etc/localtime content:
- When is UTC time zone selected:
  $ ls -l /etc/localtime
  -rw-r--r-- 2 root root 118 mar 14 10:46 /etc/localtime
  $ cat /etc/localtime
  TZif2UTCTZif2UTC
  UTC0
-When is Europe/Madrid (UTC+2) time zone selected:
  $ ls -l /etc/localtime
  lrwxrwxrwx 2 root root 22 jun 20 11:50 /etc/localtime -> ../posix/Europe/Madrid (symlink is broken)
  $ cat /etc/localtime
  cat: /etc/localtime: No existe el archivo o el directorio (File or directory doesn't exist)

This is very broken
Comment 7 Lukas ThyWalls 2013-06-23 23:05:59 UTC
When is selected the proper configuration for me, i set (in my case) a symlink of /usr/share/zoneinfo/posix/Europe/Madrid in /etc/localtime (inside /usr/share/zoneinfo/posix/ are all time zones files) and it works as it should after a few seconds (time is correct), but i can't enter in time configuration because it breaks again. At least it doesn't change in a restart...
Comment 8 Jekyll Wu 2013-06-24 01:21:43 UTC
*** Bug 319304 has been marked as a duplicate of this bug. ***
Comment 9 Lukas ThyWalls 2013-06-24 10:16:25 UTC
How said Vlado in https://bugs.kde.org/show_bug.cgi?id=319304#c4, other temporal workaround is to set the time and use as root "dpkg-reconfigure tzdata"

It generates a proper /etc/localtime, but not a symlink to posix directory, a directly file.

However, entering in clock settings messed again the configuration with the broken symlink.
Comment 10 Lukas ThyWalls 2013-07-02 12:40:18 UTC
In the last update of KDE to 4.10.4 (KUbuntu 13.04 32Bits), the same problem remains
Comment 11 Szokovacs Robert 2013-08-08 14:37:38 UTC
I don't think it's a KDE bug, it's libc's (zic's) fault:

# ls -l /etc/localtime 
lrwxrwxrwx 1 root root 41 Aug  8 14:50 /etc/localtime -> /usr/share/zoneinfo/posix/Europ/Budapest
# zic -l /usr/share/zoneinfo/Europe/Bucharest 
# ls -l /etc/localtime 
lrwxrwxrwx 2 root root 25 Mar 14 10:46 /etc/localtime -> ../posix/Europe/Bucharest

Since KDE has a fallback in case of no zic available, as a workaround you can just move it out of the way until it gets fixed:
 mv /usr/sbin/zic /usr/sbin/zic-bad
Comment 12 Michael Chalvatzis 2013-08-28 19:09:22 UTC
here the link to the bug report on launchpad for package eglibc
https://bugs.launchpad.net/ubuntu/+source/eglibc/+bug/1212662
that refers to this bug report,too (round robin ;-)
Comment 13 Christoph Feck 2013-09-18 22:09:35 UTC
*** Bug 325073 has been marked as a duplicate of this bug. ***
Comment 14 David Edmundson 2015-02-27 19:18:50 UTC
Git commit b6ae01ca8ea776c97cc57836401ca9696e2529e8 by David Edmundson.
Committed on 14/02/2015 at 13:50.
Pushed by davidedmundson into branch 'master'.

Add systemd support into the clock KCM as an optional dependency

The current time setting helper is incredibly broken.

It manually tries to run a range of NTP utilities, all of which are
deprecated.

We can just call timedated directly and cut out the middleman as it has
uses polkit anyway.

This is currently an optional dependency, and the original helper still
exists. It makes the code messy, but we have users to support for now.

Detection is done at runtime
Related: bug 196316, bug 311286, bug 317784, bug 319072, bug 337012, bug 339582, bug 241817, bug 178968, bug 320456, bug 337659
REVIEW: 122400

M  +5    -1    kcms/dateandtime/CMakeLists.txt
M  +22   -12   kcms/dateandtime/dateandtime.ui
M  +44   -30   kcms/dateandtime/dtime.cpp
M  +2    -1    kcms/dateandtime/dtime.h
M  +80   -7    kcms/dateandtime/main.cpp
M  +5    -1    kcms/dateandtime/main.h
A  +43   -0    kcms/dateandtime/timedated1.xml

http://commits.kde.org/plasma-desktop/b6ae01ca8ea776c97cc57836401ca9696e2529e8
Comment 15 mariopr25 2016-04-08 17:42:41 UTC
Created attachment 98291 [details]
sorry, send for mistake to the wrong bug