Bug 241817 - unable to change time settings
Summary: unable to change time settings
Status: RESOLVED FIXED
Alias: None
Product: systemsettings
Classification: Unclassified
Component: kcm_clock (show other bugs)
Version: 4.8.80 (beta1)
Platform: openSUSE RPMs Linux
: NOR normal with 160 votes (vote)
Target Milestone: ---
Assignee: Paul Campbell
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-06-15 15:24 UTC by bill p. (aka google01103)
Modified: 2015-08-04 07:02 UTC (History)
17 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bill p. (aka google01103) 2010-06-15 15:24:56 UTC
Version:           unspecified (using Devel) 
OS:                Linux

when I try to enable "set time and date automatically" it allows the check and "apply" but when return to main system menu it states "The settings of the current module have changed.Do you want to apply the changes or discard them?"
then gives the error "Unable to authenticate/execute the action: 3,"

On the forums another user has similar changing timezone, see http://forum.kde.org/viewtopic.php?f=66&t=88528&p=161387#p161387



Reproducible: Always

Steps to Reproduce:
as described in details

Actual Results:  
error message 

Expected Results:  
change to settings accepted and applied
Comment 1 bill p. (aka google01103) 2010-06-15 15:26:24 UTC
same result if run as root
Comment 2 s.v.savenko 2010-11-03 20:19:38 UTC
same here. KDE 4.4.4 on gentoo. Also setting time using kde has no effect.
Comment 3 s.v.savenko 2010-11-03 20:21:05 UTC
*** This bug has been confirmed by popular vote. ***
Comment 4 Anne-Marie Mahfouf 2012-06-12 15:49:52 UTC
Do you still reproduce this bug? If so, on what KDE version? thanks in advance!
Comment 5 bill p. (aka google01103) 2012-06-12 16:07:05 UTC
yes
Comment 6 Anne-Marie Mahfouf 2012-06-12 16:37:44 UTC
What KDE version?
Comment 7 bill p. (aka google01103) 2012-06-12 16:46:23 UTC
sorry running 4.8.80 

Unable to authenticate/execute the action: 6,
Comment 8 Marty Felker 2012-07-09 16:20:12 UTC
openSUSE 12.2 Beta 1
KDE 4.8.4

Upon booting the system the time was also 3 hours earlier - very annoying.  Could     fix it by

1)  Adjusting date and time manually - the clock changed but the task bar does not.  Authorization ion accepted.
2)  Set  to  automatic.  Time remains incorrect. But after a  few Seconds shows correctly (I use 12 hours AM/PM) .  Authorization accepted. 
3) Unchecked auto set. Time is now correct for the session. 
 So a bit better  than the comments  above but annoying.  I think   may be specific to KDE 4.8.4 or "perhaps" openSUSE.  Does not occur on Ubuntu  u 12.10 KDE 4.8.5 or Fedora 18 Rawhide  KDE 4.9.5

Marty Felker
Comment 9 Mark Fraser 2013-03-03 20:44:14 UTC
Still seeing this with KDE 4.9.5 in Kubuntu 12.10 and KDE 4.10 in Kubuntu 13.04.
Comment 10 Kiro 2013-04-02 19:09:40 UTC
Same problem here (fedora 18). I could solve the problem by
- remove clock widget from panel
- insert new clock widget (Digital Clock, by Riccardo Iaconelli) into the panel 

seems good for now, then, i haven't tried rebooting or similar things, basically I'm a lazy guy

all the best!
Comment 11 David P. 2013-04-16 06:49:45 UTC
It also affects me with Kubuntu 12.10.
Comment 12 David P. 2013-04-16 06:56:21 UTC
I don't see the Digital clock by Riccardo Iaconelli.  Any URL please?
Comment 13 David P. 2013-04-16 06:59:51 UTC
I cannot install 3rd party addons through a proxy.  :-(
Comment 14 Kiro 2013-04-16 19:39:20 UTC
Hi,
it's one of the "ordinary" widgets on my system (KDE 4.10.1 on Fedora 18) and as such I suppose that it shouldn't require any additional installation. Moreover I found it among all the other widgets (right-click in the panel, then "panel options" and finally "add widget").

kind regards!
Comment 15 Kiro 2013-04-16 19:42:07 UTC
by the way: in the mean while I have rebooted the system and time display is still correct..
Comment 16 David P. 2013-04-16 20:00:41 UTC
Thanks Scooby, that widget must be missing in Kubuntu 12.10.
Comment 17 cluelesscoder 2013-09-20 18:05:28 UTC
I ended up being able to fix this by using the advice at http://askubuntu.com/questions/268073/kubuntu-and-kde-clock and I cross-posted this to the forum (at http://forum.kde.org/viewtopic.php?f=66&t=100641&p=292754#p292754) which didn't have the answer there at askubuntu.com:

I just entered "sudo dpkg-reconfigure tzdata" and that did it.
Comment 18 David Edmundson 2015-02-27 19:02:38 UTC
Git commit b6ae01ca8ea776c97cc57836401ca9696e2529e8 by David Edmundson.
Committed on 14/02/2015 at 13:50.
Pushed by davidedmundson into branch 'master'.

Add systemd support into the clock KCM as an optional dependency

The current time setting helper is incredibly broken.

It manually tries to run a range of NTP utilities, all of which are
deprecated.

We can just call timedated directly and cut out the middleman as it has
uses polkit anyway.

This is currently an optional dependency, and the original helper still
exists. It makes the code messy, but we have users to support for now.

Detection is done at runtime
Related: bug 196316, bug 311286, bug 317784, bug 319072, bug 337012, bug 339582, bug 178968, bug 320456, bug 317999, bug 337659
REVIEW: 122400

M  +5    -1    kcms/dateandtime/CMakeLists.txt
M  +22   -12   kcms/dateandtime/dateandtime.ui
M  +44   -30   kcms/dateandtime/dtime.cpp
M  +2    -1    kcms/dateandtime/dtime.h
M  +80   -7    kcms/dateandtime/main.cpp
M  +5    -1    kcms/dateandtime/main.h
A  +43   -0    kcms/dateandtime/timedated1.xml

http://commits.kde.org/plasma-desktop/b6ae01ca8ea776c97cc57836401ca9696e2529e8
Comment 19 hamdi boujarra 2015-06-02 21:33:31 UTC
same problem kubuntu 15.04
Comment 20 Paolo Tezza 2015-08-04 07:02:34 UTC
(In reply to cluelesscoder from comment #17)
> I ended up being able to fix this by using the advice at
> http://askubuntu.com/questions/268073/kubuntu-and-kde-clock and I
> cross-posted this to the forum (at
> http://forum.kde.org/viewtopic.php?f=66&t=100641&p=292754#p292754) which
> didn't have the answer there at askubuntu.com:
> 
> I just entered "sudo dpkg-reconfigure tzdata" and that did it.

That works for me
I was unable to change timezone using graphical interface in kubuntu 15.04 kde 4.14.8
sudo dpkg-reconfigure tzdata 
do the magic.. tnx