Bug 316849 - exit from amarok
Summary: exit from amarok
Status: RESOLVED DUPLICATE of bug 285951
Alias: None
Product: amarok
Classification: Unclassified
Component: general (show other bugs)
Version: 2.5.0
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: 2.8
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-16 16:03 UTC by Alexandr
Modified: 2013-03-16 17:49 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexandr 2013-03-16 16:03:57 UTC
Application: amarok (2.5.0)
KDE Platform Version: 4.8.4 (4.8.4) "release 2"
Qt Version: 4.8.1
Operating System: Linux 3.4.6-2.10-desktop x86_64
Distribution: "openSUSE 12.2 (x86_64)"

-- Information about the crash:
close amarok and hi crash

The crash can be reproduced every time.

-- Backtrace:
Application: Amarok (amarok), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f1f1cc77780 (LWP 3894))]

Thread 12 (Thread 0x7f1f10e75700 (LWP 3899)):
#0  0x00007f1f2ea4a13f in poll () from /lib64/libc.so.6
#1  0x00007f1f261d408f in ?? () from /usr/lib64/libpulse.so.0
#2  0x00007f1f261c55fc in pa_mainloop_poll () from /usr/lib64/libpulse.so.0
#3  0x00007f1f261c5c59 in pa_mainloop_iterate () from /usr/lib64/libpulse.so.0
#4  0x00007f1f261c5d10 in pa_mainloop_run () from /usr/lib64/libpulse.so.0
#5  0x00007f1f261d403f in ?? () from /usr/lib64/libpulse.so.0
#6  0x00007f1f2188a2d3 in ?? () from /usr/lib64/libpulsecommon-1.1.so
#7  0x00007f1f2cb7de0e in start_thread () from /lib64/libpthread.so.0
#8  0x00007f1f2ea522bd in clone () from /lib64/libc.so.6

Thread 11 (Thread 0x7f1f039a2700 (LWP 3901)):
#0  0x00007fff2579560c in ?? ()
#1  0x00007fff2579589c in clock_gettime ()
#2  0x00007f1f276c4f7d in clock_gettime () from /lib64/librt.so.1
#3  0x00007f1f2f308a24 in ?? () from /usr/lib64/libQtCore.so.4
#4  0x00007f1f2f3db15d in ?? () from /usr/lib64/libQtCore.so.4
#5  0x00007f1f2f3db4a3 in ?? () from /usr/lib64/libQtCore.so.4
#6  0x00007f1f2f3da01c in ?? () from /usr/lib64/libQtCore.so.4
#7  0x00007f1f2f3da0c5 in ?? () from /usr/lib64/libQtCore.so.4
#8  0x00007f1f28a7bf0f in g_main_context_prepare () from /usr/lib64/libglib-2.0.so.0
#9  0x00007f1f28a7c5fb in ?? () from /usr/lib64/libglib-2.0.so.0
#10 0x00007f1f28a7c7f4 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#11 0x00007f1f2f3da956 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#12 0x00007f1f2f3ab73f in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#13 0x00007f1f2f3ab9c8 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#14 0x00007f1f2f2afe40 in QThread::exec() () from /usr/lib64/libQtCore.so.4
#15 0x00007f1f2f38c11f in ?? () from /usr/lib64/libQtCore.so.4
#16 0x00007f1f2f2b2ddb in ?? () from /usr/lib64/libQtCore.so.4
#17 0x00007f1f2cb7de0e in start_thread () from /lib64/libpthread.so.0
#18 0x00007f1f2ea522bd in clone () from /lib64/libc.so.6

Thread 10 (Thread 0x7f1f015a8700 (LWP 3908)):
#0  0x00007f1f28a7c67d in ?? () from /usr/lib64/libglib-2.0.so.0
#1  0x00007f1f28a7c7f4 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f1f2f3da956 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#3  0x00007f1f2f3ab73f in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#4  0x00007f1f2f3ab9c8 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#5  0x00007f1f2f2afe40 in QThread::exec() () from /usr/lib64/libQtCore.so.4
#6  0x00007f1f2f2b2ddb in ?? () from /usr/lib64/libQtCore.so.4
#7  0x00007f1f2cb7de0e in start_thread () from /lib64/libpthread.so.0
#8  0x00007f1f2ea522bd in clone () from /lib64/libc.so.6

Thread 9 (Thread 0x7f1f0096a700 (LWP 3909)):
#0  0x00007f1f2ea4a13f in poll () from /lib64/libc.so.6
#1  0x00007f1f28a7c6d4 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f1f28a7c7f4 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f1f2f3da956 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#4  0x00007f1f2f3ab73f in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#5  0x00007f1f2f3ab9c8 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#6  0x00007f1f2f2afe40 in QThread::exec() () from /usr/lib64/libQtCore.so.4
#7  0x00007f1f2f2b2ddb in ?? () from /usr/lib64/libQtCore.so.4
#8  0x00007f1f2cb7de0e in start_thread () from /lib64/libpthread.so.0
#9  0x00007f1f2ea522bd in clone () from /lib64/libc.so.6

Thread 8 (Thread 0x7f1ef3fff700 (LWP 3910)):
#0  0x00007f1f2cb81c61 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f1f2f2b3237 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib64/libQtCore.so.4
#2  0x00007f1f2f2a6adf in ?? () from /usr/lib64/libQtCore.so.4
#3  0x00007f1f2f2b2ddb in ?? () from /usr/lib64/libQtCore.so.4
#4  0x00007f1f2cb7de0e in start_thread () from /lib64/libpthread.so.0
#5  0x00007f1f2ea522bd in clone () from /lib64/libc.so.6

Thread 7 (Thread 0x7f1ef33f4700 (LWP 3911)):
#0  0x00007f1f2cb818f4 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f1f2f2b32db in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib64/libQtCore.so.4
#2  0x00007f1f2becf971 in ?? () from /usr/lib64/libthreadweaver.so.4
#3  0x00007f1f2bed21bb in ?? () from /usr/lib64/libthreadweaver.so.4
#4  0x00007f1f2bed21d4 in ?? () from /usr/lib64/libthreadweaver.so.4
#5  0x00007f1f2bed21d4 in ?? () from /usr/lib64/libthreadweaver.so.4
#6  0x00007f1f2bed21d4 in ?? () from /usr/lib64/libthreadweaver.so.4
#7  0x00007f1f2bed21d4 in ?? () from /usr/lib64/libthreadweaver.so.4
#8  0x00007f1f2bed102f in ?? () from /usr/lib64/libthreadweaver.so.4
#9  0x00007f1f2bed10bb in ThreadWeaver::Thread::run() () from /usr/lib64/libthreadweaver.so.4
#10 0x00007f1f2f2b2ddb in ?? () from /usr/lib64/libQtCore.so.4
#11 0x00007f1f2cb7de0e in start_thread () from /lib64/libpthread.so.0
#12 0x00007f1f2ea522bd in clone () from /lib64/libc.so.6

Thread 6 (Thread 0x7f1ef25d8700 (LWP 3913)):
#0  0x00007f1f2cb818f4 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f1f2f2b32db in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib64/libQtCore.so.4
#2  0x00007f1f2becf971 in ?? () from /usr/lib64/libthreadweaver.so.4
#3  0x00007f1f2bed21bb in ?? () from /usr/lib64/libthreadweaver.so.4
#4  0x00007f1f2bed21d4 in ?? () from /usr/lib64/libthreadweaver.so.4
#5  0x00007f1f2bed102f in ?? () from /usr/lib64/libthreadweaver.so.4
#6  0x00007f1f2bed10bb in ThreadWeaver::Thread::run() () from /usr/lib64/libthreadweaver.so.4
#7  0x00007f1f2f2b2ddb in ?? () from /usr/lib64/libQtCore.so.4
#8  0x00007f1f2cb7de0e in start_thread () from /lib64/libpthread.so.0
#9  0x00007f1f2ea522bd in clone () from /lib64/libc.so.6

Thread 5 (Thread 0x7f1ef1dd7700 (LWP 3915)):
#0  0x00007f1f2cb818f4 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f1f2f2b32db in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib64/libQtCore.so.4
#2  0x00007f1f2becf971 in ?? () from /usr/lib64/libthreadweaver.so.4
#3  0x00007f1f2bed21bb in ?? () from /usr/lib64/libthreadweaver.so.4
#4  0x00007f1f2bed21d4 in ?? () from /usr/lib64/libthreadweaver.so.4
#5  0x00007f1f2bed21d4 in ?? () from /usr/lib64/libthreadweaver.so.4
#6  0x00007f1f2bed102f in ?? () from /usr/lib64/libthreadweaver.so.4
#7  0x00007f1f2bed10bb in ThreadWeaver::Thread::run() () from /usr/lib64/libthreadweaver.so.4
#8  0x00007f1f2f2b2ddb in ?? () from /usr/lib64/libQtCore.so.4
#9  0x00007f1f2cb7de0e in start_thread () from /lib64/libpthread.so.0
#10 0x00007f1f2ea522bd in clone () from /lib64/libc.so.6

Thread 4 (Thread 0x7f1ef0e34700 (LWP 3931)):
#0  0x00007f1f2cb818f4 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f1f2f2b32db in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib64/libQtCore.so.4
#2  0x00007f1f2becf971 in ?? () from /usr/lib64/libthreadweaver.so.4
#3  0x00007f1f2bed21bb in ?? () from /usr/lib64/libthreadweaver.so.4
#4  0x00007f1f2bed102f in ?? () from /usr/lib64/libthreadweaver.so.4
#5  0x00007f1f2bed10bb in ThreadWeaver::Thread::run() () from /usr/lib64/libthreadweaver.so.4
#6  0x00007f1f2f2b2ddb in ?? () from /usr/lib64/libQtCore.so.4
#7  0x00007f1f2cb7de0e in start_thread () from /lib64/libpthread.so.0
#8  0x00007f1f2ea522bd in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7f1edbde2700 (LWP 3932)):
#0  0x00007f1f2cb818f4 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f1f255d0177 in ?? () from /usr/lib64/libQtWebKit.so.4
#2  0x00007f1f255d01a9 in ?? () from /usr/lib64/libQtWebKit.so.4
#3  0x00007f1f2cb7de0e in start_thread () from /lib64/libpthread.so.0
#4  0x00007f1f2ea522bd in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7f1edabcb700 (LWP 3937)):
#0  0x00007f1f2ea23c9d in nanosleep () from /lib64/libc.so.6
#1  0x00007f1f2ea23b41 in sleep () from /lib64/libc.so.6
#2  0x00007f1f2af111c2 in ?? () from /usr/lib64/libQtScript.so.4
#3  0x00007f1f2af11249 in ?? () from /usr/lib64/libQtScript.so.4
#4  0x00007f1f2cb7de0e in start_thread () from /lib64/libpthread.so.0
#5  0x00007f1f2ea522bd in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f1f1cc77780 (LWP 3894)):
[KCrash Handler]
#5  0x0000000000000000 in ?? ()
#6  0x00007f1f30fde387 in qDeleteAll<QList<Collections::Collection*>::const_iterator> (end=..., begin=...) at /usr/include/QtCore/qalgorithms.h:322
#7  qDeleteAll<SmartPointerList<Collections::Collection> > (c=...) at /usr/include/QtCore/qalgorithms.h:330
#8  CollectionManager::~CollectionManager (this=0x1fa45c0, __in_chrg=<optimized out>) at /usr/src/debug/amarok-2.5.0/src/core-impl/collections/support/CollectionManager.cpp:137
#9  0x00007f1f30fde609 in CollectionManager::~CollectionManager (this=0x1fa45c0, __in_chrg=<optimized out>) at /usr/src/debug/amarok-2.5.0/src/core-impl/collections/support/CollectionManager.cpp:145
#10 0x00007f1f30fdc4a6 in CollectionManager::destroy () at /usr/src/debug/amarok-2.5.0/src/core-impl/collections/support/CollectionManager.cpp:107
#11 0x00007f1f31108c85 in App::~App (this=0x7fff2570fd90, __in_chrg=<optimized out>) at /usr/src/debug/amarok-2.5.0/src/App.cpp:248
#12 0x0000000000408f39 in main (argc=1, argv=0x7fff2570fef8) at /usr/src/debug/amarok-2.5.0/src/main.cpp:303

This bug may be a duplicate of or related to bug 314531.

Possible duplicates by query: bug 316512, bug 316321, bug 316271, bug 315667, bug 315285.

Reported using DrKonqi
Comment 1 Myriam Schweingruber 2013-03-16 17:49:49 UTC
Sorry, but your Amarok version is completely outdated and this bug is solve since quite some time. Please upgrade, the current version is Amarok 2.7

*** This bug has been marked as a duplicate of bug 285951 ***