Bug 316321 - Crash on exit
Summary: Crash on exit
Status: RESOLVED DUPLICATE of bug 285951
Alias: None
Product: amarok
Classification: Unclassified
Component: general (show other bugs)
Version: 2.5.0
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: 2.8
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-07 15:59 UTC by copiga
Modified: 2013-03-07 16:53 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description copiga 2013-03-07 15:59:42 UTC
Application: amarok (2.5.0)
KDE Platform Version: 4.8.5 (4.8.5) "release 2"
Qt Version: 4.8.1
Operating System: Linux 3.4.11-2.16-desktop x86_64
Distribution: "openSUSE 12.2 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:

Closing the application on opensuse 12.2 causes a segfault.

The crash can be reproduced every time.

-- Backtrace:
Application: Amarok (amarok), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f3e4f44a7c0 (LWP 32299))]

Thread 11 (Thread 0x7f3e2cf0f700 (LWP 32302)):
#0  0x00007f3e4bd6c14f in poll () from /lib64/libc.so.6
#1  0x00007f3e4377a08f in ?? () from /usr/lib64/libpulse.so.0
#2  0x00007f3e4376b5fc in pa_mainloop_poll () from /usr/lib64/libpulse.so.0
#3  0x00007f3e4376bc59 in pa_mainloop_iterate () from /usr/lib64/libpulse.so.0
#4  0x00007f3e4376bd10 in pa_mainloop_run () from /usr/lib64/libpulse.so.0
#5  0x00007f3e4377a03f in ?? () from /usr/lib64/libpulse.so.0
#6  0x00007f3e3f0042e3 in ?? () from /usr/lib64/libpulsecommon-1.1.so
#7  0x00007f3e3d422764 in ?? () from /usr/X11R6/lib64/libGL.so.1
#8  0x00007f3e49e77e0e in start_thread () from /lib64/libpthread.so.0
#9  0x00007f3e4bd742cd in clone () from /lib64/libc.so.6

Thread 10 (Thread 0x7f3e24dbf700 (LWP 32305)):
#0  0x00007f3e49e7ad9f in __pthread_mutex_unlock_usercnt () from /lib64/libpthread.so.0
#1  0x00007f3e45d864a1 in g_mutex_unlock () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f3e45d4a175 in g_main_context_check () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f3e45d4a622 in ?? () from /usr/lib64/libglib-2.0.so.0
#4  0x00007f3e45d4a7a4 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#5  0x00007f3e4c701956 in QEventDispatcherGlib::processEvents (this=0x7f3e18000930, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00007f3e4c6d273f in QEventLoop::processEvents (this=this@entry=0x7f3e24dbecf0, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f3e4c6d29c8 in QEventLoop::exec (this=0x7f3e24dbecf0, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007f3e4c5d6e40 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#9  0x00007f3e4c6b311f in QInotifyFileSystemWatcherEngine::run (this=0x20e44c0) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x00007f3e4c5d9ddb in QThreadPrivate::start (arg=0x20e44c0) at thread/qthread_unix.cpp:298
#11 0x00007f3e3d422764 in ?? () from /usr/X11R6/lib64/libGL.so.1
#12 0x00007f3e49e77e0e in start_thread () from /lib64/libpthread.so.0
#13 0x00007f3e4bd742cd in clone () from /lib64/libc.so.6

Thread 9 (Thread 0x7f3e1e747700 (LWP 32306)):
#0  0x00007f3e4bd80b00 in pthread_mutex_lock () from /lib64/libc.so.6
#1  0x00007f3e45d86471 in g_mutex_lock () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f3e45d4a66a in ?? () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f3e45d4a7a4 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#4  0x00007f3e4c701956 in QEventDispatcherGlib::processEvents (this=0x7f3e100008f0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#5  0x00007f3e4c6d273f in QEventLoop::processEvents (this=this@entry=0x7f3e1e746d20, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007f3e4c6d29c8 in QEventLoop::exec (this=0x7f3e1e746d20, flags=...) at kernel/qeventloop.cpp:204
#7  0x00007f3e4c5d6e40 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#8  0x00007f3e4c5d9ddb in QThreadPrivate::start (arg=0x2301010) at thread/qthread_unix.cpp:298
#9  0x00007f3e3d422764 in ?? () from /usr/X11R6/lib64/libGL.so.1
#10 0x00007f3e49e77e0e in start_thread () from /lib64/libpthread.so.0
#11 0x00007f3e4bd742cd in clone () from /lib64/libc.so.6

Thread 8 (Thread 0x7f3e1d8c7700 (LWP 32307)):
#0  0x00007f3e49e7ad9f in __pthread_mutex_unlock_usercnt () from /lib64/libpthread.so.0
#1  0x00007f3e45d864a1 in g_mutex_unlock () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f3e45d4a019 in g_main_context_query () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f3e45d4a5f9 in ?? () from /usr/lib64/libglib-2.0.so.0
#4  0x00007f3e45d4a7a4 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#5  0x00007f3e4c701956 in QEventDispatcherGlib::processEvents (this=0x7f3e140008f0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00007f3e4c6d273f in QEventLoop::processEvents (this=this@entry=0x7f3e1d8c6d20, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f3e4c6d29c8 in QEventLoop::exec (this=0x7f3e1d8c6d20, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007f3e4c5d6e40 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#9  0x00007f3e4c5d9ddb in QThreadPrivate::start (arg=0x22a23f0) at thread/qthread_unix.cpp:298
#10 0x00007f3e3d422764 in ?? () from /usr/X11R6/lib64/libGL.so.1
#11 0x00007f3e49e77e0e in start_thread () from /lib64/libpthread.so.0
#12 0x00007f3e4bd742cd in clone () from /lib64/libc.so.6

Thread 7 (Thread 0x7f3e0ffff700 (LWP 32309)):
#0  0x00007f3e49e7b8f4 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f3e4c5da2db in wait (time=18446744073709551615, this=0x22b1780) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x22b1900, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f3e491d2971 in ?? () from /usr/lib64/libthreadweaver.so.4
#4  0x00007f3e491d51bb in ?? () from /usr/lib64/libthreadweaver.so.4
#5  0x00007f3e491d51d4 in ?? () from /usr/lib64/libthreadweaver.so.4
#6  0x00007f3e491d402f in ?? () from /usr/lib64/libthreadweaver.so.4
#7  0x00007f3e491d40bb in ThreadWeaver::Thread::run() () from /usr/lib64/libthreadweaver.so.4
#8  0x00007f3e4c5d9ddb in QThreadPrivate::start (arg=0x2370af0) at thread/qthread_unix.cpp:298
#9  0x00007f3e3d422764 in ?? () from /usr/X11R6/lib64/libGL.so.1
#10 0x00007f3e49e77e0e in start_thread () from /lib64/libpthread.so.0
#11 0x00007f3e4bd742cd in clone () from /lib64/libc.so.6

Thread 6 (Thread 0x7f3e0ee3f700 (LWP 32310)):
#0  0x00007f3e49e7b8f4 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f3e4c5da2db in wait (time=18446744073709551615, this=0x22b1780) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x22b1900, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f3e491d2971 in ?? () from /usr/lib64/libthreadweaver.so.4
#4  0x00007f3e491d51bb in ?? () from /usr/lib64/libthreadweaver.so.4
#5  0x00007f3e491d402f in ?? () from /usr/lib64/libthreadweaver.so.4
#6  0x00007f3e491d40bb in ThreadWeaver::Thread::run() () from /usr/lib64/libthreadweaver.so.4
#7  0x00007f3e4c5d9ddb in QThreadPrivate::start (arg=0x26d26d0) at thread/qthread_unix.cpp:298
#8  0x00007f3e3d422764 in ?? () from /usr/X11R6/lib64/libGL.so.1
#9  0x00007f3e49e77e0e in start_thread () from /lib64/libpthread.so.0
#10 0x00007f3e4bd742cd in clone () from /lib64/libc.so.6

Thread 5 (Thread 0x7f3e0e63e700 (LWP 32311)):
#0  0x00007f3e49e7b8f4 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f3e4c5da2db in wait (time=18446744073709551615, this=0x22b1780) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x22b1900, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f3e491d2971 in ?? () from /usr/lib64/libthreadweaver.so.4
#4  0x00007f3e491d51bb in ?? () from /usr/lib64/libthreadweaver.so.4
#5  0x00007f3e491d51d4 in ?? () from /usr/lib64/libthreadweaver.so.4
#6  0x00007f3e491d402f in ?? () from /usr/lib64/libthreadweaver.so.4
#7  0x00007f3e491d40bb in ThreadWeaver::Thread::run() () from /usr/lib64/libthreadweaver.so.4
#8  0x00007f3e4c5d9ddb in QThreadPrivate::start (arg=0x26d5bb0) at thread/qthread_unix.cpp:298
#9  0x00007f3e3d422764 in ?? () from /usr/X11R6/lib64/libGL.so.1
#10 0x00007f3e49e77e0e in start_thread () from /lib64/libpthread.so.0
#11 0x00007f3e4bd742cd in clone () from /lib64/libc.so.6

Thread 4 (Thread 0x7f3e0de3d700 (LWP 32312)):
#0  0x00007f3e49e7b8f4 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f3e4c5da2db in wait (time=18446744073709551615, this=0x22b1780) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x22b1900, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f3e491d2971 in ?? () from /usr/lib64/libthreadweaver.so.4
#4  0x00007f3e491d51bb in ?? () from /usr/lib64/libthreadweaver.so.4
#5  0x00007f3e491d51d4 in ?? () from /usr/lib64/libthreadweaver.so.4
#6  0x00007f3e491d51d4 in ?? () from /usr/lib64/libthreadweaver.so.4
#7  0x00007f3e491d51d4 in ?? () from /usr/lib64/libthreadweaver.so.4
#8  0x00007f3e491d402f in ?? () from /usr/lib64/libthreadweaver.so.4
#9  0x00007f3e491d40bb in ThreadWeaver::Thread::run() () from /usr/lib64/libthreadweaver.so.4
#10 0x00007f3e4c5d9ddb in QThreadPrivate::start (arg=0x26fa690) at thread/qthread_unix.cpp:298
#11 0x00007f3e3d422764 in ?? () from /usr/X11R6/lib64/libGL.so.1
#12 0x00007f3e49e77e0e in start_thread () from /lib64/libpthread.so.0
#13 0x00007f3e4bd742cd in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7f3e0cfef700 (LWP 32313)):
#0  0x00007f3e49e7b8f4 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f3e42b6c177 in ?? () from /usr/lib64/libQtWebKit.so.4
#2  0x00007f3e42b6c1a9 in ?? () from /usr/lib64/libQtWebKit.so.4
#3  0x00007f3e3d422764 in ?? () from /usr/X11R6/lib64/libGL.so.1
#4  0x00007f3e49e77e0e in start_thread () from /lib64/libpthread.so.0
#5  0x00007f3e4bd742cd in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7f3dfb7fe700 (LWP 32316)):
#0  0x00007f3e4bd45cad in nanosleep () from /lib64/libc.so.6
#1  0x00007f3e4bd45b51 in sleep () from /lib64/libc.so.6
#2  0x00007f3e481fe1c2 in ?? () from /usr/lib64/libQtScript.so.4
#3  0x00007f3e481fe249 in ?? () from /usr/lib64/libQtScript.so.4
#4  0x00007f3e3d422764 in ?? () from /usr/X11R6/lib64/libGL.so.1
#5  0x00007f3e49e77e0e in start_thread () from /lib64/libpthread.so.0
#6  0x00007f3e4bd742cd in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f3e4f44a7c0 (LWP 32299)):
[KCrash Handler]
#5  0x00000000021b5918 in ?? ()
#6  0x00007f3e4e316387 in qDeleteAll<QList<Collections::Collection*>::const_iterator> (end=..., begin=...) at /usr/include/QtCore/qalgorithms.h:322
#7  qDeleteAll<SmartPointerList<Collections::Collection> > (c=...) at /usr/include/QtCore/qalgorithms.h:330
#8  CollectionManager::~CollectionManager (this=0x1fbb270, __in_chrg=<optimized out>) at /usr/src/debug/amarok-2.5.0/src/core-impl/collections/support/CollectionManager.cpp:137
#9  0x00007f3e4e316609 in CollectionManager::~CollectionManager (this=0x1fbb270, __in_chrg=<optimized out>) at /usr/src/debug/amarok-2.5.0/src/core-impl/collections/support/CollectionManager.cpp:145
#10 0x00007f3e4e3144a6 in CollectionManager::destroy () at /usr/src/debug/amarok-2.5.0/src/core-impl/collections/support/CollectionManager.cpp:107
#11 0x00007f3e4e440c85 in App::~App (this=0x7fffad446080, __in_chrg=<optimized out>) at /usr/src/debug/amarok-2.5.0/src/App.cpp:248
#12 0x0000000000408f39 in main (argc=1, argv=0x7fffad4461e8) at /usr/src/debug/amarok-2.5.0/src/main.cpp:303

This bug may be a duplicate of or related to bug 285951.

Possible duplicates by query: bug 316271, bug 315667, bug 315285, bug 314620, bug 314531.

Reported using DrKonqi
Comment 1 Myriam Schweingruber 2013-03-07 16:53:27 UTC
Please upgrade, your Amarok version is outdated. Current is Amarok 2.7

*** This bug has been marked as a duplicate of bug 285951 ***