Bug 316372 - Broken Desktop Switch On-Screen Display Animation
Summary: Broken Desktop Switch On-Screen Display Animation
Status: RESOLVED WORKSFORME
Alias: None
Product: kwin
Classification: Plasma
Component: scripting (show other bugs)
Version: 4.10.1
Platform: Archlinux Linux
: NOR normal with 3 votes (vote)
Target Milestone: 4.11
Assignee: KWin default assignee
URL:
Keywords:
: 319314 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-03-08 15:35 UTC by HT
Modified: 2015-12-08 16:06 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Video with desktop switching bug. (1.50 MB, video/ogg)
2013-03-08 15:38 UTC, HT
Details
Desktop name screenshot. (12.18 KB, image/png)
2013-08-20 06:08 UTC, HT
Details
desktop switch on-screen display (854.95 KB, image/png)
2013-10-12 19:09 UTC, Gaby
Details
desktop switch on-screen display (new size 1 min later) (854.13 KB, image/png)
2013-10-12 19:12 UTC, Gaby
Details
desktop switch on-screen display (new size 2 min later) (800.14 KB, image/png)
2013-10-12 19:14 UTC, Gaby
Details
patched window (14.26 KB, patch)
2013-10-13 16:50 UTC, Thomas Lübking
Details
Frame around (11.59 KB, image/png)
2013-10-14 06:20 UTC, HT
Details
patched OSD window for KF/5 (14.50 KB, text/plain)
2015-11-28 09:47 UTC, Thomas Lübking
Details

Note You need to log in before you can comment on or make changes to this bug.
Description HT 2013-03-08 15:35:50 UTC
Setting checkbox "Desktop switch on-screen Display" on (in System settings -> Workspace Behavior -> Virtual Desktops - Switching), cause broken switch indicator in the middle of screen when start switching between desktops. 

Tested with new .kde4 profile and with kwin, kwin_gles and opegl/xrandr compositing type. You can see bug in attached video.

Reproducible: Always

Steps to Reproduce:
1. Check on "Desktop switch on-screen Display" in System settings -> Workspace Behavior -> Virtual Desktops - Switching 
2. Uncheck "Desktop layout indicators is off" in System settings -> Workspace Behavior -> Virtual Desktops - Switching
3. Set more then one desktop.
4. Leave KDE (logout) and Start KDE (Login)
4. Switch between desktop 1-2-3 - in first (1-2) step You will see broken desktop indicator in the middle of screen. After switch next desktop is bug gone.


Expected Results:  
Display correct desktop number/name.
Comment 1 HT 2013-03-08 15:38:53 UTC
Created attachment 77861 [details]
Video with desktop switching bug.
Comment 2 S. Christian Collins 2013-03-10 05:02:37 UTC
I can confirm this bug on three different PCs, all running Kubuntu 12.04 upgraded to KDE 4.10.1.
Comment 3 Thomas Lübking 2013-03-10 07:06:44 UTC
Actually that's no effect, the window is really there.

Do you confirm the relogin being crucial to trigger this?
Comment 4 HT 2013-03-10 08:44:31 UTC
Don't known if I fully understood question but, the crucial trigger is kwin restart. This happens too when 
I switching between kwin and kwin_gles (using kwin --replace or kwin_gles --replace) in runnig KDE.
Comment 5 Martin Flöser 2013-03-10 09:12:10 UTC
Is this a regression compared to 4.10.0? I pushed some fixes for 4.10.1, maybe something went wrong.
Comment 6 Thomas Lübking 2013-03-10 10:11:36 UTC
What i can confirm is that when moving from initial VD3 or VD4 to VD1 (din't test VD2, though), there's no indicator.

Because of the absent name string:
Have you tried to pass your VDs original names?
("Surf", "Work", "Entertain" or sth. like that)
Comment 7 HT 2013-03-10 10:23:03 UTC
(In reply to comment #5)
> Is this a regression compared to 4.10.0? I pushed some fixes for 4.10.1,
> maybe something went wrong.

It's little bit different then in 4.10.0. First time I meet this bug in KDE 4.9 version, but I can't remeber whitch version it was.
Comment 8 Martin Flöser 2013-03-10 10:37:30 UTC
I just tried the steps to reproduce (restarted KWin instead of session) on master and are not able to reproduce.

Given that I backported the changes from master and that there are some further changes in master related to virtual desktops, I would not be surprised if it's really just an issue in 4.10.
Comment 9 HT 2013-03-10 10:57:35 UTC
(In reply to comment #6)
> What i can confirm is that when moving from initial VD3 or VD4 to VD1 (din't
> test VD2, though), there's no indicator.
> 
> Because of the absent name string:
> Have you tried to pass your VDs original names?
> ("Surf", "Work", "Entertain" or sth. like that)

Hmmm tested, and it looks like that bug is active when in the name of desktop is number with space (like Desktop 1) when I rename desktops to Desktop1 Desktop2.... bug is gone.
Comment 10 Thomas Lübking 2013-03-10 11:00:25 UTC
Seems to only affect implicit names then (but I can't reproduce that part of the video - git master as well)
Comment 11 Martin Flöser 2013-04-05 12:17:02 UTC
With current master there is a problem about the sizing but in the opposite direction.

Overall the code between 4.10 and master has diverged too much, so I make this a report about the issue in master and will not fix the issue in 4.10
Comment 12 Martin Flöser 2013-06-04 05:53:38 UTC
*** Bug 319314 has been marked as a duplicate of this bug. ***
Comment 13 Janet 2013-06-04 17:35:58 UTC
(In reply to comment #9)

> Hmmm tested, and it looks like that bug is active when in the name of
> desktop is number with space (like Desktop 1) when I rename desktops to
> Desktop1 Desktop2.... bug is gone.

Funny: It does work here with the space between word and number - but it does not work with German umlauts. Bug with "Arbeitsfläche 1" and "Arbeitsfläche 2" but no bug with "Arbeitsflaeche 1" and "Arbeitsflaeche 2"... It also depends on the number of virtual desktops, see Bug 319314.
Comment 14 Thomas Lübking 2013-06-04 18:42:36 UTC
Does it also happen when renaming the desktop to eg. "Cholemüs 1" "Cholemüs 2" etc? (I guess "Arbeitsfläche 1" will just be the i18n'ized default value, right?)
Comment 15 HT 2013-08-20 06:07:47 UTC
Using 4.11.0 now. Animation is solved, but window with desktop name looks ugly. Attachment added.

- Tested with new profile
- Using kwin_gles
- Driver radeon
Comment 16 HT 2013-08-20 06:08:43 UTC
Created attachment 81797 [details]
Desktop name screenshot.
Comment 17 Janet 2013-08-20 10:39:03 UTC
In reply of comment 14: It happend here with every name containing an umlaut.

(In reply to comment #16)
> Created attachment 81797 [details]
> Desktop name screenshot.

Well, yes, a little too much space at the bottom. Would look better with centered text and less height of the box. But  - it works :).
Comment 18 S. Christian Collins 2013-08-20 14:51:50 UTC
I can confirm this is happening for me as well in 4.11.
Comment 19 Gaby 2013-10-12 19:07:43 UTC
4.11.2 - same problem ... funny thing is that the size of the popup is constantly changing size
Comment 20 Gaby 2013-10-12 19:09:14 UTC
Created attachment 82807 [details]
desktop switch on-screen display
Comment 21 Gaby 2013-10-12 19:12:12 UTC
Created attachment 82808 [details]
desktop switch on-screen display (new size 1 min later)
Comment 22 Gaby 2013-10-12 19:14:33 UTC
Created attachment 82809 [details]
desktop switch on-screen display (new size 2 min later)
Comment 23 Gaby 2013-10-12 19:17:48 UTC
Any time you change "something" in system settings -> virtual desktops -> switching .. shape varies
Happens to me after I accidentally killed (Ctrl-Alt-Esc) the desktop (the background) and had to restart via Ctrl-Alt-F1 -> Ctrl->Alt-F6 (reboot)
Comment 24 Janet 2013-10-13 07:58:18 UTC
(In reply to comment #19)
> 4.11.2 - same problem ... funny thing is that the size of the popup is
> constantly changing size

I cannot confirm this. I am also using 4.11.2 (in siduction) and the space below the desktop name is gone in my current plasma theme after I temporarily activated the preview for the on-screen display, tested it and deactivated the preview again. It also was gone in other themes - so it might be a cache issue?
Comment 25 Thomas Lübking 2013-10-13 16:50:50 UTC
Created attachment 82829 [details]
patched window

random guess (only size, not Umlaute)
replace /usr/share/apps/kwin/scripts/desktopchangeosd/contents/ui/osd.qml with the attached version, then restart "kwin --replace &"
Comment 26 HT 2013-10-13 18:12:56 UTC
(In reply to comment #25)
> Created attachment 82829 [details]
> patched window
> 
> random guess (only size, not Umlaute)
> replace /usr/share/apps/kwin/scripts/desktopchangeosd/contents/ui/osd.qml
> with the attached version, then restart "kwin --replace &"

It Works! But smaller font will be better.
Thanks
Comment 27 Thomas Lübking 2013-10-13 18:45:16 UTC
alter "font.pointSize: dialogItem.showGrid ? font.pointSize : 32"
to eg. "font.pointSize: dialogItem.showGrid ? font.pointSize : 18"

I just felt it was too tiny to be really a usable indicator in this context.
Comment 28 HT 2013-10-14 06:18:33 UTC
(In reply to comment #27)
> alter "font.pointSize: dialogItem.showGrid ? font.pointSize : 32"
> to eg. "font.pointSize: dialogItem.showGrid ? font.pointSize : 18"
> 
> I just felt it was too tiny to be really a usable indicator in this context.

Thanks for tip. For me small font looks better.

One another question, is possible to have smaller frame? Height is too big with smaller fonts. It seems, that width of frame is adjustable but height is not. Screenshot attached.

Thanks.
Comment 29 HT 2013-10-14 06:20:41 UTC
Created attachment 82836 [details]
Frame around
Comment 30 Janet 2013-10-14 10:51:21 UTC
The default font size really is big and therefore looks a bit unfamiliar. But I like that it is now possible to better read it and I like  a lot that it is configurable! With the default font size the proportion of the text in relation to the surrounding box is perfect - and this ratio should be kept with every chosen font size.
Comment 31 Thomas Lübking 2013-10-14 17:17:58 UTC
Tried, as soon as i set the pointSize  > 2 the window seems to get a minimum height - even if i set another explicit size for label and mainItem.

Attaching Marco.
Is there somehow a conditional minimum size/height in the plasma dialog component?
Comment 32 Gernot Wieprecht 2014-02-03 20:04:27 UTC
My daughter just installed the patched osd.qml file on my system and pointed me to this bug report. I really love the big font, finally the text is good readable for me. 

If I understand it right this new feature by now will be overwritten each time the system is updated and after that the file has to be copied again or at least the font size has to be entered again in the text file?

I'd really would be very glad if you can implement this new feature together with a configuration option for the font size so that it does not get overwritten on updates. 

Thanks for your time and efforts.
Comment 33 Thomas Lübking 2014-02-03 21:12:39 UTC
cp -r /usr/share/apps/kwin/scripts/desktopchangeosd ~/.kde/share/kwin/scripts
This should make the local version shadow the global one.

NOTICE:
-------------
- might be rather ~/.kde4
- you might have to create kwin/scripts directories
- any pot. improvement to the global version will be lost by this (well, until you remove the patched version)
Comment 34 Martin Flöser 2014-02-04 07:09:48 UTC
> cp -r /usr/share/apps/kwin/scripts/desktopchangeosd
> ~/.kde/share/kwin/scripts This should make the local version shadow the
> global one.
> 
> NOTICE:
> -------------
> - might be rather ~/.kde4
> - you might have to create kwin/scripts directories
> - any pot. improvement to the global version will be lost by this (well,
> until you remove the patched version)

The last one doesn't really matter. There won't be any improvements for the 
4.x version and the 5.x version won't use .kde[4] folders any more.
Comment 35 Janet 2015-11-28 01:04:49 UTC
(In reply to Thomas Lübking from comment #27)
> alter "font.pointSize: dialogItem.showGrid ? font.pointSize : 32"

This line doesn't seem to work in Plasma 5? The osd.qml file in Plasma 5 already contains the nice big 32 font.pointSize but the font nonetheless is tiny. I copied the file to ~/.local/share.....same structure... and altered the number - but after a "kwin --replace" still no change :(. 

How do I get the big font in Plasma 5?
Comment 36 Thomas Lübking 2015-11-28 09:47:26 UTC
Created attachment 95780 [details]
patched OSD window for KF/5

cp -r /usr/share/kwin/scripts/desktopchangeosd/ ~/.local/share/kwin/scripts
and replace  ~/.local/share/kwin/scripts/desktopchangeosd/contents/ui/osd.qml with the attachment. Then restart "kwin_x11 --replace &"

The KDE4 version should not work and the vanilla KDE5 version does not have an increased font size.

All concerns reg. the shadow (and the partially unwanted 32pt font ;-) remain.

Do we have other bugs itr. left, ie. is this bug actually open in KF5 (leaving the font size aside)
Comment 37 Janet 2015-11-29 00:24:28 UTC
Great, that works! Thanks a lot for the new file! And leaving the font size aside this bug seems to be fixed in KF/Plasma 5, at least I couldn't reproduce the faulty behaviour so far.
Comment 38 Thomas Lübking 2015-12-08 16:06:15 UTC
Ok, thanks.
Closing "worksforme" then.

As of any "Desktop switching OSD is ugly, should have bigger fonts, ..." concerns, please file a new bug (we maybe need to involve HIG and VDG members and I don't want to scare them off by the technical elements in this bug ;-)
Comment 39 Thomas Lübking 2015-12-08 16:06:30 UTC
Ok, thanks.
Closing "worksforme" then.

As of any "Desktop switching OSD is ugly, should have bigger fonts, ..." concerns, please file a new bug (we maybe need to involve HIG and VDG members and I don't want to scare them off by the technical elements in this bug ;-)