Bug 315605 - krarc doesn't handle archive files containing paths with "." as a component
Summary: krarc doesn't handle archive files containing paths with "." as a component
Status: RESOLVED LATER
Alias: None
Product: krusader
Classification: Applications
Component: krarc (show other bugs)
Version: Git
Platform: Other Linux
: NOR major (vote)
Target Milestone: ---
Assignee: Krusader Bugs Distribution List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-21 22:41 UTC by Jan Lepper
Modified: 2018-05-06 00:15 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Lepper 2013-02-21 22:41:34 UTC
If krarc encounters a path with "." as a component like "./foo/bar" it aborts with an 'internal error' message.
This is due to the way in which krarc handles paths and cannot be easily resolved.
The error message was added in response to bug 315357 as not to silently fail.

A fix is unlikely to happen before a krarc rewrite.


Reproducible: Always