Bug 315357 - krusader opens some zip files and says it contains no file but actually does
Summary: krusader opens some zip files and says it contains no file but actually does
Status: RESOLVED FIXED
Alias: None
Product: krusader
Classification: Applications
Component: krarc (show other bugs)
Version: 2.4.0-beta3 "Single Step"
Platform: OpenSUSE Linux
: NOR critical (vote)
Target Milestone: ---
Assignee: Krusader Bugs Distribution List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-18 04:48 UTC by Bruce Ouyang
Modified: 2018-05-06 00:15 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
the zip file which krusader can not handle well. (44.17 KB, application/zip)
2013-02-18 04:49 UTC, Bruce Ouyang
Details
ark can handle this zip file very well (75.13 KB, image/png)
2013-02-18 04:50 UTC, Bruce Ouyang
Details
but krusader say no file exists in this zip file. (19.22 KB, image/png)
2013-02-18 04:51 UTC, Bruce Ouyang
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bruce Ouyang 2013-02-18 04:48:20 UTC
there are a zip file, if i opened it with Ark, everything is ok and i can see it actually contains some files. but if i opened it with krusader,  no files is displayed , just like they do not exist in the zip file.

Reproducible: Always
Comment 1 Bruce Ouyang 2013-02-18 04:49:30 UTC
Created attachment 77392 [details]
the zip file which krusader can not handle well.
Comment 2 Bruce Ouyang 2013-02-18 04:50:34 UTC
Created attachment 77393 [details]
ark can handle this zip file very well
Comment 3 Bruce Ouyang 2013-02-18 04:51:53 UTC
Created attachment 77394 [details]
but krusader say  no file exists in this zip file.
Comment 4 Jan Lepper 2013-02-21 22:24:27 UTC
Git commit 3ee6a5dae58bce2b3335ce93a2d64e63ca656393 by Jan Lepper.
Committed on 21/02/2013 at 23:22.
Pushed by janlepper into branch 'master'.

FIXED: [ 315357 ] krarc silently fails to display contents of some zip files

Zip files containing paths with "." as a path component are still not handled,
but now krarc reports an error instead silently failing.

M  +3    -0    ChangeLog
M  +10   -5    krArc/krarc.cpp

http://commits.kde.org/krusader/3ee6a5dae58bce2b3335ce93a2d64e63ca656393
Comment 5 Jan Lepper 2013-02-21 22:44:00 UTC
Since the underlying issue hasn't been fixed, I added a new bug report for that: https://bugs.kde.org/show_bug.cgi?id=315605