Bug 315247 - Sort photos by exif creation date
Summary: Sort photos by exif creation date
Status: RESOLVED DUPLICATE of bug 125790
Alias: None
Product: digikam
Classification: Unclassified
Component: Searches-Dates (show other bugs)
Version: 2.8.0
Platform: Ubuntu Packages Linux
: NOR wishlist with 21 votes (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-15 23:56 UTC by Cambenora
Modified: 2014-08-23 11:27 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cambenora 2013-02-15 23:56:11 UTC
Add an option to sort photos by the date recorded in the image metadata.

Reproducible: Always

Actual Results:  
Currently, "sort by date" sorts photos by the file date. Whilst this normally equates to the same as the exif date, it can change if the file has been modified. Therefore the file is then sorted out of order in respect to the date the photo was taken.
Comment 1 caulier.gilles 2013-02-16 09:17:50 UTC
Which type of files you have in your collection ?

Sort by date use time-stamp of photo registered in database. This info is take from photo metadata in first or, if metadata are not available, from file system date.

Gilles Caulier
Comment 2 Cambenora 2013-02-16 10:13:20 UTC
Hello Gilles

I have jpeg files taken from a digital camera (Fujifilm FinePix AV100).
I've attached one as an example.


-- Andy
--



On Sat, Feb 16, 2013 at 8:17 PM, Gilles Caulier <caulier.gilles@gmail.com>wrote:

> https://bugs.kde.org/show_bug.cgi?id=315247
>
> Gilles Caulier <caulier.gilles@gmail.com> changed:
>
>            What    |Removed                     |Added
>
> ----------------------------------------------------------------------------
>                  CC|                            |caulier.gilles@gmail.com
>           Component|Albums GUI                  |Dates
>
> --- Comment #1 from Gilles Caulier <caulier.gilles@gmail.com> ---
> Which type of files you have in your collection ?
>
> Sort by date use time-stamp of photo registered in database. This info is
> take
> from photo metadata in first or, if metadata are not available, from file
> system date.
>
> Gilles Caulier
>
> --
> You are receiving this mail because:
> You reported the bug.
>
Comment 3 Cambenora 2013-02-16 10:17:21 UTC
Hello, Gilles

I have jpeg files from a digital camera (Fulifilm FinePix AV100)

Hope that helps.

-- Andy
--



On Sat, Feb 16, 2013 at 8:17 PM, Gilles Caulier <caulier.gilles@gmail.com>wrote:

> https://bugs.kde.org/show_bug.cgi?id=315247
>
> Gilles Caulier <caulier.gilles@gmail.com> changed:
>
>            What    |Removed                     |Added
>
> ----------------------------------------------------------------------------
>                  CC|                            |caulier.gilles@gmail.com
>           Component|Albums GUI                  |Dates
>
> --- Comment #1 from Gilles Caulier <caulier.gilles@gmail.com> ---
> Which type of files you have in your collection ?
>
> Sort by date use time-stamp of photo registered in database. This info is
> take
> from photo metadata in first or, if metadata are not available, from file
> system date.
>
> Gilles Caulier
>
> --
> You are receiving this mail because:
> You reported the bug.
>
Comment 4 Thomas Kuther 2013-03-04 19:34:18 UTC
Instead of opening a new bug, I'll jump in here.

I also desperately need an option to sort by EXIF DateTimeOriginal. My RAW converter (correctly, as per EXIF standard) re-sets DateTime when exporting to JPEG. The original date is in the DateTimeOriginal tag.

Actually, in "Settings -> Album view settings", there is a tickbox for "camera creation time", but this picks the wrong tag. The coolest thing would be to get this fixed, and additionally add an option to "View -> Album sorting" menu for DateTime (original)

See for example Gwenview bug 281720 where this has been done.

A related digikam bug is 139264
Comment 5 Wulf Bolte 2013-07-26 08:25:58 UTC
The import feature also makes this mistake and creates sub-albums by modify date - not as axpected by creation date...
makes the import unusable for me...
Comment 6 caulier.gilles 2014-08-23 11:27:11 UTC

*** This bug has been marked as a duplicate of bug 125790 ***