Bug 313947 - Add new toolbar button to change Labels, at new digiKam session button do not appear until make another change in toolbar
Summary: Add new toolbar button to change Labels, at new digiKam session button do not...
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Albums-MainView (show other bugs)
Version: 3.0.0
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-27 03:05 UTC by Stas
Modified: 2014-09-13 08:44 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 4.4.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stas 2013-01-27 03:05:50 UTC
Hello,

I have made items in the toolbar for labeling and rating the pics and after a restart they do not appear in the toolbar.

I have to make one change and then all the elements appear again.

It does not happen for other elements added to the toolbar.

Maybe this happens because I have made following changes to the tagsactionmngr.cpp file to be able to change shortcuts for labeling and rating the pics:
Line 190, 210, 230 : change "flase" to "true"
See this bug for more information: https://bugs.kde.org/show_bug.cgi?id=313856

I also noticed, that my added shortcuts for this elements (labeling and rating) also only appear after make a change to the toolbar.

I wonder if this will happen, when compile without the changes but hope, that this can be changed easily  and the option mentioned in the other bug can be re enabled as default feature.

Thanks.

Reproducible: Always
Comment 1 caulier.gilles 2013-11-25 17:26:00 UTC
Stas,

Whats about this file with digiKam 3.5.0 ?

Gilles Caulier
Comment 2 caulier.gilles 2014-08-31 17:31:41 UTC
Stats,

This file still valid using last digiKam 4.2.0 ?

Gilles Caulier
Comment 3 caulier.gilles 2014-09-13 08:44:43 UTC
Since bug #313856, i cannot reproduce this dysfunction with current implementation from git/master.

Gilles Caulier