Bug 313856 - Re-enable the possibility to set up the shortcuts for rating and labeling (color and pick)
Summary: Re-enable the possibility to set up the shortcuts for rating and labeling (co...
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Usability-Keyboard (show other bugs)
Version: 3.2.0
Platform: unspecified All
: NOR wishlist with 30 votes (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-24 23:46 UTC by Stas
Modified: 2017-08-02 17:42 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.0.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stas 2013-01-24 23:46:28 UTC
Hello, for me now I have to compile digikam on my own because I miss the possibility to set the shortcuts for rating pictures and set labels.

When sorting 1000 and more pics pressing the CTRL button every time to rate the picture is horrible.

I have found a thread, where the solution is given. This are only three values in the source code to be changed to true. In the "tagsactionmngr.cpp" file. For Rating Color and Pick Labels.

http://digikam.1695700.n4.nabble.com/Rating-shortcuts-td4297121.html

It would be a great help for me and I think for more people when you would give us the course to decide how we want to set up our shortcuts. Especially it is done in 2 minutes for you in the active development version.

Thanks.

Reproducible: Always
Comment 1 Stas 2013-01-25 02:05:34 UTC
Hello, I have now tried to compile digikam 3.0 rc with the applied changes (see above). I now can change the shortcuts but the changes are not saved (only rating and labels shortcuts).

So I think it is no as easy as I thought now, but it would be still very welcome to have this feature back.
Comment 2 Anton 2013-09-11 07:00:24 UTC
You never know what you'll face after update.

Dear developers.
You created very good soft to manage photos, to organize them. Thank you a lot.

I use free software and I'm proud that it's possible to do all cycle from raw file to web and prints here, at linux.

Have not updated digikam since 2011 - it works, and I have no problems. (Can't say I do not shoot - it's about 10-15k of images in a year in database after clean-ups).

And, finally, I've reinstalled system and got fresh Digikam. 
With all respect - this thing, uncostomizable shortcuts, is horrible.
People use star rating to manage sessions of thousands images - and now its VERY uncomfortable.

Please, make that patch, that was found by Stas in archieve.
Comment 3 Wulf 2013-12-06 09:37:42 UTC
*** This bug has been confirmed by popular vote. ***
Comment 4 caulier.gilles 2013-12-18 17:32:57 UTC
Git commit f0738406bae6d719499c5040a0305d9f2d2c3049 by Gilles Caulier.
Committed on 18/12/2013 at 17:27.
Pushed by cgilles into branch 'master'.

Make Labels keyboard shorcuts configurable by end user into KDE config panel of each root digiKam window.
This include Rating, Color, and Pick Labels.
Unlike tag action shortcuts which are stored in digiKam DB, Labels action shortcuts are stored in each
XML GUI config file of each root digiKam window.
Because each root window manage shortcut individually for relevant GUI, you need to apply a keyboard shortcut
change in each root window setup, to be homogenous everywhere.
FIXED-IN: 4.0.0

M  +8    -4    digikam/main/digikamapp.cpp
M  +18   -28   digikam/tags/tagsactionmngr.cpp
M  +12   -8    digikam/tags/tagsactionmngr.h
M  +4    -0    utilities/imageeditor/main/imagewindow.cpp
M  +4    -0    utilities/lighttable/lighttablewindow.cpp

http://commits.kde.org/digikam/f0738406bae6d719499c5040a0305d9f2d2c3049