Bug 313143 - Korganizer seg fault on disabling calendar
Summary: Korganizer seg fault on disabling calendar
Status: RESOLVED FIXED
Alias: None
Product: korganizer
Classification: Applications
Component: general (show other bugs)
Version: 4.9.3
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-12 18:55 UTC by Michael Hammond
Modified: 2013-01-13 03:34 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.10.0


Attachments
New crash information added by DrKonqi (11.38 KB, text/plain)
2013-01-12 19:00 UTC, Michael Hammond
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Hammond 2013-01-12 18:55:59 UTC
Application: korganizer (4.9.3)
KDE Platform Version: 4.9.3
Qt Version: 4.8.3
Operating System: Linux 3.5.0-21-generic x86_64
Distribution: Ubuntu 12.10

-- Information about the crash:
- What I was doing when the application crashed:
Iterating down the list of my local and WebDAV calendars, disabling them to minimize the events shown while I dealt with one particular calendar.  Got to a local calendar after closing a WebDAV calendar and when I disabled the local calendar, Korganizer seg faulted

The crash can be reproduced every time.

-- Backtrace:
Application: KOrganizer (korganizer), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f4c569da7c0 (LWP 5332))]

Thread 2 (Thread 0x7f4c4efbe700 (LWP 5415)):
#0  0x00007f4c6743f303 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f4c6012ed84 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f4c6012eea4 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f4c68a81c16 in QEventDispatcherGlib::processEvents (this=0x7f4c480008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f4c68a522bf in QEventLoop::processEvents (this=this@entry=0x7f4c4efbdd90, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f4c68a52548 in QEventLoop::exec (this=0x7f4c4efbdd90, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f4c68953b10 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f4c68a329af in QInotifyFileSystemWatcherEngine::run (this=0x1288480) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f4c68956aec in QThreadPrivate::start (arg=0x1288480) at thread/qthread_unix.cpp:338
#9  0x00007f4c609f5e9a in start_thread (arg=0x7f4c4efbe700) at pthread_create.c:308
#10 0x00007f4c6744acbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f4c569da7c0 (LWP 5332)):
[KCrash Handler]
#6  size (this=0x21) at ../../include/QtCore/../../src/corelib/tools/qvector.h:137
#7  QSortFilterProxyModelPrivate::proxy_to_source (this=0xf84580, proxy_index=...) at itemviews/qsortfilterproxymodel.cpp:370
#8  0x00007f4c6838695d in QSortFilterProxyModel::mapToSource (this=<optimized out>, proxyIndex=...) at itemviews/qsortfilterproxymodel.cpp:2503
#9  0x00007f4c68387ab1 in QSortFilterProxyModelPrivate::store_persistent_indexes (this=this@entry=0xf84580) at itemviews/qsortfilterproxymodel.cpp:996
#10 0x00007f4c6838bce3 in QSortFilterProxyModelPrivate::_q_sourceDataChanged (this=0xf84580, source_top_left=..., source_bottom_right=...) at itemviews/qsortfilterproxymodel.cpp:1161
#11 0x00007f4c68a68f5f in QMetaObject::activate (sender=0xf64eb0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffd7c8c9c0) at kernel/qobject.cpp:3547
#12 0x00007f4c68ab2aa7 in QAbstractItemModel::dataChanged (this=<optimized out>, _t1=..., _t2=...) at .moc/release-shared/moc_qabstractitemmodel.cpp:164
#13 0x00007f4c69798496 in KOTodoModel::reloadTodos (this=0xf64eb0) at ../../korganizer/views/todoview/kotodomodel.cpp:252
#14 0x00007f4c69708383 in CalendarView::updateView (this=this@entry=0xe04810, start=..., end=..., preferredMonth=..., updateTodos=updateTodos@entry=true) at ../../korganizer/calendarview.cpp:848
#15 0x00007f4c6970b62a in CalendarView::updateView (this=0xe04810) at ../../korganizer/calendarview.cpp:866
#16 0x00007f4c6971cfd2 in CalendarView::qt_static_metacall (_o=0xe04810, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at ./calendarview.moc:574
#17 0x00007f4c68a68f5f in QMetaObject::activate (sender=0x126b0a0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3547
#18 0x00007f4c6259094a in CalendarSupport::Calendar::Private::itemsRemoved (this=this@entry=0x1262e80, items=...) at ../../calendarsupport/calendar.cpp:645
#19 0x00007f4c6259118a in CalendarSupport::Calendar::Private::rowsAboutToBeRemoved (this=0x1262e80, parent=..., start=<optimized out>, end=<optimized out>) at ../../calendarsupport/calendar.cpp:128
#20 0x00007f4c68a68f5f in QMetaObject::activate (sender=0x12620f0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffd7c8d180) at kernel/qobject.cpp:3547
#21 0x00007f4c68ab2c34 in QAbstractItemModel::rowsAboutToBeRemoved (this=<optimized out>, _t1=..., _t2=0, _t3=14) at .moc/release-shared/moc_qabstractitemmodel.cpp:204
#22 0x00007f4c68a4ad06 in QAbstractItemModel::beginRemoveRows (this=0x12620f0, parent=..., first=0, last=14) at kernel/qabstractitemmodel.cpp:2470
#23 0x00007f4c68386df5 in QSortFilterProxyModelPrivate::remove_proxy_interval (this=0x1262110, source_to_proxy=..., proxy_to_source=..., proxy_start=0, proxy_end=<optimized out>, proxy_parent=..., orient=Qt::Vertical, emit_signal=true) at itemviews/qsortfilterproxymodel.cpp:557
#24 0x00007f4c6838b58a in QSortFilterProxyModelPrivate::remove_source_items (this=this@entry=0x1262110, source_to_proxy=..., proxy_to_source=..., source_items=..., source_parent=..., orient=orient@entry=Qt::Vertical, emit_signal=emit_signal@entry=true) at itemviews/qsortfilterproxymodel.cpp:539
#25 0x00007f4c6838cc6d in QSortFilterProxyModelPrivate::source_items_about_to_be_removed (this=0x1262110, source_parent=..., start=0, end=14, orient=Qt::Vertical) at itemviews/qsortfilterproxymodel.cpp:840
#26 0x00007f4c68a68f5f in QMetaObject::activate (sender=0x12615d0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffd7c8d4d0) at kernel/qobject.cpp:3547
#27 0x00007f4c68ab2c34 in QAbstractItemModel::rowsAboutToBeRemoved (this=<optimized out>, _t1=..., _t2=0, _t3=14) at .moc/release-shared/moc_qabstractitemmodel.cpp:204
#28 0x00007f4c68a4ad06 in QAbstractItemModel::beginRemoveRows (this=0x12615d0, parent=..., first=0, last=14) at kernel/qabstractitemmodel.cpp:2470
#29 0x00007f4c6a813f34 in KSelectionProxyModelPrivate::removeRangeFromProxy (this=this@entry=0x1261880, range=...) at ../../kdeui/itemviews/kselectionproxymodel.cpp:1714
#30 0x00007f4c6a814a54 in KSelectionProxyModelPrivate::removeSelectionFromProxy (this=this@entry=0x1261880, selection=...) at ../../kdeui/itemviews/kselectionproxymodel.cpp:1637
#31 0x00007f4c6a816613 in KSelectionProxyModelPrivate::selectionChanged (this=0x1261880, _selected=..., _deselected=...) at ../../kdeui/itemviews/kselectionproxymodel.cpp:1887
#32 0x00007f4c68a68f5f in QMetaObject::activate (sender=0x127c720, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffd7c8dbb0) at kernel/qobject.cpp:3547
#33 0x00007f4c68359077 in QItemSelectionModel::selectionChanged (this=this@entry=0x127c720, _t1=..., _t2=...) at .moc/release-shared/moc_qitemselectionmodel.cpp:166
#34 0x00007f4c6835e1ed in QItemSelectionModel::emitSelectionChanged (this=this@entry=0x127c720, newSelection=..., oldSelection=...) at itemviews/qitemselectionmodel.cpp:1600
#35 0x00007f4c6835eedc in QItemSelectionModel::select (this=0x127c720, selection=..., command=...) at itemviews/qitemselectionmodel.cpp:1110
#36 0x00007f4c6a7e7fad in KCheckableProxyModel::select (this=this@entry=0xda3ec0, selection=..., command=...) at ../../kdeui/itemviews/kcheckableproxymodel.cpp:130
#37 0x00007f4c6a7e822e in KCheckableProxyModel::setData (this=0xda3ec0, index=..., value=..., role=<optimized out>) at ../../kdeui/itemviews/kcheckableproxymodel.cpp:105
#38 0x00007f4c6838553e in QSortFilterProxyModel::setData (this=<optimized out>, index=..., value=..., role=10) at itemviews/qsortfilterproxymodel.cpp:1731
#39 0x00007f4c6838553e in QSortFilterProxyModel::setData (this=<optimized out>, index=..., value=..., role=10) at itemviews/qsortfilterproxymodel.cpp:1731
#40 0x00007f4c6838553e in QSortFilterProxyModel::setData (this=this@entry=0x124ea10, index=..., value=..., role=role@entry=10) at itemviews/qsortfilterproxymodel.cpp:1731
#41 0x00007f4c683a6ab5 in QStyledItemDelegate::editorEvent (this=0x124e710, event=0x7fffd7c8eec0, model=0x124ea10, option=..., index=...) at itemviews/qstyleditemdelegate.cpp:758
#42 0x00007f4c68306167 in QAbstractItemViewPrivate::sendDelegateEvent (this=this@entry=0x1240460, index=..., event=event@entry=0x7fffd7c8eec0) at itemviews/qabstractitemview.cpp:4184
#43 0x00007f4c6830c45c in QAbstractItemView::edit (this=this@entry=0x123f3a0, index=..., trigger=trigger@entry=QAbstractItemView::NoEditTriggers, event=event@entry=0x7fffd7c8eec0) at itemviews/qabstractitemview.cpp:2560
#44 0x00007f4c683066a0 in QAbstractItemView::mouseReleaseEvent (this=0x123f3a0, event=0x7fffd7c8eec0) at itemviews/qabstractitemview.cpp:1802
#45 0x00007f4c67e4a850 in QWidget::event (this=0x123f3a0, event=0x7fffd7c8eec0) at kernel/qwidget.cpp:8371
#46 0x00007f4c681f9b66 in QFrame::event (this=0x123f3a0, e=0x7fffd7c8eec0) at widgets/qframe.cpp:557
#47 0x00007f4c6830559b in QAbstractItemView::viewportEvent (this=0x123f3a0, event=0x7fffd7c8eec0) at itemviews/qabstractitemview.cpp:1644
#48 0x00007f4c68349d81 in QTreeView::viewportEvent (this=0x123f3a0, event=0x7fffd7c8eec0) at itemviews/qtreeview.cpp:1257
#49 0x00007f4c68a536d6 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<optimized out>, receiver=0x1240ad0, event=0x7fffd7c8eec0) at kernel/qcoreapplication.cpp:1025
#50 0x00007f4c67dfae6c in QApplicationPrivate::notify_helper (this=this@entry=0xcc6890, receiver=receiver@entry=0x1240ad0, e=e@entry=0x7fffd7c8eec0) at kernel/qapplication.cpp:4558
#51 0x00007f4c67dffb6b in QApplication::notify (this=<optimized out>, receiver=0x1240ad0, e=0x7fffd7c8eec0) at kernel/qapplication.cpp:4105
#52 0x00007f4c6a8271d6 in KApplication::notify (this=0x7fffd7c8fc70, receiver=0x1240ad0, event=0x7fffd7c8eec0) at ../../kdeui/kernel/kapplication.cpp:311
#53 0x00007f4c68a5356e in QCoreApplication::notifyInternal (this=0x7fffd7c8fc70, receiver=0x1240ad0, event=0x7fffd7c8eec0) at kernel/qcoreapplication.cpp:915
#54 0x00007f4c67dfbcd3 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#55 QApplicationPrivate::sendMouseEvent (receiver=0x1240ad0, event=0x7fffd7c8eec0, alienWidget=0x1240ad0, nativeWidget=0xdabbd0, buttonDown=0x7f4c688d7308 <qt_button_down>, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3173
#56 0x00007f4c67e79554 in QETWidget::translateMouseEvent (this=this@entry=0xdabbd0, event=event@entry=0x7fffd7c8f640) at kernel/qapplication_x11.cpp:4622
#57 0x00007f4c67e7844f in QApplication::x11ProcessEvent (this=0x7fffd7c8fc70, event=0x7fffd7c8f640) at kernel/qapplication_x11.cpp:3737
#58 0x00007f4c67e9ffa2 in x11EventSourceDispatch (s=0xccdd70, callback=0x0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#59 0x00007f4c6012eab5 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#60 0x00007f4c6012ede8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#61 0x00007f4c6012eea4 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#62 0x00007f4c68a81bf6 in QEventDispatcherGlib::processEvents (this=0xc90b60, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#63 0x00007f4c67e9fc1e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#64 0x00007f4c68a522bf in QEventLoop::processEvents (this=this@entry=0x7fffd7c8fa10, flags=...) at kernel/qeventloop.cpp:149
#65 0x00007f4c68a52548 in QEventLoop::exec (this=0x7fffd7c8fa10, flags=...) at kernel/qeventloop.cpp:204
#66 0x00007f4c68a57708 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1187
#67 0x0000000000407d36 in main (argc=<optimized out>, argv=<optimized out>) at ../../korganizer/main.cpp:59

This bug may be a duplicate of or related to bug 311153.

Possible duplicates by query: bug 311153, bug 307026, bug 305924, bug 304849, bug 304582.

Reported using DrKonqi
Comment 1 Michael Hammond 2013-01-12 19:00:15 UTC
Created attachment 76424 [details]
New crash information added by DrKonqi

korganizer (4.9.3) on KDE Platform 4.9.3 using Qt 4.8.3

- What I was doing when the application crashed:

Disabled other local calendars - no issue, crash only occurs when closing "House"

-- Backtrace (Reduced):
#6  size (this=0x51) at ../../include/QtCore/../../src/corelib/tools/qvector.h:137
#7  QSortFilterProxyModelPrivate::proxy_to_source (this=0x1985620, proxy_index=...) at itemviews/qsortfilterproxymodel.cpp:370
#8  0x00007fc60ad5995d in QSortFilterProxyModel::mapToSource (this=<optimized out>, proxyIndex=...) at itemviews/qsortfilterproxymodel.cpp:2503
#9  0x00007fc60ad5aab1 in QSortFilterProxyModelPrivate::store_persistent_indexes (this=this@entry=0x1985620) at itemviews/qsortfilterproxymodel.cpp:996
#10 0x00007fc60ad5ece3 in QSortFilterProxyModelPrivate::_q_sourceDataChanged (this=0x1985620, source_top_left=..., source_bottom_right=...) at itemviews/qsortfilterproxymodel.cpp:1161
Comment 2 Sergio Martins 2013-01-13 03:19:05 UTC
Fixed in 4.10