Bug 304582 - zarafa IMAP account
Summary: zarafa IMAP account
Status: RESOLVED DUPLICATE of bug 275662
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.8.4
Platform: openSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-05 00:06 UTC by Peter Fritz
Modified: 2012-08-14 21:38 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Fritz 2012-08-05 00:06:16 UTC
Application: kontact (4.8.4)
KDE Platform Version: 4.8.4 (4.8.4) "release 513"
Qt Version: 4.8.2
Operating System: Linux 3.1.0-1.2-desktop x86_64
Distribution: "openSUSE 12.1 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:

Moved public folders of a zarafa imap account into another public folder.
Server is a DS from Synology.
Client is openSuse12.1 with KDE4.8 from suse rpm's

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fcf7a21d760 (LWP 2840))]

Thread 3 (Thread 0x7fcf616c7700 (LWP 2841)):
#0  0x00007fcf72076e6c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fcf76a119dc in ?? () from /usr/lib64/libQtWebKit.so.4
#2  0x00007fcf76a11b09 in ?? () from /usr/lib64/libQtWebKit.so.4
#3  0x00007fcf72072f05 in start_thread () from /lib64/libpthread.so.0
#4  0x00007fcf7771c10d in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7fcf60dae700 (LWP 2842)):
#0  0x00007fcf77712ff3 in poll () from /lib64/libc.so.6
#1  0x00007fcf71b63a98 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007fcf71b63f59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007fcf77e8ae36 in QEventDispatcherGlib::processEvents (this=0x7fcf5c0008c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007fcf77e5a842 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fcf77e5aa97 in QEventLoop::exec (this=0x7fcf60dade20, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007fcf77d5a5f7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007fcf77d5d61b in QThreadPrivate::start (arg=0x76fb00) at thread/qthread_unix.cpp:307
#8  0x00007fcf72072f05 in start_thread () from /lib64/libpthread.so.0
#9  0x00007fcf7771c10d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7fcf7a21d760 (LWP 2840)):
[KCrash Handler]
#6  size (this=0x0) at ../../src/corelib/tools/qvector.h:137
#7  QSortFilterProxyModelPrivate::proxy_to_source (this=0xb45130, proxy_index=...) at itemviews/qsortfilterproxymodel.cpp:370
#8  0x00007fcf78e1defd in QSortFilterProxyModel::mapToSource (this=<optimized out>, proxyIndex=<optimized out>) at itemviews/qsortfilterproxymodel.cpp:2502
#9  0x00007fcf78e1f18d in QSortFilterProxyModelPrivate::store_persistent_indexes (this=<optimized out>) at itemviews/qsortfilterproxymodel.cpp:996
#10 0x00007fcf78e1ffb3 in QSortFilterProxyModelPrivate::_q_sourceLayoutAboutToBeChanged (this=0xb45130) at itemviews/qsortfilterproxymodel.cpp:1244
#11 0x00007fcf77e6fc41 in QMetaObject::activate (sender=0xa0f140, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3556
#12 0x00007fcf77e5578c in QAbstractItemModel::beginMoveRows (this=0xa0f140, sourceParent=..., sourceFirst=7, sourceLast=7, destinationParent=..., destinationChild=0) at kernel/qabstractitemmodel.cpp:2635
#13 0x00007fcf745217df in Akonadi::EntityTreeModelPrivate::monitoredCollectionMoved (this=0xb42f40, collection=..., sourceCollection=..., destCollection=...) at /usr/src/debug/kdepimlibs-4.8.4/akonadi/entitytreemodel_p.cpp:917
#14 0x00007fcf77e6fc41 in QMetaObject::activate (sender=0xb14470, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffd73fb970) at kernel/qobject.cpp:3556
#15 0x00007fcf744a294f in Akonadi::Monitor::collectionMoved (this=<optimized out>, _t1=<optimized out>, _t2=<optimized out>, _t3=<optimized out>) at /usr/src/debug/kdepimlibs-4.8.4/build/akonadi/monitor.moc:252
#16 0x00007fcf744dbe03 in Akonadi::MonitorPrivate::emitCollectionNotification (this=0xb175d0, msg=..., col=<optimized out>, par=<optimized out>, dest=<optimized out>) at /usr/src/debug/kdepimlibs-4.8.4/akonadi/monitor_p.cpp:612
#17 0x00007fcf744e3d8a in Akonadi::MonitorPrivate::emitNotification (this=0xb175d0, msg=...) at /usr/src/debug/kdepimlibs-4.8.4/akonadi/monitor_p.cpp:285
#18 0x00007fcf74574311 in Akonadi::ChangeRecorderPrivate::emitNotification (this=0xb175d0, msg=<optimized out>) at /usr/src/debug/kdepimlibs-4.8.4/akonadi/changerecorder_p.h:60
#19 0x00007fcf74527276 in Akonadi::MonitorPrivate::flushPipeline (this=0xb175d0) at /usr/src/debug/kdepimlibs-4.8.4/akonadi/monitor_p.cpp:429
#20 0x00007fcf74527309 in Akonadi::MonitorPrivate::dataAvailable (this=0xb175d0) at /usr/src/debug/kdepimlibs-4.8.4/akonadi/monitor_p.cpp:438
#21 0x00007fcf77e6fc41 in QMetaObject::activate (sender=0xa7e570, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3556
#22 0x00007fcf7456c95d in Akonadi::EntityCache<Akonadi::Collection, Akonadi::CollectionFetchJob, Akonadi::CollectionFetchScope>::processResult (this=0xa7e570, job=<optimized out>) at /usr/src/debug/kdepimlibs-4.8.4/akonadi/entitycache_p.h:192
#23 0x00007fcf77e6fc41 in QMetaObject::activate (sender=0x17833b0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffd73fc050) at kernel/qobject.cpp:3556
#24 0x00007fcf782f0ed2 in KJob::result (this=<optimized out>, _t1=0x17833b0) at /usr/src/debug/kdelibs-4.8.4/build/kdecore/kjob.moc:208
#25 0x00007fcf782f0f10 in KJob::emitResult (this=0x17833b0) at /usr/src/debug/kdelibs-4.8.4/kdecore/jobs/kjob.cpp:318
#26 0x00007fcf77e74e06 in QObject::event (this=0x17833b0, e=<optimized out>) at kernel/qobject.cpp:1204
#27 0x00007fcf78874fe4 in notify_helper (e=0x5ef1650, receiver=0x17833b0, this=0x639840) at kernel/qapplication.cpp:4551
#28 QApplicationPrivate::notify_helper (this=0x639840, receiver=0x17833b0, e=0x5ef1650) at kernel/qapplication.cpp:4523
#29 0x00007fcf78879db3 in QApplication::notify (this=0x7fffd73fca10, receiver=0x17833b0, e=0x5ef1650) at kernel/qapplication.cpp:4412
#30 0x00007fcf795bb746 in KApplication::notify (this=0x7fffd73fca10, receiver=0x17833b0, event=0x5ef1650) at /usr/src/debug/kdelibs-4.8.4/kdeui/kernel/kapplication.cpp:311
#31 0x00007fcf77e5bd0c in QCoreApplication::notifyInternal (this=0x7fffd73fca10, receiver=0x17833b0, event=0x5ef1650) at kernel/qcoreapplication.cpp:915
#32 0x00007fcf77e5f5ba in sendEvent (event=0x5ef1650, receiver=0x17833b0) at kernel/qcoreapplication.h:231
#33 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x60dc70) at kernel/qcoreapplication.cpp:1539
#34 0x00007fcf77e8a9a3 in sendPostedEvents () at kernel/qcoreapplication.h:236
#35 postEventSourceDispatch (s=0x63ea70) at kernel/qeventdispatcher_glib.cpp:279
#36 0x00007fcf71b6358d in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#37 0x00007fcf71b63d88 in ?? () from /usr/lib64/libglib-2.0.so.0
#38 0x00007fcf71b63f59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#39 0x00007fcf77e8adcf in QEventDispatcherGlib::processEvents (this=0x60d530, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#40 0x00007fcf7891869e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#41 0x00007fcf77e5a842 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#42 0x00007fcf77e5aa97 in QEventLoop::exec (this=0x7fffd73fc9a0, flags=...) at kernel/qeventloop.cpp:204
#43 0x00007fcf77e5f8b5 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1187
#44 0x0000000000403919 in ?? ()
#45 0x00007fcf7766223d in __libc_start_main () from /lib64/libc.so.6
#46 0x0000000000403e51 in _start ()

Possible duplicates by query: bug 296588.

Reported using DrKonqi
Comment 1 Christophe Marin 2012-08-14 21:38:33 UTC

*** This bug has been marked as a duplicate of bug 275662 ***