Bug 313046 - Can't play Audio CDs with phonon-vlc backend (Amarok, KsCD)
Summary: Can't play Audio CDs with phonon-vlc backend (Amarok, KsCD)
Status: RESOLVED FIXED
Alias: None
Product: phonon-backend-vlc
Classification: Unclassified
Component: general (show other bugs)
Version: 0.6.2
Platform: Other Linux
: NOR normal (vote)
Target Milestone: 0.7
Assignee: Harald Sitter
URL:
Keywords:
: 315688 319709 (view as bug list)
Depends on:
Blocks: 290216
  Show dependency treegraph
 
Reported: 2013-01-10 22:39 UTC by Matěj Laitl
Modified: 2013-05-25 21:55 UTC (History)
8 users (show)

See Also:
Latest Commit:
Version Fixed In: 0.7


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Matěj Laitl 2013-01-10 22:39:05 UTC
This is a memo bug witch catchy title, so that we hopefully don't get duplicates. Filling this so that I have something to link to..

[15:35] <strohel> apachelogger: Is following sequence valid? mediaObject->setCurrentSource( Phonon::MediaSource( Phonon::Cd, device ) ); mediaObject->play();
[15:36] <strohel> device == "/dev/sr0"
[15:36] <apachelogger> yep
[15:37] <apachelogger> note however that you can only use the mediacontroller once the mediaobject is in playing state
[15:39] <strohel> apachelogger: With http://dpaste.com/871054/ (note setCurrentTitle commented out) I still get http://dpaste.com/871060/ and no sound.
[15:39] <apachelogger> with which backend?
[15:40] <strohel> pvlc 0.6.1
[15:40] <apachelogger> broken
[15:40] <strohel> gst now plays audiocds fine.
[15:41] <strohel> is there a fix?
[15:41] <apachelogger> no
[15:41] <strohel> yea. :-)
[15:41] <apachelogger> vlc2 decided to break behavior in an undocumented way
[15:41] <strohel> :-(
[15:42] <apachelogger> that is to say ... I have a hack patch that makes it work, only I currently don't give it priority as it only ever worked for one release in pvlc anyway
[15:43] * strohel tries to find a good place to say "Audio CD doesn't work with phonon-vlc" to users...
[15:44] <apachelogger> don't you get an error anyway? :P
[15:44] <apachelogger> i mean, that essentially is the problem ... vlc is throwing errors that are not errors because it really is just in the process of probing the device ;)
[15:45] <strohel> silly, however, we have end users that know nothing about phonon or alternative backends..
[15:48] <apachelogger> well
[15:48] <apachelogger> only impacts windows and osx users
[15:48] <apachelogger> and they have no where to go anyway
[15:48] <apachelogger> all linux distros default to gstreamer, so people who explicit switch to vlc shoudl know what they are doing
Comment 1 Matěj Laitl 2013-01-10 22:45:44 UTC
Git commit 05ebb165204e7b3f200e1a08632a1dc499591475 by Matěj Laitl.
Committed on 10/01/2013 at 23:43.
Pushed by laitl into branch 'master'.

README, ChangeLog: mention that Audio CD playback is broken with phonon-vlc

M  +2    -2    ChangeLog
M  +1    -1    README

http://commits.kde.org/amarok/05ebb165204e7b3f200e1a08632a1dc499591475
Comment 2 Myriam Schweingruber 2013-04-13 11:03:30 UTC
*** Bug 315688 has been marked as a duplicate of this bug. ***
Comment 3 Myriam Schweingruber 2013-05-12 09:50:24 UTC
*** Bug 319709 has been marked as a duplicate of this bug. ***
Comment 4 Martin Sandsmark 2013-05-25 15:31:08 UTC
forgot the commit hook again, but fixed in master.

http://commits.kde.org/phonon-vlc/a5eed1936a7105d69dfb42c8ba9e57fe5f908d64