Bug 312890 - Dolphin tries to render timeline:/ results as tree
Summary: Dolphin tries to render timeline:/ results as tree
Status: RESOLVED FIXED
Alias: None
Product: dolphin
Classification: Unclassified
Component: view-engine: details mode (show other bugs)
Version: 2.2
Platform: Gentoo Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Dolphin Bug Assignee
URL: https://projects.kde.org/projects/kde...
Keywords:
: 319374 (view as bug list)
Depends on: 311577
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-08 15:43 UTC by Elias Probst
Modified: 2013-05-06 10:35 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.11.0


Attachments
Screenshot showing the broken rendering of a timeline:/today view. (126.11 KB, image/png)
2013-01-08 15:43 UTC, Elias Probst
Details
Dolphin details view file order (115.82 KB, image/png)
2013-02-21 21:17 UTC, Janek Bevendorff
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Elias Probst 2013-01-08 15:43:51 UTC
Created attachment 76309 [details]
Screenshot showing the broken rendering of a timeline:/today view.

Nepomuk just got a fix for bug#311577 which makes the timeline:/ KIO return real filesystem URLs instead of Nepomuk URLs.

This breaks Dolphin's "Details View Mode" as it tries to render the result list of "timeline:/today" and "timeline:/yesterday" as a tree, resulting in weirdly indented files (see screenshot in attachment).

Dolphin should treat the "today" and "yesterday" timeline in the same way as "nepomuksearch" results - dismissing any tree view related things and just resort to displaying a regular file list.
Comment 1 Janek Bevendorff 2013-02-21 21:16:38 UTC
The tree view in combination with timeline:/ URLs seems to be a little buggy in general.
When I am in "compact" or "icon" view mode and change to "details" while having such an URL open, the files show up in the broken tree view with a certain order. When I reload the viewport, though (e.g. with F5), the files are shown in a different order.

See the screen shot I attached.
Comment 2 Janek Bevendorff 2013-02-21 21:17:18 UTC
Created attachment 77498 [details]
Dolphin details view file order
Comment 3 Emmanuel Pescosta 2013-02-21 22:18:59 UTC
Hello Elias and Janek, I think this patch https://git.reviewboard.kde.org/r/109045/ will solve all two problems ;) 

@Elias, @Janek:
Can you please test it? Thanks
Comment 4 Elias Probst 2013-02-22 00:40:17 UTC
(In reply to comment #3)
> Hello Elias and Janek, I think this patch
> https://git.reviewboard.kde.org/r/109045/ will solve all two problems ;) 
> 
> @Elias, @Janek:
> Can you please test it? Thanks

Is this patch meant to apply against 4.10.0 or only master/4.11? Can't apply it against 4.10.0.
Comment 5 Emmanuel Pescosta 2013-02-22 07:02:16 UTC
(In reply to comment #4)
> (In reply to comment #3)
> > Hello Elias and Janek, I think this patch
> > https://git.reviewboard.kde.org/r/109045/ will solve all two problems ;) 
> > 
> > @Elias, @Janek:
> > Can you please test it? Thanks
> 
> Is this patch meant to apply against 4.10.0 or only master/4.11? Can't apply
> it against 4.10.0.

Master only
Comment 6 Janek Bevendorff 2013-02-22 10:45:31 UTC
Currently I'm on 4.10, not on master, so I can't test it here. Sorry. 
:-\
I'd need to download a Neon image first. Maybe I can do this tonight.
Comment 7 Frank Reininghaus 2013-02-22 11:33:25 UTC
(In reply to comment #6)
> Currently I'm on 4.10, not on master, so I can't test it here. Sorry. 
> :-\
> I'd need to download a Neon image first. Maybe I can do this tonight.

How is that going to help? I thought that Neon only provides binary packages. In any case, considering that the patch does not even apply correctly to master, I'd wait a bit before putting too much effort into testing this.
Comment 8 Janek Bevendorff 2013-02-22 11:36:14 UTC
I does, but I still can compile custom packages there. ;-)
Comment 9 Emmanuel Pescosta 2013-02-27 13:04:09 UTC
Git commit 8008bc233d8447794df6f4cdc8c3f0ee7e8ac628 by Emmanuel Pescosta.
Committed on 27/02/2013 at 13:35.
Pushed by emmanuelp into branch 'master'.

Big Thanks to Frank Reininghaus, who helped me a lot with these
changes! :)

* Fixed the "Network browser" and "timeline" issues, by using the
KDirLister's itemsAdded(KUrl,KFileItemList) signal -> Use the
given Url to define the parent-child relationship.

* Changed the name of the slot "slotNewItems" to "slotItemsAdded"
for consistency with the signal.

* Use a QHash<KFileItem, ItemData*> instead of a QSet<KFileItem> to
store the filtered data (needed to keep the O(1) lookup for filtered
KFileItems in slotItemsDeleted + needed to fix bug 311912 "After
erasing a filter, some thumbnails randomly disappear")

* Made the determination of the "expandedParentsCount" slightly
simpler - just adding 1 to the parent's level (Also needed to fix the
"Network browser" and "timeline" issues)

FIXED-IN: 4.11.0
REVIEW: 109180
Related: bug 304565, bug 311912, bug 315593

M  +69   -64   dolphin/src/kitemviews/kfileitemmodel.cpp
M  +13   -8    dolphin/src/kitemviews/kfileitemmodel.h
M  +9    -3    dolphin/src/tests/kfileitemmodelbenchmark.cpp
M  +1    -1    dolphin/src/tests/kfileitemmodeltest.cpp

http://commits.kde.org/kde-baseapps/8008bc233d8447794df6f4cdc8c3f0ee7e8ac628
Comment 10 Frank Reininghaus 2013-05-06 10:35:09 UTC
*** Bug 319374 has been marked as a duplicate of this bug. ***