Bug 312242 - Window menu operates on active window, instead of "clicked" window
Summary: Window menu operates on active window, instead of "clicked" window
Status: RESOLVED DUPLICATE of bug 312004
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: 4.9.95 (RC 1)
Platform: Other Linux
: NOR major (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-27 00:32 UTC by Christoph Feck
Modified: 2012-12-27 00:42 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christoph Feck 2012-12-27 00:32:31 UTC
To reproduce:
- open two windows A and B
- activate window A
- use right-click menu on titlebar of window B to operate on it, e.g. Maximize, or Keep Above

Actual result:
- selected operation is performed on active window A

Expected result:
- selected operation is performed on window B that received the right-button click

(major, because I am now unable to use xvkbd on-screen-keyboard, forcing me to attach a physical keyboard)
Comment 1 Thomas Lübking 2012-12-27 00:42:11 UTC

*** This bug has been marked as a duplicate of bug 312004 ***