Bug 312004 - Window operations menu affects only the window in focus.
Summary: Window operations menu affects only the window in focus.
Status: RESOLVED FIXED
Alias: None
Product: kwin
Classification: Unclassified
Component: core (show other bugs)
Version: 4.9.90 (Beta 2)
Platform: Archlinux Packages Linux
: NOR normal (vote)
Target Milestone: 4.10 RC 2
Assignee: KWin default assignee
URL: https://git.reviewboard.kde.org/r/107...
Keywords: regression
: 312242 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-12-20 19:37 UTC by Michael Coronel
Modified: 2012-12-27 00:42 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 4.10 RC 2
mgraesslin: ReviewRequest+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Coronel 2012-12-20 19:37:04 UTC
Actions selected from a window's operations menu are only applied to the window in focus. This behavior is independent of what decoration is being used and impacts standard actions (minimize, maximize, close) as well as those under the 'More Actions' menu; actions under the 'Move To Desktop' and 'Attach as Tab to' menus behave as one would expect. The bug is present in both 4.9.90 and 4.9.95.

Reproducible: Always

Steps to Reproduce:
1. Right-click on the title bar of a window not in focus and bring up the operations menu.
2. Select maximize, minimize, close or any item in the 'More Actions' menu.
Actual Results:  
The action is applied to the window in focus.

Expected Results:  
The action is applied to the window that was clicked, regardless of focus.
Comment 1 Martin Flöser 2012-12-20 19:48:38 UTC
what's your focus policy?
Comment 2 Michael Coronel 2012-12-20 19:52:13 UTC
Click to Focus
Comment 3 Martin Flöser 2012-12-20 20:09:40 UTC
probably a regression caused by c0b762dcd51de033294784e116f9d8e02bfa5401 as now close() is called before the operations are processed. close() invalidates the internal Client which causes the selection of the active client once the slot is invoked.

We should be able to remove the Client invalidation from close() as it's just a QWeakPointer.
Comment 4 Martin Flöser 2012-12-22 10:45:47 UTC
Git commit 35279c1402e08f127a9506866b7a567de90fc10c by Martin Gräßlin.
Committed on 20/12/2012 at 21:26.
Pushed by graesslin into branch 'KDE/4.10'.

Do not clear UserActionMenu's Client after the menu closed

The Client is still needed as the invoked action might be delayed by one
event cycle to work around a crash if the operation causes the deco to
close.
FIXED-IN: 4.10 RC 2
REVIEW: 107823

M  +3    -4    kwin/useractions.cpp

http://commits.kde.org/kde-workspace/35279c1402e08f127a9506866b7a567de90fc10c
Comment 5 Thomas Lübking 2012-12-27 00:42:11 UTC
*** Bug 312242 has been marked as a duplicate of this bug. ***