Bug 311834 - Plasma applet shows IPv4 address even after it is disabled
Summary: Plasma applet shows IPv4 address even after it is disabled
Status: RESOLVED DUPLICATE of bug 311894
Alias: None
Product: Network Management
Classification: Miscellaneous
Component: Plasma Widget (show other bugs)
Version: 0.9
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Sebastian Kügler
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-17 15:08 UTC by Martin Holec
Modified: 2013-01-23 13:05 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Holec 2012-12-17 15:08:36 UTC
Plasma applet shows IPv4 address even after it is disabled and only IPv6 is configured in NM and on interface.

Reproducible: Always

Steps to Reproduce:
1. Configure IPv4 connection in NM profile and connect to network.
2. Disable IPv4 in configuration and enable IPv6. Reconnect to network.
3. Look at network interface details at Plasma Applet and compare it with "ip address".
Actual Results:  
Plasma Applet shows IPv4 address (and no IPv6 address which is reported as bug #311832).
"ip address" shows no IPv4 address, only two IPv6.

Expected Results:  
Plasma Applet shows IPv4 address when it is really configured on interface.

When I remove and reinsert network driver kernel module and reconnect, Plasma Applet shows no address.
Comment 1 Lamarque V. Souza 2012-12-18 17:59:53 UTC
because of bug https://bugs.kde.org/show_bug.cgi?id=311894, which I have just fixed, it was not possible to really disable IPv4 in Plasma NM.  What Plasma NM do you use?  You can see the version string in "Manage Connections" -> "Other".  Bug #311832 is a duplicate of bug #276110.
Comment 2 Martin Holec 2013-01-23 12:52:47 UTC
Version 0.9.0.5 (nm09 20121206)

I can still reproduce it.
Comment 3 Lamarque V. Souza 2013-01-23 13:05:37 UTC
Well, this bug will be fixed in Plasma NM 0.9.0.7, which I have not relesead yet. I will release it next weekend.

*** This bug has been marked as a duplicate of bug 311894 ***