Bug 311491 - Battery Monitor widget disappears after one move of Screen Brightness slider
Summary: Battery Monitor widget disappears after one move of Screen Brightness slider
Status: RESOLVED FIXED
Alias: None
Product: plasma4
Classification: Unclassified
Component: widget-battery (show other bugs)
Version: 4.9.90 Beta2
Platform: Fedora RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2012-12-10 23:26 UTC by nucleo
Modified: 2013-12-09 00:52 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.10


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description nucleo 2012-12-10 23:26:25 UTC
Battery Monitor widget disappears after one move of Screen Brightness slider.

Reproducible: Always

Steps to Reproduce:
Update to 4.9.4.
Actual Results:  
Battery Monitor widget disappears immediately after one move of Screen Brightness slider. If brightness needs to be changed more then widget should be opened again.

Expected Results:  
Widget should not disappear after every slider movement.

No problem in 4.9.3.
Comment 1 nucleo 2012-12-11 00:22:38 UTC
This happens only if Battery Monitor widget opened from hidden icons.
Comment 2 Rex Dieter 2012-12-11 02:36:49 UTC
 confirmed,  actually it would appear it happens when the battery widget is full (normally hidden). even setting to "always show" in systray prefs doesn't help though.
Comment 3 Anne-Marie Mahfouf 2012-12-11 08:53:55 UTC
Present in KDE 4.10 beta 2. Marking as regression.
Comment 4 nucleo 2012-12-30 11:42:01 UTC
Bug still present in 4.9.5.
Comment 5 Anne-Marie Mahfouf 2013-01-05 09:47:04 UTC
As soon as the slider is slightly moved, "onValueChanged: brightnessChanged(value)" is called and then PowerDevil is invoked to set the new brightness value in "onBrightnessChanged" and takes over the screen and the popup disappears. 
The popup menu should stay as long as the user does not make it disappear.
Comment 6 Weng Xuetian 2013-01-12 14:38:08 UTC
Git commit 70ed17ef99dd33adda271ebc338d82039b191caf by Weng Xuetian.
Committed on 12/01/2013 at 15:33.
Pushed by xuetianweng into branch 'KDE/4.10'.

various fix for battery plasmoid

Fix access undefined value warning, when calling function in
logic.js, pmSource.data can still be null since it might not connect at
that time.
When brightness is passively changed from outer environment, don't
trigger the dataSource service call with a bool protector called
disableBrightnessUpdate.
Move more code to DataModel.onDataChanged, under the same idea with:
https://git.reviewboard.kde.org/r/108280/ , hence the plasmoid.status
will always be the correct value, the changing of plasmoid.status cause
tray make popup unfocus.
Remove ugly hack of resetBatteryData in logic.js.
Fix some anchor related warning in PopupDialog.qml

FIXED-IN: 4.10
Related: bug 302130
REVIEW: 108355

M  +14   -7    plasma/generic/applets/batterymonitor/contents/code/logic.js
M  +9    -11   plasma/generic/applets/batterymonitor/contents/ui/PopupDialog.qml
M  +20   -13   plasma/generic/applets/batterymonitor/contents/ui/batterymonitor.qml

http://commits.kde.org/kde-workspace/70ed17ef99dd33adda271ebc338d82039b191caf
Comment 7 nucleo 2013-01-13 01:40:47 UTC
This bug is 4.9.4 regression, so fix can be backported to 4.9 branch?
Comment 8 nucleo 2013-08-01 19:49:06 UTC
Problem appeared again in KDE 4.10.97.
Comment 9 makism 2013-08-16 09:45:23 UTC
I have the same issue in 4.11.0
Comment 10 Adriano Vilela 2013-12-09 00:50:18 UTC
Is this really fixed? I just got hit by this bug after upgrading my KDE installation from 4.10.5 to 4.11.3. The problem always happens, even if the battery widget is set to always visible. I'm running Debian Testing.

Adriano
Comment 11 nucleo 2013-12-09 00:52:37 UTC
(In reply to comment #10)
See bug 321823