Bug 302130 - brightness popup at session startup
Summary: brightness popup at session startup
Status: RESOLVED FIXED
Alias: None
Product: plasma4
Classification: Unclassified
Component: widget-battery (show other bugs)
Version: 4.9.1
Platform: Ubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
: 312206 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-06-18 14:41 UTC by lucazade
Modified: 2013-01-12 14:38 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.10


Attachments
screenshot of brightness popup (746.32 KB, image/jpeg)
2012-06-18 14:43 UTC, lucazade
Details

Note You need to log in before you can comment on or make changes to this bug.
Description lucazade 2012-06-18 14:41:33 UTC
When the session startup and the panel is fully loaded it automatically appears the brightness dialog
then after some seconds it disappears.


I've applied the kubuntu backport beta ppa (kde 4.8.90) to my Ubuntu Precise installation.


Reproducible: Always

Steps to Reproduce:
1. startup kde session
2. the brightness popup automatically
3. then after some seconds it closes


Expected Results:  
no brightness popup expected
Comment 1 lucazade 2012-06-18 14:43:23 UTC
Created attachment 71913 [details]
screenshot of brightness popup
Comment 2 Kai Uwe Broulik 2012-06-18 23:57:26 UTC
Normally not noticeable for the average user (that uses a splash screen)
But definitly visible when plasma crashes and restarts
Comment 3 Myriam Schweingruber 2012-06-20 07:52:47 UTC
Confirmed based on comment #2
Comment 4 lucazade 2012-06-28 10:21:48 UTC
"Normally not noticeable for the average user (that uses a splash screen)"
This is noticeable for every kind of users (what is the meaning of average user????)... 
I have the splash screen enabled (it is by default) and the issue is reproducible on different machines.
Comment 5 markuss 2012-07-30 23:22:39 UTC
Confirming the bug with 4.9 RC2. Had it only on first startup after upgrade from 4.8, though.
Comment 6 Ralf Jung 2012-09-13 19:06:22 UTC
I can confirm the issue, and it happens on each login. Users with slow PCs probably don't see it, but it's clearly visible on my system.
Comment 7 Weng Xuetian 2013-01-11 23:04:30 UTC
*** Bug 312206 has been marked as a duplicate of this bug. ***
Comment 8 Weng Xuetian 2013-01-12 14:38:08 UTC
Git commit 70ed17ef99dd33adda271ebc338d82039b191caf by Weng Xuetian.
Committed on 12/01/2013 at 15:33.
Pushed by xuetianweng into branch 'KDE/4.10'.

various fix for battery plasmoid

Fix access undefined value warning, when calling function in
logic.js, pmSource.data can still be null since it might not connect at
that time.
When brightness is passively changed from outer environment, don't
trigger the dataSource service call with a bool protector called
disableBrightnessUpdate.
Move more code to DataModel.onDataChanged, under the same idea with:
https://git.reviewboard.kde.org/r/108280/ , hence the plasmoid.status
will always be the correct value, the changing of plasmoid.status cause
tray make popup unfocus.
Remove ugly hack of resetBatteryData in logic.js.
Fix some anchor related warning in PopupDialog.qml

FIXED-IN: 4.10
Related: bug 311491
REVIEW: 108355

M  +14   -7    plasma/generic/applets/batterymonitor/contents/code/logic.js
M  +9    -11   plasma/generic/applets/batterymonitor/contents/ui/PopupDialog.qml
M  +20   -13   plasma/generic/applets/batterymonitor/contents/ui/batterymonitor.qml

http://commits.kde.org/kde-workspace/70ed17ef99dd33adda271ebc338d82039b191caf