Bug 311018 (qml~crash) - kwin crashed after applying a new color sceheme
Summary: kwin crashed after applying a new color sceheme
Status: RESOLVED UPSTREAM
Alias: qml~crash
Product: kwin
Classification: Unclassified
Component: general (show other bugs)
Version: 4.9.80
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
: 304617 311110 312399 313132 314445 314508 314606 314716 314737 314758 314891 315087 315671 315984 316001 316076 316152 317409 318997 320120 320250 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-12-02 10:51 UTC by Simple
Modified: 2013-05-25 10:30 UTC (History)
30 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
possible patch (524 bytes, patch)
2012-12-02 14:16 UTC, Thomas Lübking
Details
New crash information added by DrKonqi (5.70 KB, text/plain)
2013-01-18 01:30 UTC, Simon Andric
Details
New crash information added by DrKonqi (4.80 KB, text/plain)
2013-01-29 23:58 UTC, yo
Details
New crash information added by DrKonqi (5.07 KB, text/plain)
2013-02-09 12:17 UTC, George
Details
New crash information added by DrKonqi (5.31 KB, text/plain)
2013-02-14 23:27 UTC, captainstormy
Details
New crash information added by DrKonqi (4.94 KB, text/plain)
2013-02-18 09:29 UTC, troy R
Details
New crash information added by DrKonqi (5.63 KB, text/plain)
2013-02-22 13:47 UTC, damir
Details
New crash information added by DrKonqi (5.06 KB, text/plain)
2013-03-06 16:45 UTC, GGG
Details
New crash information added by DrKonqi (5.09 KB, text/plain)
2013-03-08 07:08 UTC, GGG
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Simple 2012-12-02 10:51:22 UTC
Application: kwin (4.9.80)
KDE Platform Version: 4.9.80
Qt Version: 4.8.3
Operating System: Linux 3.5.0-17-generic x86_64
Distribution: Ubuntu Raring Ringtail (development branch)

-- Information about the crash:
I run systemsettings and went to Appearance->Colors and choosed a new color scheme and hit in the "Apply" button and kwin crashed.

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f25f8e617c0 (LWP 15216))]

Thread 4 (Thread 0x7f25dcdef700 (LWP 15218)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:168
#1  0x00007f25f4f72cd7 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#2  0x00007f25f4f72d09 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#3  0x00007f25eca4af9f in start_thread (arg=0x7f25dcdef700) at pthread_create.c:311
#4  0x00007f25f867b0cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:114

Thread 3 (Thread 0x7f25cec30700 (LWP 15383)):
#0  0x00007f25f8674293 in select () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f25f3abd023 in qt_safe_select (nfds=21, fdread=0x7f25c4000ac8, fdwrite=0x7f25c4000d60, fdexcept=0x7f25c4000ff8, orig_timeout=0x0) at kernel/qcore_unix.cpp:83
#2  0x00007f25f3ac19e4 in QEventDispatcherUNIXPrivate::doSelect (this=this@entry=0x7f25c4000910, flags=..., timeout=0x0) at kernel/qeventdispatcher_unix.cpp:223
#3  0x00007f25f3ac2572 in QEventDispatcherUNIX::processEvents (this=0x7f25c40008f0, flags=...) at kernel/qeventdispatcher_unix.cpp:926
#4  0x00007f25f3a902bf in QEventLoop::processEvents (this=this@entry=0x7f25cec2fd90, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f25f3a90548 in QEventLoop::exec (this=0x7f25cec2fd90, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f25f3991b10 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f25f3a709af in QInotifyFileSystemWatcherEngine::run (this=0x10d6790) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f25f3994aec in QThreadPrivate::start (arg=0x10d6790) at thread/qthread_unix.cpp:338
#9  0x00007f25eca4af9f in start_thread (arg=0x7f25cec30700) at pthread_create.c:311
#10 0x00007f25f867b0cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:114

Thread 2 (Thread 0x7f25d71aa700 (LWP 15781)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:217
#1  0x00007f25f3994fa7 in wait (time=30000, this=0x1235b20) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x1235ac8, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f25f398854f in QThreadPoolThread::run (this=0x122e070) at concurrent/qthreadpool.cpp:141
#4  0x00007f25f3994aec in QThreadPrivate::start (arg=0x122e070) at thread/qthread_unix.cpp:338
#5  0x00007f25eca4af9f in start_thread (arg=0x7f25d71aa700) at pthread_create.c:311
#6  0x00007f25f867b0cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:114

Thread 1 (Thread 0x7f25f8e617c0 (LWP 15216)):
[KCrash Handler]
#6  0x00007f25f75fcdd4 in QDeclarativeItem::~QDeclarativeItem (this=0x1e8cd60, __in_chrg=<optimized out>) at graphicsitems/qdeclarativeitem.cpp:1668
#7  0x00007f25f75c06ee in ~QDeclarativeElement (this=0x1e8cd60, __in_chrg=<optimized out>) at ../../include/QtDeclarative/../../src/declarative/qml/qdeclarativeprivate.h:87
#8  QDeclarativePrivate::QDeclarativeElement<QDeclarativeItem>::~QDeclarativeElement (this=0x1e8cd60, __in_chrg=<optimized out>) at ../../include/QtDeclarative/../../src/declarative/qml/qdeclarativeprivate.h:87
#9  0x00007f25f341dfd1 in QGraphicsScene::clear (this=this@entry=0x1d3df10) at graphicsview/qgraphicsscene.cpp:2442
#10 0x00007f25f341e055 in QGraphicsScene::~QGraphicsScene (this=0x1d3df10, __in_chrg=<optimized out>) at graphicsview/qgraphicsscene.cpp:1649
#11 0x00007f25f341e0c9 in QGraphicsScene::~QGraphicsScene (this=0x1d3df10, __in_chrg=<optimized out>) at graphicsview/qgraphicsscene.cpp:1654
#12 0x00007f25f3aa4182 in QObjectPrivate::deleteChildren (this=this@entry=0x18ea9f0) at kernel/qobject.cpp:1908
#13 0x00007f25f3aa7fc6 in QObject::~QObject (this=0x1eb1730, __in_chrg=<optimized out>) at kernel/qobject.cpp:927
#14 0x00007f25dcdf6aa9 in Aurorae::AuroraeClient::~AuroraeClient (this=0x1eb1730, __in_chrg=<optimized out>) at ../../../../../kwin/clients/aurorae/src/aurorae.cpp:249
#15 0x00007f25f899d2cb in KWin::Client::destroyDecoration (this=this@entry=0x1f98190) at ../../kwin/client.cpp:454
#16 0x00007f25f899dfde in updateDecoration (force=true, check_workspace_pos=true, this=0x1f98190) at ../../kwin/client.cpp:412
#17 KWin::Client::updateDecoration (this=0x1f98190, check_workspace_pos=<optimized out>, force=<optimized out>) at ../../kwin/client.cpp:404
#18 0x00007f25f898722e in KWin::Workspace::slotReconfigure (this=0x11f7160) at ../../kwin/workspace.cpp:1036
#19 0x00007f25f898c53a in qt_static_metacall (_a=<optimized out>, _id=<optimized out>, _o=<optimized out>, _c=<optimized out>) at ./workspace.moc:318
#20 KWin::Workspace::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at ./workspace.moc:234
#21 0x00007f25f3aa6f5f in QMetaObject::activate (sender=0x11f7430, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3547
#22 0x00007f25f3aa626c in QObject::event (this=0x11f7430, e=<optimized out>) at kernel/qobject.cpp:1157
#23 0x00007f25f2e38e9c in QApplicationPrivate::notify_helper (this=this@entry=0x1089ee0, receiver=receiver@entry=0x11f7430, e=e@entry=0x7fffb4b63cb0) at kernel/qapplication.cpp:4562
#24 0x00007f25f2e3d30a in QApplication::notify (this=0x7fffb4b642f0, receiver=0x11f7430, e=0x7fffb4b63cb0) at kernel/qapplication.cpp:4423
#25 0x00007f25f8166386 in KApplication::notify (this=0x7fffb4b642f0, receiver=0x11f7430, event=0x7fffb4b63cb0) at ../../kdeui/kernel/kapplication.cpp:311
#26 0x00007f25f3a9156e in QCoreApplication::notifyInternal (this=0x7fffb4b642f0, receiver=0x11f7430, event=0x7fffb4b63cb0) at kernel/qcoreapplication.cpp:915
#27 0x00007f25f3ac2462 in sendEvent (event=0x7fffb4b63cb0, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#28 QTimerInfoList::activateTimers (this=0x108aa28) at kernel/qeventdispatcher_unix.cpp:611
#29 0x00007f25f3ac24c0 in QEventDispatcherUNIX::activateTimers (this=this@entry=0x1030ad0) at kernel/qeventdispatcher_unix.cpp:868
#30 0x00007f25f3ac2618 in QEventDispatcherUNIX::processEvents (this=0x1030ad0, flags=...) at kernel/qeventdispatcher_unix.cpp:930
#31 0x00007f25f2edea3f in QEventDispatcherX11::processEvents (this=0x1030ad0, flags=...) at kernel/qeventdispatcher_x11.cpp:152
#32 0x00007f25f3a902bf in QEventLoop::processEvents (this=this@entry=0x7fffb4b64000, flags=...) at kernel/qeventloop.cpp:149
#33 0x00007f25f3a90548 in QEventLoop::exec (this=0x7fffb4b64000, flags=...) at kernel/qeventloop.cpp:204
#34 0x00007f25f3a95708 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1187
#35 0x00007f25f89acea4 in kdemain (argc=3, argv=0x7fffb4b64438) at ../../kwin/main.cpp:545
#36 0x00007f25f85a5c15 in __libc_start_main (main=0x4006d0 <main(int, char**)>, argc=3, ubp_av=0x7fffb4b64438, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fffb4b64428) at libc-start.c:227
#37 0x0000000000400701 in _start ()

Possible duplicates by query: bug 304617.

Reported using DrKonqi
Comment 1 Simple 2012-12-02 10:55:40 UTC
After having kwin crashed i tried to restart it and run 'kwin --replace' but it continued crashing, the output:

~$ kwin --replace
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 9: reading configurations from ~/.fonts.conf is deprecated.
QCoreApplication::sendPostedEvents: Cannot send posted events for objects in another thread
QCoreApplication::sendPostedEvents: Cannot send posted events for objects in another thread
QCoreApplication::sendPostedEvents: Cannot send posted events for objects in another thread
QCoreApplication::sendPostedEvents: Cannot send posted events for objects in another thread
OpenGL vendor string:                   Intel Open Source Technology Center
OpenGL renderer string:                 Mesa DRI Intel(R) Sandybridge Mobile 
OpenGL version string:                  3.0 Mesa 9.0.1
OpenGL shading language version string: 1.30
Driver:                                 Intel
GPU class:                              SandyBridge
OpenGL version:                         3.0
GLSL version:                           1.30
Mesa version:                           9.0.1
X server version:                       1.13
Linux kernel version:                   3.5
Direct rendering:                       yes
Requires strict binding:                no
GLSL shaders:                           yes
Texture NPOT support:                   yes
Virtual Machine:                        no
Comment 2 Thomas Lübking 2012-12-02 13:59:57 UTC
The original crash is in the aurorae decoration, possibly Qt.

As for the follow-up crashes, we'll rather need a backtrace than the konsole output.

To restore the syste, try to alter the decoration (~/.kde/share/config/kwinrc, delete the "PluginLib" key in the [Style] section.

Did you recently perform an "apt-get upgrade" or similar?
Comment 3 Thomas Lübking 2012-12-02 14:16:25 UTC
Created attachment 75581 [details]
possible patch

attached is a possible (completely untested) patch, but this is of course silly (as  post deleting the view has been ...)
Comment 4 Thomas Lübking 2012-12-03 20:18:54 UTC
*** Bug 311110 has been marked as a duplicate of this bug. ***
Comment 5 Thomas Lübking 2012-12-14 21:55:17 UTC
Git commit dcb8165e46028431ff3c2ae4908ccd441eca818a by Thomas Lübking.
Committed on 11/12/2012 at 16:09.
Pushed by luebking into branch 'master'.

defer all member destruction to next event cycle
FIXE-IN: 4.10

M  +4    -0    kwin/clients/aurorae/src/aurorae.cpp

http://commits.kde.org/kde-workspace/dcb8165e46028431ff3c2ae4908ccd441eca818a
Comment 6 Thomas Lübking 2012-12-30 21:02:40 UTC
*** Bug 312399 has been marked as a duplicate of this bug. ***
Comment 7 Thomas Lübking 2012-12-30 21:03:12 UTC
There goes our patch.
Comment 8 Thomas Lübking 2012-12-30 21:08:30 UTC
Crashy Qt line seems:
if (!d->parent || (parentItem() && !parentItem()->QGraphicsItem::d_ptr->inDestructor)) {

so probably parentItem() is dangeling.

Once more: does anybody encountering this or bug #304617 NOT use ubuntu?
Comment 9 Thomas Lübking 2013-01-12 13:57:21 UTC
*** Bug 313132 has been marked as a duplicate of this bug. ***
Comment 10 Simon Andric 2013-01-18 01:30:15 UTC
Created attachment 76536 [details]
New crash information added by DrKonqi

kwin (4.9.97) on KDE Platform 4.9.97 using Qt 4.8.4

- What I was doing when the application crashed:

changed to air oxygen color theme... then crash happened

nice day

Simon :)

-- Backtrace (Reduced):
#7  0xb6aefd9e in QDeclarativeItem::~QDeclarativeItem (this=0x9b728d8, __in_chrg=<optimized out>) at graphicsitems/qdeclarativeitem.cpp:1668
#8  0xb6aaec74 in ~QDeclarativeElement (this=0x9b728d8, __in_chrg=<optimized out>) at ../../include/QtDeclarative/../../src/declarative/qml/qdeclarativeprivate.h:87
#9  QDeclarativePrivate::QDeclarativeElement<QDeclarativeItem>::~QDeclarativeElement (this=0x9b728d8, __in_chrg=<optimized out>) at ../../include/QtDeclarative/../../src/declarative/qml/qdeclarativeprivate.h:87
#10 0xb5fc47f3 in qDeleteInEventHandler (o=o@entry=0x9b728d8) at kernel/qobject.cpp:4269
#11 0xb5fc6f80 in QObject::event (this=0x9b728d8, e=0x9e652b8) at kernel/qobject.cpp:1175
Comment 11 yo 2013-01-29 23:58:23 UTC
Created attachment 76796 [details]
New crash information added by DrKonqi

kwin (4.9.98) on KDE Platform 4.9.98 using Qt 4.8.4

- What I was doing when the application crashed:

I attempted to swap the window direction of my KDE setup on Kubuntu 13.04. 

- Unusual behavior I noticed:

After swapping the decoration, the entire decoration disappeared. I had to run "kwin --replace" to get it to apply. This is a persistant problem.

-- Backtrace (Reduced):
#6  0x00007f76f21ca4b7 in QDeclarativeItem::~QDeclarativeItem (this=0x1bc2b00, __in_chrg=<optimized out>) at graphicsitems/qdeclarativeitem.cpp:1668
#7  0x00007f76f218e0de in ~QDeclarativeElement (this=0x1bc2b00, __in_chrg=<optimized out>) at ../../include/QtDeclarative/../../src/declarative/qml/qdeclarativeprivate.h:87
#8  QDeclarativePrivate::QDeclarativeElement<QDeclarativeItem>::~QDeclarativeElement (this=0x1bc2b00, __in_chrg=<optimized out>) at ../../include/QtDeclarative/../../src/declarative/qml/qdeclarativeprivate.h:87
#9  0x00007f76ee66e5b8 in QObject::event (this=0x1bc2b00, e=<optimized out>) at kernel/qobject.cpp:1175
#10 0x00007f76ed9fffbc in QApplicationPrivate::notify_helper (this=this@entry=0x128c9d0, receiver=receiver@entry=0x1bc2b00, e=e@entry=0x1e078b0) at kernel/qapplication.cpp:4567
Comment 12 Martin Flöser 2013-01-30 08:05:58 UTC
Setting to UPSTREAM: when looking at Plasma crashes I have seen similar crashes in the dtor of QDeclarativeItem quite often and they are also on UPSTREAM.
Comment 13 Martin Flöser 2013-02-05 08:16:45 UTC
*** Bug 314445 has been marked as a duplicate of this bug. ***
Comment 14 Thomas Lübking 2013-02-06 13:40:58 UTC
*** Bug 314508 has been marked as a duplicate of this bug. ***
Comment 15 Thomas Lübking 2013-02-07 15:44:21 UTC
*** Bug 314606 has been marked as a duplicate of this bug. ***
Comment 16 Thomas Lübking 2013-02-08 22:18:25 UTC
*** Bug 314716 has been marked as a duplicate of this bug. ***
Comment 17 Thomas Lübking 2013-02-09 09:50:41 UTC
*** Bug 314737 has been marked as a duplicate of this bug. ***
Comment 18 George 2013-02-09 12:17:03 UTC
Created attachment 77049 [details]
New crash information added by DrKonqi

kwin (4.10.00) on KDE Platform 4.10.00 using Qt 4.8.2

- What I was doing when the application crashed:

Changed Decoration.. It happens everytime so far, whenever I try that.

-- Backtrace (Reduced):
#6  0x00007fc3e97399ee in QDeclarativeItem::~QDeclarativeItem (this=0x1e99f90, __in_chrg=<optimized out>) at graphicsitems/qdeclarativeitem.cpp:1668
#7  0x00007fc3e96fcaf5 in ~QDeclarativeElement (this=0x1e99f90, __in_chrg=<optimized out>) at ../../include/QtDeclarative/../../src/declarative/qml/qdeclarativeprivate.h:87
#8  QDeclarativePrivate::QDeclarativeElement<QDeclarativeItem>::~QDeclarativeElement (this=0x1e99f90, __in_chrg=<optimized out>) at ../../include/QtDeclarative/../../src/declarative/qml/qdeclarativeprivate.h:87
#9  0x00007fc3e5b18958 in QObject::event (this=0x1e99f90, e=<optimized out>) at kernel/qobject.cpp:1176
#10 0x00007fc3e4e807b4 in notify_helper (e=0x26a1670, receiver=0x1e99f90, this=0x19e7ad0) at kernel/qapplication.cpp:4556
Comment 19 Thomas Lübking 2013-02-09 12:43:22 UTC
*** Bug 314758 has been marked as a duplicate of this bug. ***
Comment 20 Thomas Lübking 2013-02-11 15:32:31 UTC
*** Bug 314891 has been marked as a duplicate of this bug. ***
Comment 21 Martin Flöser 2013-02-13 20:02:27 UTC
*** Bug 315087 has been marked as a duplicate of this bug. ***
Comment 22 captainstormy 2013-02-14 23:27:24 UTC
Created attachment 77311 [details]
New crash information added by DrKonqi

kwin (4.10.00) on KDE Platform 4.10.00 using Qt 4.8.2

- What I was doing when the application crashed:
Changing window decorations.  I couldn't really tell which ones, if any specifically caused the crash as it happened most of the time I changed.

-- Backtrace (Reduced):
#6  0x00007ff4775039ee in QDeclarativeItem::~QDeclarativeItem (this=0xd3d7e0, __in_chrg=<optimized out>) at graphicsitems/qdeclarativeitem.cpp:1668
#7  0x00007ff4774c6af5 in ~QDeclarativeElement (this=0xd3d7e0, __in_chrg=<optimized out>) at ../../include/QtDeclarative/../../src/declarative/qml/qdeclarativeprivate.h:87
#8  QDeclarativePrivate::QDeclarativeElement<QDeclarativeItem>::~QDeclarativeElement (this=0xd3d7e0, __in_chrg=<optimized out>) at ../../include/QtDeclarative/../../src/declarative/qml/qdeclarativeprivate.h:87
#9  0x00007ff4738e2958 in QObject::event (this=0xd3d7e0, e=<optimized out>) at kernel/qobject.cpp:1176
#10 0x00007ff472c4a7b4 in notify_helper (e=0xbeccd0, receiver=0xd3d7e0, this=0x9954f0) at kernel/qapplication.cpp:4556
Comment 23 Thomas Lübking 2013-02-15 23:28:01 UTC
*** Bug 304617 has been marked as a duplicate of this bug. ***
Comment 24 troy R 2013-02-18 09:29:13 UTC
Created attachment 77402 [details]
New crash information added by DrKonqi

kwin (4.10.00) on KDE Platform 4.10.00 using Qt 4.8.3

- What I was doing when the application crashed:
changing window decaration,
does this every time

-- Backtrace (Reduced):
#7  0x00007f5b5d602dd7 in QDeclarativeItem::~QDeclarativeItem (this=0x1899f60, __in_chrg=<optimized out>) at graphicsitems/qdeclarativeitem.cpp:1668
#8  0x00007f5b5d5c66ee in ~QDeclarativeElement (this=0x1899f60, __in_chrg=<optimized out>) at ../../include/QtDeclarative/../../src/declarative/qml/qdeclarativeprivate.h:87
#9  QDeclarativePrivate::QDeclarativeElement<QDeclarativeItem>::~QDeclarativeElement (this=0x1899f60, __in_chrg=<optimized out>) at ../../include/QtDeclarative/../../src/declarative/qml/qdeclarativeprivate.h:87
#10 0x00007f5b59aac468 in QObject::event (this=0x1899f60, e=<optimized out>) at kernel/qobject.cpp:1176
#11 0x00007f5b58e3ee9c in QApplicationPrivate::notify_helper (this=this@entry=0x15b4d90, receiver=receiver@entry=0x1899f60, e=e@entry=0x24dd030) at kernel/qapplication.cpp:4562
Comment 25 damir 2013-02-22 13:47:59 UTC
Created attachment 77510 [details]
New crash information added by DrKonqi

kwin (4.10.00) on KDE Platform 4.10.00 using Qt 4.8.3

- Change Plasma theme

- change from one to other

- nothing change

-- Backtrace (Reduced):
#6  0x00007f57309d9dd4 in QDeclarativeItem::~QDeclarativeItem (this=0x2054170, __in_chrg=<optimized out>) at graphicsitems/qdeclarativeitem.cpp:1668
#7  0x00007f573099d6ee in ~QDeclarativeElement (this=0x2054170, __in_chrg=<optimized out>) at ../../include/QtDeclarative/../../src/declarative/qml/qdeclarativeprivate.h:87
#8  QDeclarativePrivate::QDeclarativeElement<QDeclarativeItem>::~QDeclarativeElement (this=0x2054170, __in_chrg=<optimized out>) at ../../include/QtDeclarative/../../src/declarative/qml/qdeclarativeprivate.h:87
#9  0x00007f572cedf498 in QObject::event (this=0x2054170, e=<optimized out>) at kernel/qobject.cpp:1176
#10 0x00007f572c271e9c in QApplicationPrivate::notify_helper (this=this@entry=0x1c84ea0, receiver=receiver@entry=0x2054170, e=e@entry=0x21758d0) at kernel/qapplication.cpp:4562
Comment 26 Jekyll Wu 2013-02-23 14:26:57 UTC
*** Bug 315671 has been marked as a duplicate of this bug. ***
Comment 27 Christoph Feck 2013-03-02 01:48:41 UTC
*** Bug 315984 has been marked as a duplicate of this bug. ***
Comment 28 Thomas Lübking 2013-03-02 15:08:29 UTC
*** Bug 316001 has been marked as a duplicate of this bug. ***
Comment 29 eric.erfanian 2013-03-02 19:26:12 UTC
I can also confirm this bug when changing decorations in 4.10.

All of kwin doesn't crash, but the top title bar/window decoration goes away.

kwin --replace solves the issue.
Comment 30 Thomas Lübking 2013-03-02 19:28:17 UTC
That is not nearly the same bug.
Please file a new one any attach the output of "qdbus org.kde.kwin /KWin supportInformation" there as well as "from what decoration to what decoration" you switched and (because of the other report ;-) whether it only occurs for freshly installed decos from GHNS.
Comment 31 Jekyll Wu 2013-03-03 23:54:12 UTC
*** Bug 316076 has been marked as a duplicate of this bug. ***
Comment 32 Thomas Lübking 2013-03-05 09:44:55 UTC
*** Bug 316152 has been marked as a duplicate of this bug. ***
Comment 33 Thomas Lübking 2013-03-05 09:46:12 UTC
last dupe claims relation to raster graphicssystem and/or opengl compositor
Comment 34 Dustin Falgout 2013-03-05 10:40:19 UTC
Can someone explain to me what is going on with this bug? It says its closed and yet I believe we are all still experiencing the issue. Is there a workaround or patch?
Comment 35 Thomas Lübking 2013-03-05 12:03:32 UTC
"resolved upstream" - it's a bug in Qt.
Bug #300393 claims it to be fixed with Qt 4.8.4
Comment 36 evtux 2013-03-05 12:18:12 UTC
As far as a workaround, gotta report this:

I switched form nouveau to one of the proprietary nvidia drivers.  The  
behavior went away.  My card is a geforce 7600.


On Tue, 05 Mar 2013 12:40:19 +0200, Dustin Falgout <falgout@outlook.com>  
wrote:

> https://bugs.kde.org/show_bug.cgi?id=311018
>
> --- Comment #34 from Dustin Falgout <falgout@outlook.com> ---
> Can someone explain to me what is going on with this bug? It says its  
> closed
> and yet I believe we are all still experiencing the issue. Is there a
> workaround or patch?
>
Comment 37 GGG 2013-03-06 16:45:26 UTC
Created attachment 77805 [details]
New crash information added by DrKonqi

systemsettings (1.0) on KDE Platform 4.10.00 using Qt 4.8.4

- What I was doing when the application crashed:
Navigating through the SystemSettings application
- Unusual behavior I noticed:
Xorg eats 100% of CPU at that moment even if  I switch desktop effects off

-- Backtrace (Reduced):
#7  0x00007fb0fc84b947 in QDeclarativeItem::~QDeclarativeItem (this=0x512f350, __in_chrg=<optimized out>) at graphicsitems/qdeclarativeitem.cpp:1668
#8  0x00007fb0fc81010e in ~QDeclarativeElement (this=0x512f350, __in_chrg=<optimized out>) at ../../include/QtDeclarative/../../src/declarative/qml/qdeclarativeprivate.h:87
#9  QDeclarativePrivate::QDeclarativeElement<QDeclarativeItem>::~QDeclarativeElement (this=0x512f350, __in_chrg=<optimized out>) at ../../include/QtDeclarative/../../src/declarative/qml/qdeclarativeprivate.h:87
#10 0x00007fb0ffc925d8 in QObject::event (this=0x512f350, e=<optimized out>) at kernel/qobject.cpp:1175
#11 0x00007fb1008db8ec in QApplicationPrivate::notify_helper (this=this@entry=0x925630, receiver=receiver@entry=0x512f350, e=e@entry=0x20935c0) at kernel/qapplication.cpp:4567
Comment 38 GGG 2013-03-08 07:08:12 UTC
Created attachment 77849 [details]
New crash information added by DrKonqi

kwin (4.10.1) on KDE Platform 4.10.1 using Qt 4.8.4

- What I was doing when the application crashed:

I was changing window decoration behavior for mouse event, i.e. to shade windows for a wheel scroll, to lower for middle button

- Unusual behavior I noticed:

Window decodations dissapeared fora moment, then reappeared with a crash handler	

- Custom settings of the application:

Custom mouse events settings

-- Backtrace (Reduced):
#6  0x00007f24b53de944 in QDeclarativeItem::~QDeclarativeItem (this=0x170ec20, __in_chrg=<optimized out>) at graphicsitems/qdeclarativeitem.cpp:1668
#7  0x00007f24b53a310e in ~QDeclarativeElement (this=0x170ec20, __in_chrg=<optimized out>) at ../../include/QtDeclarative/../../src/declarative/qml/qdeclarativeprivate.h:87
#8  QDeclarativePrivate::QDeclarativeElement<QDeclarativeItem>::~QDeclarativeElement (this=0x170ec20, __in_chrg=<optimized out>) at ../../include/QtDeclarative/../../src/declarative/qml/qdeclarativeprivate.h:87
#9  0x00007f24b18875d8 in QObject::event (this=0x170ec20, e=<optimized out>) at kernel/qobject.cpp:1175
#10 0x00007f24b0c138ec in QApplicationPrivate::notify_helper (this=this@entry=0x14ed5a0, receiver=receiver@entry=0x170ec20, e=e@entry=0x2155610) at kernel/qapplication.cpp:4567
Comment 39 Thomas Lübking 2013-03-09 20:17:24 UTC
Can anybody reproducing this crash try https://git.reviewboard.kde.org/r/109273/
It's supposed to fix/workaround/bypass sth. different but *might* implicitly bypass this issue as well.
Comment 40 Dustin Falgout 2013-03-10 01:17:07 UTC
Just how would I go about testing this for you? I have tried searching for the aurorae.cpp file to edit but cant find it so I am probably way off base. If you could point me in the right direction, I will test it tonight. Thanks!

(In reply to comment #39)
> Can anybody reproducing this crash try
> https://git.reviewboard.kde.org/r/109273/
> It's supposed to fix/workaround/bypass sth. different but *might* implicitly
> bypass this issue as well.
Comment 41 Thomas Lübking 2013-03-10 01:40:13 UTC
you should be able to download the patch and from the kwin dir
patch -p2 < path/to/patch.diff

the sources are in kde-workspace/kwin/clients/aurorae/src/aurorae.cpp
it's sufficient to recompile/install only the aurorae client.
Comment 42 Dustin Falgout 2013-03-11 04:30:00 UTC
I do not have that directory. The only aurorae directory I have is at /usr/share/kde4/apps/kwin/aurorae but it only contains some .qml files. I even tried several different searches for aurorae.cpp as well as trying to find other directories in the path you gave and came up with nothing. Either I am crazy, or its not on my system lol

(In reply to comment #41)
> you should be able to download the patch and from the kwin dir
> patch -p2 < path/to/patch.diff
> 
> the sources are in kde-workspace/kwin/clients/aurorae/src/aurorae.cpp
> it's sufficient to recompile/install only the aurorae client.
Comment 43 Thomas Lübking 2013-03-11 11:34:26 UTC
you have to compile kwin yourself for this, it's not like patching some runtime resource - this is the sourcecode for gcc
Comment 44 Dustin Falgout 2013-03-11 15:25:06 UTC
Oh ok that would explain it then. Sorry, I have only been using linux as my daily driver for about 2 months, so there is a lot left for me to learn. I am willing to try it out if you still need it tested and if you dont mind giving me some instructions.


(In reply to comment #43)
> you have to compile kwin yourself for this, it's not like patching some
> runtime resource - this is the sourcecode for gcc
Comment 45 Thomas Lübking 2013-03-24 21:59:36 UTC
this *could* bypass this crash (not "fix" it, though)
It would be great if anyone encountering it could provide feedback on the 4.10.2 situation, thanks.

-----------

Git commit 45a6f0a2ecc79fe974f69cde6c4941dfb6ec5ab8 by Thomas Lübking.
Committed on 03/03/2013 at 21:46.
Pushed by luebking into branch 'KDE/4.10'.

fix aurorae theme loading

I've no real idea what breaks the theme -> qml assignment but the patch
re/creates the theme object (just as the engine and component) with the theme
FIXED-IN: 4.10.2
REVIEW: 109273

M  +2    -5    kwin/clients/aurorae/src/aurorae.cpp

http://commits.kde.org/kde-workspace/45a6f0a2ecc79fe974f69cde6c4941dfb6ec5ab8
Comment 46 Thomas Lübking 2013-03-26 22:06:56 UTC
*** Bug 317409 has been marked as a duplicate of this bug. ***
Comment 47 Thomas Lübking 2013-04-27 22:16:23 UTC
*** Bug 318997 has been marked as a duplicate of this bug. ***
Comment 48 Christoph Feck 2013-05-13 12:48:22 UTC
Latest duplicate is from Qt 4.8.4 / KDE 4.10.2, so the workaround is not effective.

I love QDeclarative crashes, they are so easy to debug...
Comment 49 Jekyll Wu 2013-05-22 11:38:25 UTC
*** Bug 320120 has been marked as a duplicate of this bug. ***
Comment 50 Jekyll Wu 2013-05-25 10:30:24 UTC
*** Bug 320250 has been marked as a duplicate of this bug. ***