Bug 300393 - Crash when shutting down the system
Summary: Crash when shutting down the system
Status: RESOLVED FIXED
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: 4.9.2
Platform: Ubuntu Linux
: NOR crash
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
: 294415 295858 299632 301751 301867 302568 307382 308111 308198 308634 309662 320835 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-05-21 16:04 UTC by Maarten Bezemer
Modified: 2013-08-03 12:43 UTC (History)
14 users (show)

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Attachments
New crash information added by DrKonqi (5.77 KB, text/plain)
2012-08-15 04:37 UTC, Bob Scown
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Maarten Bezemer 2012-05-21 16:04:33 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.8.2 (4.8.2)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-24-generic x86_64
Distribution: Ubuntu 12.04 LTS

-- Information about the crash:
I wanted to shutdown the system and clicked/accepted the confirmation message.
System started to shutdown and then I got this crash. While typing this report, the shutdown procedure continued (properly I suppose) as my screen is black (except for application to fill in the report)

-- Backtrace:
Application: Plasma Desktop Shell (plasma-desktop), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f59f1191780 (LWP 1975))]

Thread 4 (Thread 0x7f59d0fc4700 (LWP 1978)):
#0  0x00007f59f0a5eb03 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f59e4c1bff6 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f59e4c1c124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f59edc3c426 in QEventDispatcherGlib::processEvents (this=0x7f59c00008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f59edc0bc82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f59edc0bed7 in QEventLoop::exec (this=0x7f59d0fc3dd0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f59edb0afa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f59edbeb9ff in QInotifyFileSystemWatcherEngine::run (this=0x2699430) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f59edb0dfcb in QThreadPrivate::start (arg=0x2699430) at thread/qthread_unix.cpp:298
#9  0x00007f59e5520e9a in start_thread (arg=0x7f59d0fc4700) at pthread_create.c:308
#10 0x00007f59f0a6a4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f59c67f1700 (LWP 1979)):
#0  0x00007f59e4c1b680 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f59e4c1bf1b in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f59e4c1c124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f59edc3c426 in QEventDispatcherGlib::processEvents (this=0x7f59b80008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f59edc0bc82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f59edc0bed7 in QEventLoop::exec (this=0x7f59c67f0dd0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f59edb0afa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f59edbeb9ff in QInotifyFileSystemWatcherEngine::run (this=0x272d310) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f59edb0dfcb in QThreadPrivate::start (arg=0x272d310) at thread/qthread_unix.cpp:298
#9  0x00007f59e5520e9a in start_thread (arg=0x7f59c67f1700) at pthread_create.c:308
#10 0x00007f59f0a6a4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f59bffff700 (LWP 1980)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f59ea9f0222 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#2  0x00007f59ea9f0259 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#3  0x00007f59e5520e9a in start_thread (arg=0x7f59bffff700) at pthread_create.c:308
#4  0x00007f59f0a6a4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f59f1191780 (LWP 1975)):
[KCrash Handler]
#6  0x00007f59e9c4b90e in QDeclarativeItem::~QDeclarativeItem (this=0x42e4fd0, __in_chrg=<optimized out>) at graphicsitems/qdeclarativeitem.cpp:1668
#7  0x00007f59e9c0ea35 in ~QDeclarativeElement (this=0x42e4fd0, __in_chrg=<optimized out>) at ../../include/QtDeclarative/../../src/declarative/qml/qdeclarativeprivate.h:87
#8  QDeclarativePrivate::QDeclarativeElement<QDeclarativeItem>::~QDeclarativeElement (this=0x42e4fd0, __in_chrg=<optimized out>) at ../../include/QtDeclarative/../../src/declarative/qml/qdeclarativeprivate.h:87
#9  0x00007f59edc26478 in QObject::event (this=0x42e4fd0, e=<optimized out>) at kernel/qobject.cpp:1176
#10 0x00007f59ecf8f894 in notify_helper (e=0x28ac390, receiver=0x42e4fd0, this=0x1e30220) at kernel/qapplication.cpp:4559
#11 QApplicationPrivate::notify_helper (this=0x1e30220, receiver=0x42e4fd0, e=0x28ac390) at kernel/qapplication.cpp:4531
#12 0x00007f59ecf94713 in QApplication::notify (this=0x1e150b0, receiver=0x42e4fd0, e=0x28ac390) at kernel/qapplication.cpp:4420
#13 0x00007f59ee8e9b46 in KApplication::notify (this=0x1e150b0, receiver=0x42e4fd0, event=0x28ac390) at ../../kdeui/kernel/kapplication.cpp:311
#14 0x00007f59edc0ce9c in QCoreApplication::notifyInternal (this=0x1e150b0, receiver=0x42e4fd0, event=0x28ac390) at kernel/qcoreapplication.cpp:876
#15 0x00007f59edc10c6a in sendEvent (event=0x28ac390, receiver=0x42e4fd0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#16 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=52, data=0x1dbb1f0) at kernel/qcoreapplication.cpp:1500
#17 0x00007f59edc10f9e in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1155
#18 0x00007f59f0d76a13 in kdemain () from /usr/lib/kde4/libkdeinit/libkdeinit4_plasma-desktop.so
#19 0x00007f59f099976d in __libc_start_main (main=0x400640, argc=1, ubp_av=0x7fff02201af8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff02201ae8) at libc-start.c:226
#20 0x0000000000400671 in _start ()

Possible duplicates by query: bug 299632, bug 295858.

Reported using DrKonqi
Comment 1 Beat Wolf 2012-05-24 08:40:34 UTC
*** Bug 299632 has been marked as a duplicate of this bug. ***
Comment 2 Beat Wolf 2012-05-24 08:40:40 UTC
*** Bug 295858 has been marked as a duplicate of this bug. ***
Comment 3 Jekyll Wu 2012-06-13 22:32:52 UTC
*** Bug 301867 has been marked as a duplicate of this bug. ***
Comment 4 Myriam Schweingruber 2012-06-19 18:26:26 UTC
Confirmed by duplicates
Comment 5 Lamarque V. Souza 2012-06-26 22:39:42 UTC
*** Bug 302568 has been marked as a duplicate of this bug. ***
Comment 6 Marco Martin 2012-06-28 09:58:12 UTC
*** Bug 301751 has been marked as a duplicate of this bug. ***
Comment 7 Marco Martin 2012-06-28 09:58:39 UTC
*** Bug 294415 has been marked as a duplicate of this bug. ***
Comment 8 Christoph Feck 2012-07-02 18:44:09 UTC
If you can reproduce this crash, could you please try removing/adding widgets to find out which of them is causing the bug?
Comment 9 Myriam Schweingruber 2012-07-17 10:52:44 UTC
Please see comment #8
Comment 10 Maarten Bezemer 2012-07-17 11:22:23 UTC
I cannot reproduce the crash (anymore). I suppose there was something broken and 'fixed' by rebooting...?
Although there are other people who seemingly have the same crash, so maybe they are able to reproduce it?
Comment 11 Bob Scown 2012-08-15 04:37:03 UTC
Created attachment 73172 [details]
New crash information added by DrKonqi

plasma-desktop (0.4) on KDE Platform 4.9.00 using Qt 4.8.1

- What I was doing when the application crashed:
Started Kubuntu, played KPatience (card game), closed KPatience and initiated shutdown.

-- Backtrace (Reduced):
#6  0x00007f983ce8790e in QDeclarativeItem::~QDeclarativeItem (this=0x47f26c0, __in_chrg=<optimized out>) at graphicsitems/qdeclarativeitem.cpp:1668
#7  0x00007f983ce4aa35 in ~QDeclarativeElement (this=0x47f26c0, __in_chrg=<optimized out>) at ../../include/QtDeclarative/../../src/declarative/qml/qdeclarativeprivate.h:87
#8  QDeclarativePrivate::QDeclarativeElement<QDeclarativeItem>::~QDeclarativeElement (this=0x47f26c0, __in_chrg=<optimized out>) at ../../include/QtDeclarative/../../src/declarative/qml/qdeclarativeprivate.h:87
#9  0x00007f983b26e478 in QObject::event (this=0x47f26c0, e=<optimized out>) at kernel/qobject.cpp:1176
#10 0x00007f983a5d7894 in notify_helper (e=0x46b6b50, receiver=0x47f26c0, this=0x247bf70) at kernel/qapplication.cpp:4559
Comment 12 Christoph Feck 2012-09-25 19:30:51 UTC
*** Bug 307382 has been marked as a duplicate of this bug. ***
Comment 13 Jekyll Wu 2012-10-09 07:37:18 UTC
*** Bug 308111 has been marked as a duplicate of this bug. ***
Comment 14 Myriam Schweingruber 2012-10-11 13:31:39 UTC
*** Bug 308198 has been marked as a duplicate of this bug. ***
Comment 15 Myriam Schweingruber 2012-10-22 11:08:11 UTC
*** Bug 308634 has been marked as a duplicate of this bug. ***
Comment 16 Christoph Feck 2012-11-06 20:31:15 UTC
*** Bug 309662 has been marked as a duplicate of this bug. ***
Comment 17 Myriam Schweingruber 2012-12-16 12:15:56 UTC
Set status correctly.
Comment 18 Christoph Feck 2012-12-16 12:52:13 UTC
This bug is most likely fixed with Qt 4.8.4. Can anyone confirm?
Comment 19 David Edmundson 2013-01-17 07:45:09 UTC
Please reopen if this occurs with using Qt > 4.8.4
Comment 20 Anne-Marie Mahfouf 2013-06-07 06:39:42 UTC
*** Bug 320835 has been marked as a duplicate of this bug. ***
Comment 21 Cecilia Stevens 2013-08-03 12:43:11 UTC
I'm having this issue, running KDE 4.8.4 on Debian 7.1. It seems to crash every time I log out.

-backtrace
Application: Plasma Desktop Shell (plasma-desktop), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fd28b11b780 (LWP 4998))]

Thread 3 (Thread 0x7fd268c6f700 (LWP 5019)):
#0  0x00007fd27f981205 in pthread_mutex_lock () from /lib/x86_64-linux-gnu/libpthread.so.0
#1  0x00007fd27eeab421 in g_mutex_lock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fd27ee6f60a in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fd27ee6f744 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007fd287d2e296 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#5  0x00007fd287cfe8af in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#6  0x00007fd287cfeb38 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#7  0x00007fd287c01d70 in QThread::exec() () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#8  0x00007fd287cdf1bf in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#9  0x00007fd287c04d0b in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#10 0x00007fd27f97eb50 in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#11 0x00007fd28ab70a7d in clone () from /lib/x86_64-linux-gnu/libc.so.6
#12 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fd25a7fd700 (LWP 5029)):
#0  0x00007fd27f9832d4 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/x86_64-linux-gnu/libpthread.so.0
#1  0x00007fd284d6de77 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#2  0x00007fd284d6dea9 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#3  0x00007fd27f97eb50 in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#4  0x00007fd28ab70a7d in clone () from /lib/x86_64-linux-gnu/libc.so.6
#5  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fd28b11b780 (LWP 4998)):
[KCrash Handler]
#5  0x00007fd28766e7a8 in QGraphicsItemPrivate::setVisibleHelper(bool, bool, bool) () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#6  0x00007fd26d33ec99 in ?? () from /usr/lib/python2.7/dist-packages/PyQt4/QtGui.so
#7  0x00007fd26e1ed422 in PyEval_EvalFrameEx () from /usr/lib/libpython2.7.so.1.0
#8  0x00007fd26e1ee2e8 in PyEval_EvalCodeEx () from /usr/lib/libpython2.7.so.1.0
#9  0x00007fd26e244806 in ?? () from /usr/lib/libpython2.7.so.1.0
#10 0x00007fd26e2d3d3e in PyObject_Call () from /usr/lib/libpython2.7.so.1.0
#11 0x00007fd26e322810 in ?? () from /usr/lib/libpython2.7.so.1.0
#12 0x00007fd26e2d3d3e in PyObject_Call () from /usr/lib/libpython2.7.so.1.0
#13 0x00007fd26e2d4647 in PyEval_CallObjectWithKeywords () from /usr/lib/libpython2.7.so.1.0
#14 0x00007fd26e2bd1e3 in ?? () from /usr/lib/libpython2.7.so.1.0
#15 0x00007fd26e27a509 in ?? () from /usr/lib/libpython2.7.so.1.0
#16 0x00007fd26e2912b7 in ?? () from /usr/lib/libpython2.7.so.1.0
#17 0x00007fd26e32a494 in PyDict_SetItem () from /usr/lib/libpython2.7.so.1.0
#18 0x00007fd26e26a638 in _PyObject_GenericSetAttrWithDict () from /usr/lib/libpython2.7.so.1.0
#19 0x00007fd26e2b8ccf in PyObject_SetAttr () from /usr/lib/libpython2.7.so.1.0
#20 0x00007fd26e1e9541 in PyEval_EvalFrameEx () from /usr/lib/libpython2.7.so.1.0
#21 0x00007fd26e1ee2e8 in PyEval_EvalCodeEx () from /usr/lib/libpython2.7.so.1.0
#22 0x00007fd26e244806 in ?? () from /usr/lib/libpython2.7.so.1.0
#23 0x00007fd26e2d3d3e in PyObject_Call () from /usr/lib/libpython2.7.so.1.0
#24 0x00007fd26e322810 in ?? () from /usr/lib/libpython2.7.so.1.0
#25 0x00007fd26e2d3d3e in PyObject_Call () from /usr/lib/libpython2.7.so.1.0
#26 0x00007fd26e2d4647 in PyEval_CallObjectWithKeywords () from /usr/lib/libpython2.7.so.1.0
#27 0x00007fd26d90f102 in ?? () from /usr/lib/python2.7/dist-packages/sip.so
#28 0x00007fd26d9107db in sip_api_common_dtor () from /usr/lib/python2.7/dist-packages/sip.so
#29 0x00007fd26cbb3156 in sipPlasma_AppletScript::~sipPlasma_AppletScript() () from /usr/lib/python2.7/dist-packages/PyKDE4/plasma.so
#30 0x00007fd26cbb3169 in sipPlasma_AppletScript::~sipPlasma_AppletScript() () from /usr/lib/python2.7/dist-packages/PyKDE4/plasma.so
#31 0x00007fd28a682e48 in ?? () from /usr/lib/libplasma.so.3
#32 0x00007fd28a68c3ad in Plasma::Applet::~Applet() () from /usr/lib/libplasma.so.3
#33 0x00007fd28a68c3f9 in Plasma::Applet::~Applet() () from /usr/lib/libplasma.so.3
#34 0x00007fd28a69bc4e in Plasma::Containment::~Containment() () from /usr/lib/libplasma.so.3
#35 0x00007fd26e8adbc9 in ?? () from /usr/lib/kde4/plasma_containment_desktop.so
#36 0x00007fd28a6ac22e in ?? () from /usr/lib/libplasma.so.3
#37 0x00007fd28a6ac435 in Plasma::Corona::~Corona() () from /usr/lib/libplasma.so.3
#38 0x00007fd28ae58829 in ?? () from /usr/lib/kde4/libkdeinit/libkdeinit4_plasma-desktop.so
#39 0x00007fd28ae7783b in ?? () from /usr/lib/kde4/libkdeinit/libkdeinit4_plasma-desktop.so
#40 0x00007fd28ae7c68a in ?? () from /usr/lib/kde4/libkdeinit/libkdeinit4_plasma-desktop.so
#41 0x00007fd287d1554f in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#42 0x00007fd287d03d4d in QCoreApplication::exec() () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#43 0x00007fd28ae634c5 in kdemain () from /usr/lib/kde4/libkdeinit/libkdeinit4_plasma-desktop.so
#44 0x00007fd28aab4ead in __libc_start_main () from /lib/x86_64-linux-gnu/libc.so.6
#45 0x0000000000400781 in _start ()