Bug 310762 - Desktop icon plasmoid does not launch application anymore when they are unlocked.
Summary: Desktop icon plasmoid does not launch application anymore when they are unloc...
Status: RESOLVED FIXED
Alias: None
Product: plasma4
Classification: Plasma
Component: widget-misc (show other bugs)
Version: 4.9.90 Beta2
Platform: unspecified Linux
: NOR major (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords: regression, reproducible
: 311892 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-11-27 13:50 UTC by Kai Uwe Broulik
Modified: 2012-12-20 10:11 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:
adaptee: Usability-


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kai Uwe Broulik 2012-11-27 13:50:13 UTC
[Using master]
The desktop icon plasmoid does no longer launch an application anymore. It used to work a few days ago, then it suddenly broke. When you click the icon, the mousedown effecton does not launch. 

Reproducible: Always

Steps to Reproduce:
1. Open kickoff and drag any application, such as systemsettings or dolphin, onto your workspace (make sure widgets are unlocked)
2. Click the icon that got created
3.
Actual Results:  
The mousedown effect is applied but nothing happens

Expected Results:  
The application starts normal

Also true with other file formats such as pictures (ie. drag a file onto the workspace and select "Icon" from the Widgets section of the popup menu)
Comment 1 Jekyll Wu 2012-11-27 14:43:43 UTC
I can also reproduce it using master. It doesn't work when widgets are unlocked.
Comment 2 Andrew Tee 2012-12-06 09:13:15 UTC
also suffering from this in 4.9.90
Comment 3 Jekyll Wu 2012-12-19 14:07:30 UTC
*** Bug 311892 has been marked as a duplicate of this bug. ***
Comment 4 Aaron J. Seigo 2012-12-20 10:11:11 UTC
Git commit 2a685d9a1d87d11680970cea88cdcc96da17d514 by Aaron Seigo.
Committed on 20/12/2012 at 11:10.
Pushed by aseigo into branch 'master'.

don't register the icon as a dragable with the applet

this causes events to be intercepted which prevent launching when
the applet is movable.

M  +1    -3    plasma/generic/applets/icon/icon.cpp

http://commits.kde.org/kde-workspace/2a685d9a1d87d11680970cea88cdcc96da17d514