Bug 310592 - Some icons of symlinks folders are bigger than others
Summary: Some icons of symlinks folders are bigger than others
Status: RESOLVED FIXED
Alias: None
Product: dolphin
Classification: Unclassified
Component: view-engine: icons mode (show other bugs)
Version: 4.11.2
Platform: Ubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Dolphin Bug Assignee
URL: http://i.imgur.com/mBZsF.png
Keywords: reproducible
Depends on:
Blocks:
 
Reported: 2012-11-24 04:01 UTC by Frank Souza
Modified: 2014-03-06 13:04 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 4.13.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Frank Souza 2012-11-24 04:01:54 UTC
Some icons of symlinks folders are bigger than others

This is random, I do not know when it happens, but I can say some bug features:

It does not happen when in preview mode
Is not related to the icon theme (also tested with default oxygen theme and many others)
I copy the folder containing the symlink odd, and the problem continues with the symlink copied
This has been happening since KDE 4.8

Reproducible: Couldn't Reproduce

Actual Results:  
Some icons are larger than others, and seem out of place

Expected Results:  
Icon size should be the same size as the other
Comment 1 Frank Souza 2012-11-24 04:06:39 UTC
Another information:
Happens between the minimum zoom to zoom up to 96 px
Comment 2 Frank Reininghaus 2012-11-24 04:23:11 UTC
Thanks for the bug report, I can reproduce this. Seems to be related to the length of the file name.
Comment 3 Emmanuel Pescosta 2013-09-04 18:45:14 UTC
Still reproducible?

I can't reproduce it in Dolphin 4.11.0.
Comment 4 Frank Reininghaus 2013-10-10 15:44:30 UTC
I cannot reproduce either. Please reopen if you see the problem again in Dolphin 4.11.2 or later. Thanks!
Comment 5 Frank Souza 2013-10-10 23:19:16 UTC
The problem persists

Ubuntu 12.04
Dolphin 4.11.2

Watch: http://www.youtube.com/watch?v=dkyIbayy1wM
Comment 6 Emmanuel Pescosta 2013-10-11 08:03:38 UTC
Thanks for your immediate feedback and for the video!
Comment 7 Frank Reininghaus 2013-10-18 17:43:02 UTC
I think I have an idea about what might be going wrong. Could you please try the following:

In a different folder, create a regular file or folder with the same name that one of the symlinks that gets such a huge icon has. If you use exactly the same view settings, could it be that the non-symlink needs one more line of text below the icon than the symlink?

If my assumption is true, then the problem is that

KStandardItemListWidgetInformant::itemSizeHint(int index, const KItemListView* view)

calculates the number of lines required for the item's name based on the metrics of the non-italic font. When the view tries to render the item on the screen, it uses the italic font and finds that needs less space than it reserved earlier for the item, and then uses the excess space to show a bigger icon.

Similar bugs are bug 326210 (about incorrect text rendering for symlinks in Compact View), bug 308022 and bug 323841 (which are about the view drawing a blurry icon because the reserved height for the item is 1 pixel less than is actually needed).
Comment 8 Emmanuel Pescosta 2014-02-27 14:15:51 UTC
Review-Request: https://git.reviewboard.kde.org/r/116121/

Can someone, who can reproduce this bug, please test if this patch fixes the problem? Thanks!
Comment 9 Frank Souza 2014-02-27 14:24:36 UTC
What version was this fixed?
Comment 10 Frank Souza 2014-02-27 14:27:25 UTC
Oh, I see, 4.13. I'll wait for updates, then I can test...sorry again. 4.12.2 here
Comment 11 Emmanuel Pescosta 2014-03-06 13:02:40 UTC
Git commit b892058730544d53e0c08e32dc297f2f1256f9ae by Emmanuel Pescosta.
Committed on 05/03/2014 at 09:48.
Pushed by emmanuelp into branch 'KDE/4.13'.

Fix Bug 326210 - Dolphin unnecessarily truncates names of soft links in compact mode

FIXED-IN: 4.13.0
Related: bug 326210
REVIEW: 116121

M  +18   -0    dolphin/src/kitemviews/kfileitemlistwidget.cpp
M  +2    -0    dolphin/src/kitemviews/kfileitemlistwidget.h
M  +31   -5    dolphin/src/kitemviews/kstandarditemlistwidget.cpp
M  +12   -0    dolphin/src/kitemviews/kstandarditemlistwidget.h

http://commits.kde.org/kde-baseapps/b892058730544d53e0c08e32dc297f2f1256f9ae
Comment 12 Emmanuel Pescosta 2014-03-06 13:04:26 UTC
@Frank Souza:
Thanks for your help! Feel free to reopen this bug report if you can reproduce it in 4.13.0 ;)