Bug 308022 - Thumbs and icons in the main pane have become blurry and ugly
Summary: Thumbs and icons in the main pane have become blurry and ugly
Status: RESOLVED DUPLICATE of bug 323841
Alias: None
Product: dolphin
Classification: Unclassified
Component: view-engine: icons mode (show other bugs)
Version: 2.1
Platform: openSUSE RPMs Linux
: NOR major (vote)
Target Milestone: ---
Assignee: Dolphin Bug Assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-10-07 13:22 UTC by Rahul Goma Phulore
Modified: 2013-12-08 09:55 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rahul Goma Phulore 2012-10-07 13:22:18 UTC
The icons and thumbnails in the main pane of Dolphin 2.1 look blurry and ugly. That was not the case with 2.0.

Below are a few screenshots to demonstrate the problem.

With Dolphin 2.0, nice and crisp, with icon sizes 48 and 64: 
http://imgur.com/a/N49ro

With Dolphin 2.1, blurry and ugly, with icon sizes 48 and 64 respectively: 
http://imgur.com/a/ekgvQ


Reproducible: Always

Steps to Reproduce:
1. Open any directory with some directories, images, and other thumb-able things.
Actual Results:  
Blurry and ugly icons/thumbs.

Expected Results:  
Nice and crisp icons/thumbs.
Comment 1 Christoph Feck 2012-10-08 08:49:46 UTC
Can you please make ensure that:
- both screen shots are made at the same screen resolution
- both are saved as PNG, not JPEG
- both are uploaded to a service that does not convert PNG to JPEG (if unsure, attach the PNGs here)
From comparing what you provided, the blurry screen shot is using a different screen resolution, but that is hard to tell with the JPEG artifacts visible.
Comment 2 Rahul Goma Phulore 2012-10-08 09:18:59 UTC
Hello. Thank you for your response. Replying bulletwise.
- That is a bit hard. One screenshot was taken on laptop; it has Dolphin 2.0 and slightly smaller resolution. Another screenshot was taken on desktop; it has Dolphin 2.1 and slightly greater resolution. Do you suggest I upgrade Dolphin on the laptop? Though I don't see how resolution is a relevant factor here.
- As far as I know, both images are saved by imgur in PNG format. On imgur, if you right click the gear at the top right, you get an option to see the images in their full resolution. See http://i.imgur.com/HtLig.png.
-
Comment 3 Christoph Feck 2012-10-08 11:30:26 UTC
Oh, I have JavaScript disabled, so I did not see the option to view the original size. Clicking on the image made that site scale it down to 1024 pixels and convert to JPEG. I suggest to use a different image sharing site in the future, which does not have those annoying "features".

The folder icon is indeed blurry, but somehow not exactly the same size as I see it on my system. Could you check if removing icon caches in /var/tmp/kde-<user>/ makes any difference? Could you also attach your dolphinrc file from ~/.kde/share/config/
Comment 4 Rahul Goma Phulore 2012-10-08 12:44:42 UTC
I have uploaded images to mediafire - http://www.mediafire.com/?a1k35veyyiexa.

On my side, for all sizes except 256, icons and thumbs look badly blurred.

I tried deleting the icon caches. That didn't help.

My dolphinrc - https://www.refheap.com/paste/5598.
Comment 5 Christoph Feck 2012-10-08 14:24:56 UTC
If you only have sharp 256 px icons, it is possible you only have "oxygen-icon-theme-large" installed, but you also need "oxygen-icon-theme" as well. Otherwise, I am still unsure what happens on your system.

Regarding the thumbnails, I think it is unrelated. Probably on the old system, scaling was done using full size images, while on the new system, JPEG previews are created from small resolution data, which can be extracted very fast (only DC coefficients, if you want to look it up).
Comment 6 Rahul Goma Phulore 2012-10-08 15:56:10 UTC
Icons in every other app look just fine, for all sizes. And when I had Dolphin 2.0 on my systems, they worked correctly there as well.
Comment 7 Rahul Goma Phulore 2012-10-08 15:59:19 UTC
Here is something interesting I discovered (at the cost of accidentally deleting whole of my ~/.kde4/share/config/ ... sigh):

I am using Aller, size 8 as my system font. 
If I change it to some other font, blurriness vanishes.
If I increase the size of my Aller font to 11 or more, blurriness vanishes.
If I keep my font as Aller 8, and force DPI of 120 or more, blurriness vanishes.

Would this information help?
Comment 8 Rahul Goma Phulore 2012-10-08 16:06:34 UTC
In my last comment, replace 8 by 9.
Comment 9 Frank Reininghaus 2013-10-17 16:11:59 UTC
Sorry for the very late feedback. I have never been able to reproduce the problem, but there has been another very similar report (bug 323841), which seems to be caused by an issue in Qt, and which mentions the "maximum number of lines" setting.

Do you also set a limit for the number of text lines in Icons View? Can you confirm that the problem disappears if you set the maximum number to "unlimited"? If that is the case, the bug reports are duplicates, and I have an idea how we might be able to work around the problem.

Thanks for your help!
Comment 10 Frank Reininghaus 2013-12-08 09:55:56 UTC

*** This bug has been marked as a duplicate of bug 323841 ***