Bug 309946 - KMail forgets "reply" or "forward" status in mails
Summary: KMail forgets "reply" or "forward" status in mails
Status: RESOLVED DUPLICATE of bug 291332
Alias: None
Product: Akonadi
Classification: Unclassified
Component: IMAP resource (show other bugs)
Version: GIT (master)
Platform: unspecified Linux
: NOR normal with 20 votes (vote)
Target Milestone: ---
Assignee: Christian Mollekopf
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-12 07:54 UTC by Thomas Fischer
Modified: 2013-11-30 14:45 UTC (History)
7 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Example of an email and its reply, missing the small "reply" overlay icon (12.32 KB, image/png)
2012-11-12 07:56 UTC, Thomas Fischer
Details
Before-after screenshot of the overlay icon (16.52 KB, image/png)
2012-11-12 08:06 UTC, Thomas Fischer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Fischer 2012-11-12 07:54:36 UTC
When replying to or forwarding emails, KMail does not properly set the status for this mail. A small "reply" or "forward" icon is set as an overlay on the mail's icon directly after sending the forward/reply, but this icon gets cleared as soon as one changes the mail folder.
In the mail's source view, there is neither a "status", nor a "x-status" set. Below, this is the header of a sent mail which was a reply to another mail:

From: AAAAAAAAAAAAAA
To: BBBBBBBBBBBBBBBBBBBBBB
Subject: Re: Restfull webservice
Date: Mon, CCCCCCCCCCCCCCCCCCCCC
Message-ID: DDDDDDDDDDDDDDDDDDDD
Organization: EEEEEEEEEEEEEEEEEEEEEEEEEEEEE
X-KMail-Identity: 1608138006
User-Agent: KMail/4.9.3 (Linux/3.6.6-1-ARCH; KDE/4.9.3; x86_64; ; )
In-Reply-To: FFFFFFFFFFFFFFFFFFFF
References: GGGGGGGGGGGGGGGGGGGGGG
MIME-Version: 1.0
Content-Transfer-Encoding: quoted-printable
Content-Type: text/plain; charset="utf-8"


Reproducible: Always
Comment 1 Thomas Fischer 2012-11-12 07:56:16 UTC
Created attachment 75192 [details]
Example of an email and its reply, missing the small "reply" overlay icon
Comment 2 Thomas Fischer 2012-11-12 08:06:33 UTC
Created attachment 75193 [details]
Before-after screenshot of the overlay icon
Comment 3 Laurent Montel 2012-11-12 08:18:16 UTC
Imap account ?
Comment 4 Thomas Fischer 2012-11-12 13:02:58 UTC
Yes, I forgot to mention this. MS Exchange via IMAP:
* OK The Microsoft Exchange IMAP4 service is ready.
Comment 5 Laurent Montel 2012-11-12 13:15:53 UTC
It's a problem from imap.
Known bug
Comment 6 Thomas Fischer 2012-11-12 13:58:22 UTC
> It's a problem from imap.
Ok, so it is on KMail's side and not Exchange?

> Known bug
Was this bug been filed previously? How can I help to fix it?
Comment 7 Cyrille Dunant 2013-04-04 09:21:31 UTC
I have that problem also, and I would be glad to help
Comment 8 Wolfgang Bauer 2013-07-23 14:12:35 UTC
I think this is the same as https://bugs.kde.org/show_bug.cgi?id=322346 and https://bugs.kde.org/show_bug.cgi?id=291332
Comment 9 Kevin Ottens 2013-11-16 07:29:52 UTC
The IMAP resource has a new maintainer, reassigning to him.
Comment 10 Christian Mollekopf 2013-11-20 12:05:18 UTC
Please reopen if I'm wrong.

*** This bug has been marked as a duplicate of bug 291332 ***
Comment 11 Andre Woebbeking 2013-11-20 20:28:39 UTC
Sorry, only the reply case is fixed.

There is no standard IMAP flag for forwarded, so this must be stored in Akonadi (this is already done) but must not be overwritten by the next sync. If I find some time I want to fix that too.
Comment 12 Andre Woebbeking 2013-11-30 14:45:32 UTC
Git commit 23662faa4f6684ea6a327b44b242ec9c28390e19 by Andre Woebbeking.
Committed on 30/11/2013 at 14:44.
Pushed by woebbe into branch 'KDE/4.12'.

Don't bother IMAP servers with not supported flags - part II

Added a Akonadi collection as parameter to ResourceTask::fromAkonadiToSupportedImapFlags()
to make sure that the method has always a collection to work with. Therefore the method
can also be static.

E.g. "forward" at least doesn't result in an error anymore.
REVIEW:114108

M  +1    -1    resources/imap/additemtask.cpp
M  +2    -2    resources/imap/changeitemsflagstask.cpp
M  +2    -2    resources/imap/changeitemtask.cpp
M  +3    -2    resources/imap/resourcetask.cpp
M  +1    -1    resources/imap/resourcetask.h

http://commits.kde.org/kdepim-runtime/23662faa4f6684ea6a327b44b242ec9c28390e19