Bug 309909 - Totem reproduciendo video
Summary: Totem reproduciendo video
Status: RESOLVED DUPLICATE of bug 303450
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-11 16:51 UTC by Asier
Modified: 2012-12-29 08:49 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Asier 2012-11-11 16:51:10 UTC
Application: kwin (4.8.5 (4.8.5))
KDE Platform Version: 4.8.5 (4.8.5)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-32-generic x86_64
Distribution: Ubuntu 12.04.1 LTS

-- Information about the crash:
- What I was doing when the application crashed:
I was closing Totem after I finished waching a film, with Firefox open.

The crash can be reproduced some of the time.

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7ff0584de780 (LWP 6893))]

Thread 3 (Thread 0x7ff02ffff700 (LWP 6900)):
#0  0x00007ff057cec023 in select () at ../sysdeps/unix/syscall-template.S:82
#1  0x00007ff0534e4366 in qt_safe_select (nfds=21, fdread=0x7ff028000ac8, fdwrite=0x7ff028000d60, fdexcept=0x7ff028000ff8, orig_timeout=<optimized out>) at kernel/qcore_unix.cpp:83
#2  0x00007ff0534e97b2 in QEventDispatcherUNIXPrivate::doSelect (this=0x7ff028000910, flags=..., timeout=0x0) at kernel/qeventdispatcher_unix.cpp:223
#3  0x00007ff0534e9ca3 in QEventDispatcherUNIX::processEvents (this=0x7ff0280008f0, flags=...) at kernel/qeventdispatcher_unix.cpp:926
#4  0x00007ff0534b6c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007ff0534b6ed7 in QEventLoop::exec (this=0x7ff02fffedd0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007ff0533b5fa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007ff0534969ff in QInotifyFileSystemWatcherEngine::run (this=0x1e41900) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007ff0533b8fcb in QThreadPrivate::start (arg=0x1e41900) at thread/qthread_unix.cpp:298
#9  0x00007ff04c5dde9a in start_thread (arg=0x7ff02ffff700) at pthread_create.c:308
#10 0x00007ff057cf2cbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7ff02f7fe700 (LWP 6901)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007ff0547a7222 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#2  0x00007ff0547a7259 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#3  0x00007ff04c5dde9a in start_thread (arg=0x7ff02f7fe700) at pthread_create.c:308
#4  0x00007ff057cf2cbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7ff0584de780 (LWP 6893)):
[KCrash Handler]
#6  0x0000000000000000 in ?? ()
#7  0x00007ff05283a894 in notify_helper (e=0x7fff682ca1d0, receiver=0x3303aa0, this=0x19438b0) at kernel/qapplication.cpp:4559
#8  QApplicationPrivate::notify_helper (this=0x19438b0, receiver=0x3303aa0, e=0x7fff682ca1d0) at kernel/qapplication.cpp:4531
#9  0x00007ff05283f713 in QApplication::notify (this=0x7fff682cadc0, receiver=0x3303aa0, e=0x7fff682ca1d0) at kernel/qapplication.cpp:4420
#10 0x00007ff0577cc3f6 in KApplication::notify (this=0x7fff682cadc0, receiver=0x3303aa0, event=0x7fff682ca1d0) at ../../kdeui/kernel/kapplication.cpp:311
#11 0x00007ff0534b7e9c in QCoreApplication::notifyInternal (this=0x7fff682cadc0, receiver=0x3303aa0, event=0x7fff682ca1d0) at kernel/qcoreapplication.cpp:876
#12 0x00007ff05283b862 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#13 QApplicationPrivate::sendMouseEvent (receiver=0x3303aa0, event=0x7fff682ca1d0, alienWidget=0x0, nativeWidget=0x3303aa0, buttonDown=0x0, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3170
#14 0x00007ff0528babf5 in QETWidget::translateMouseEvent (this=0x3303aa0, event=<optimized out>) at kernel/qapplication_x11.cpp:4617
#15 0x00007ff0528b9bae in QApplication::x11ProcessEvent (this=0x7fff682cadc0, event=0x7fff682caab0) at kernel/qapplication_x11.cpp:3732
#16 0x00007ff0528e3b3a in QEventDispatcherX11::processEvents (this=0x18f0ad0, flags=...) at kernel/qeventdispatcher_x11.cpp:132
#17 0x00007ff0534b6c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#18 0x00007ff0534b6ed7 in QEventLoop::exec (this=0x7fff682cad00, flags=...) at kernel/qeventloop.cpp:204
#19 0x00007ff0534bbf67 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#20 0x00007ff05801ec36 in kdemain (argc=<optimized out>, argv=<optimized out>) at ../../kwin/main.cpp:541
#21 0x00007ff057c2076d in __libc_start_main (main=0x400630 <main(int, char**)>, argc=1, ubp_av=0x7fff682cb4e8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff682cb4d8) at libc-start.c:226
#22 0x0000000000400661 in _start ()

Possible duplicates by query: bug 309889, bug 309824, bug 309801, bug 309788, bug 309775.

Reported using DrKonqi
Comment 1 Thomas Lübking 2012-11-11 17:47:30 UTC
this is effectively bug #303450 - what titlebar decoration do you use?
Comment 2 Asier 2012-11-11 21:42:54 UTC
KDE 4.8.5 and the decoration "Oxigen"


En Sun, 11 Nov 2012 18:47:30 +0100, Thomas Lübking   
<thomas.luebking@gmail.com> escribió:

> https://bugs.kde.org/show_bug.cgi?id=309909
>
> --- Comment #1 from Thomas Lübking <thomas.luebking@gmail.com> ---
> this is effectively bug #303450 - what titlebar decoration do you use?
>
Comment 3 Martin Flöser 2012-12-29 08:49:49 UTC
let's just assume it's the same :-)

*** This bug has been marked as a duplicate of bug 303450 ***