Bug 309775 - Crash on checking IMAP mail
Summary: Crash on checking IMAP mail
Status: RESOLVED DUPLICATE of bug 302459
Alias: None
Product: Akonadi
Classification: Unclassified
Component: IMAP resource (show other bugs)
Version: 4.9
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Kevin Ottens
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-08 21:46 UTC by Joshua J. Kugler
Modified: 2012-11-09 03:16 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Joshua J. Kugler 2012-11-08 21:46:08 UTC
Application: akonadi_imap_resource (4.9)
KDE Platform Version: 4.9.2
Qt Version: 4.8.2
Operating System: Linux 3.2.0-32-generic x86_64
Distribution: Ubuntu 12.04.1 LTS

-- Information about the crash:
I was checking mail on an Exchange 2010 server, and did not see the "accept certificate" dialog right away (it popped up in the background. After clicking accept, IMAP crashed.

-- Backtrace:
Application: Intel of type IMAP E-Mail Server (akonadi_imap_resource), signal: Bus error
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f1050354780 (LWP 6796))]

Thread 4 (Thread 0x7f103c8be700 (LWP 16448)):
#0  0x00007f104b34f05d in __pthread_mutex_unlock_usercnt (mutex=<optimized out>, decr=<optimized out>) at pthread_mutex_unlock.c:52
#1  __pthread_mutex_unlock (mutex=0x7f102c009d90) at pthread_mutex_unlock.c:290
#2  0x00007f104a86b5d1 in g_mutex_unlock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f104a83002a in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f104a830164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f104f767906 in QEventDispatcherGlib::processEvents (this=0x7f102c0304d0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00007f104f736e42 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f104f737097 in QEventLoop::exec (this=0x7f103c8bdde0, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007f104f636057 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#9  0x00007f104e36ac39 in KIMAP::SessionThread::run (this=0x1e50730) at ../../kimap/sessionthread.cpp:181
#10 0x00007f104f63907b in QThreadPrivate::start (arg=0x1e50730) at thread/qthread_unix.cpp:307
#11 0x00007f104b34be9a in start_thread (arg=0x7f103c8be700) at pthread_create.c:308
#12 0x00007f104bcf0cbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#13 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f1036630700 (LWP 31733)):
#0  0x00007f104b34f05d in __pthread_mutex_unlock_usercnt (mutex=<optimized out>, decr=<optimized out>) at pthread_mutex_unlock.c:52
#1  __pthread_mutex_unlock (mutex=0x7f103800e100) at pthread_mutex_unlock.c:290
#2  0x00007f104a86b5d1 in g_mutex_unlock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f104a82f83b in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f104a82ff5b in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f104a830164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#6  0x00007f104f767906 in QEventDispatcherGlib::processEvents (this=0x7f1038011ae0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#7  0x00007f104f736e42 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#8  0x00007f104f737097 in QEventLoop::exec (this=0x7f103662fdd0, flags=...) at kernel/qeventloop.cpp:204
#9  0x00007f104f636057 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#10 0x00007f104f716b4f in QInotifyFileSystemWatcherEngine::run (this=0x20d0670) at io/qfilesystemwatcher_inotify.cpp:248
#11 0x00007f104f63907b in QThreadPrivate::start (arg=0x20d0670) at thread/qthread_unix.cpp:307
#12 0x00007f104b34be9a in start_thread (arg=0x7f1036630700) at pthread_create.c:308
#13 0x00007f104bcf0cbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#14 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f102bcab700 (LWP 31797)):
#0  0x00007f104bce5303 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f104a830036 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f104a830164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f104f767906 in QEventDispatcherGlib::processEvents (this=0x7f101c00bc30, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f104f736e42 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f104f737097 in QEventLoop::exec (this=0x7f102bcaade0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f104f636057 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f104e36ac39 in KIMAP::SessionThread::run (this=0x1d31130) at ../../kimap/sessionthread.cpp:181
#8  0x00007f104f63907b in QThreadPrivate::start (arg=0x1d31130) at thread/qthread_unix.cpp:307
#9  0x00007f104b34be9a in start_thread (arg=0x7f102bcab700) at pthread_create.c:308
#10 0x00007f104bcf0cbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f1050354780 (LWP 6796)):
[KCrash Handler]
#6  QMetaObject::invokeMethod (obj=0x3ff0000000000000, member=<optimized out>, type=Qt::AutoConnection, ret=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1166
#7  0x00007f104e367497 in invokeMethod (val9=..., val8=..., val7=..., val6=..., val5=..., val4=..., val3=..., val2=..., val1=..., val0=..., member=<optimized out>, obj=<optimized out>) at /usr/include/qt4/QtCore/qobjectdefs.h:434
#8  KIMAP::SessionPrivate::handleSslError (this=0x1e9bd30, errorData=...) at ../../kimap/session.cpp:121
#9  0x00007f104f751926 in QObject::event (this=0x1efa4b0, e=<optimized out>) at kernel/qobject.cpp:1195
#10 0x00007f104eab97b4 in notify_helper (e=0x7f101c00c3e0, receiver=0x1efa4b0, this=0x1cf0c00) at kernel/qapplication.cpp:4556
#11 QApplicationPrivate::notify_helper (this=0x1cf0c00, receiver=0x1efa4b0, e=0x7f101c00c3e0) at kernel/qapplication.cpp:4528
#12 0x00007f104eabe583 in QApplication::notify (this=0x7fffbe176b90, receiver=0x1efa4b0, e=0x7f101c00c3e0) at kernel/qapplication.cpp:4417
#13 0x00007f104cbe0756 in KApplication::notify (this=0x7fffbe176b90, receiver=0x1efa4b0, event=0x7f101c00c3e0) at ../../kdeui/kernel/kapplication.cpp:311
#14 0x00007f104f73830c in QCoreApplication::notifyInternal (this=0x7fffbe176b90, receiver=0x1efa4b0, event=0x7f101c00c3e0) at kernel/qcoreapplication.cpp:915
#15 0x00007f104f73c0ea in sendEvent (event=0x7f101c00c3e0, receiver=0x1efa4b0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#16 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x1cc54d0) at kernel/qcoreapplication.cpp:1539
#17 0x00007f104f767473 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#18 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:279
#19 0x00007f104a82fd53 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#20 0x00007f104a8300a0 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#21 0x00007f104a830164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#22 0x00007f104f76789f in QEventDispatcherGlib::processEvents (this=0x1cc6cb0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#23 0x00007f104eb61cde in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#24 0x00007f104f736e42 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#25 0x00007f104f737097 in QEventLoop::exec (this=0x7fffbe176b10, flags=...) at kernel/qeventloop.cpp:204
#26 0x00007f104f73c3e7 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1187
#27 0x00007f104fe65746 in Akonadi::ResourceBase::init (r=0x1e31890) at ../../akonadi/resourcebase.cpp:451
#28 0x000000000041b2c6 in int Akonadi::ResourceBase::init<ImapResource>(int, char**) ()
#29 0x00007f104bc1e76d in __libc_start_main (main=0x415500, argc=3, ubp_av=0x7fffbe176ca8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fffbe176c98) at libc-start.c:226
#30 0x00000000004156b5 in _start ()

This bug may be a duplicate of or related to bug 302459.

Possible duplicates by query: bug 307197, bug 304955, bug 304110, bug 302459, bug 301881.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-11-09 03:16:08 UTC

*** This bug has been marked as a duplicate of bug 302459 ***