Bug 304110 - IMAP E-mail Server setup crash report
Summary: IMAP E-mail Server setup crash report
Status: RESOLVED DUPLICATE of bug 279113
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: IMAP resource (show other bugs)
Version: 4.8
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Kevin Ottens
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-26 20:22 UTC by pbhj
Modified: 2012-07-26 23:41 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description pbhj 2012-07-26 20:22:23 UTC
Application: akonadi_imap_resource (4.8)
KDE Platform Version: 4.8.4 (4.8.4)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-24-generic x86_64
Distribution: Ubuntu 12.04 LTS

-- Information about the crash:
- What I was doing when the application crashed:

Using the "Account Assistant" in Kmail to set up an IMAP account. The SSL cert was queried as unmatching, I accepted the mismatch and the assistant crashed (though it's still showing).

-- Backtrace:
Application: IMAP Account 1 of type IMAP E-Mail Server (akonadi_imap_resource), signal: Bus error
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f94f2359780 (LWP 6809))]

Thread 3 (Thread 0x7f94dcb5f700 (LWP 6812)):
#0  0x00007f94edcfdb03 in poll () from /lib/x86_64-linux-gnu/libc.so.6
#1  0x00007f94ec849ff6 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f94ec84a45a in g_main_loop_run () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f94e34662c6 in ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
#4  0x00007f94ec86b9a5 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f94ed365e9a in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#6  0x00007f94edd094bd in clone () from /lib/x86_64-linux-gnu/libc.so.6
#7  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f94cd454700 (LWP 6852)):
#0  0x00007f94edcfc0bd in read () from /lib/x86_64-linux-gnu/libc.so.6
#1  0x00007f94ec88488f in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f94ec849abd in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f94ec849f96 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f94ec84a124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f94f177e426 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#6  0x00007f94f174dc82 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#7  0x00007f94f174ded7 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#8  0x00007f94f164cfa7 in QThread::exec() () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#9  0x00007f94f0383c39 in ?? () from /usr/lib/libkimap.so.4
#10 0x00007f94f164ffcb in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#11 0x00007f94ed365e9a in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#12 0x00007f94edd094bd in clone () from /lib/x86_64-linux-gnu/libc.so.6
#13 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f94f2359780 (LWP 6809)):
[KCrash Handler]
#6  0x00007f94f1759068 in QMetaObject::invokeMethod(QObject*, char const*, Qt::ConnectionType, QGenericReturnArgument, QGenericArgument, QGenericArgument, QGenericArgument, QGenericArgument, QGenericArgument, QGenericArgument, QGenericArgument, QGenericArgument, QGenericArgument, QGenericArgument) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#7  0x00007f94f0380497 in KIMAP::SessionPrivate::handleSslError(KSslErrorUiData const&) () from /usr/lib/libkimap.so.4
#8  0x00007f94f1768446 in QObject::event(QEvent*) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#9  0x00007f94f0ad1894 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#10 0x00007f94f0ad6713 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#11 0x00007f94eebf99e6 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#12 0x00007f94f174ee9c in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#13 0x00007f94f1752c6a in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#14 0x00007f94f177df93 in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#15 0x00007f94ec849c9a in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#16 0x00007f94ec84a060 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#17 0x00007f94ec84a124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#18 0x00007f94f177e3bf in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#19 0x00007f94f0b79d5e in ?? () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#20 0x00007f94f174dc82 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#21 0x00007f94f174ded7 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#22 0x00007f94f1752f67 in QCoreApplication::exec() () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#23 0x00007f94f1e7d326 in Akonadi::ResourceBase::init(Akonadi::ResourceBase*) () from /usr/lib/libakonadi-kde.so.4
#24 0x000000000041a996 in int Akonadi::ResourceBase::init<ImapResource>(int, char**) ()
#25 0x00007f94edc3876d in __libc_start_main () from /lib/x86_64-linux-gnu/libc.so.6
#26 0x0000000000415375 in _start ()

This bug may be a duplicate of or related to bug 279113.

Possible duplicates by query: bug 302459, bug 301881, bug 301629, bug 296856, bug 296728.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-07-26 23:41:29 UTC

*** This bug has been marked as a duplicate of bug 279113 ***