Bug 309753 - Optimize writes to the swap file
Summary: Optimize writes to the swap file
Status: RESOLVED DUPLICATE of bug 309751
Alias: None
Product: kate
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-08 16:16 UTC by Bram Vandoren
Modified: 2013-04-16 14:53 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bram Vandoren 2012-11-08 16:16:23 UTC
With swap files enabled (default setting), kate writes to the swap file after every change. On slow storage (like network disks) the text editor blocks sometimes for a fraction of a second (annoying). It would be nice if changes are written to disk only every x seconds and/or executed in a separate thread so that it doesn't block the text editor.

Reproducible: Always




Network disks (eg NFS) are often synchronous (the data has to be written to disk before the write call returns, -similar to calling fsync after each write). 

Version 3.9.2
Comment 1 Dominik Haumann 2013-04-16 14:53:06 UTC
It writes to disk every 15 seconds, and if you check the option "[x] Disable swap files syncing" in Open/Save > Advanced, writing the swap file is never forced.

There was a bug in KDE <= 4.9, which got fixed for KDE 4.10: https://bugs.kde.org/show_bug.cgi?id=309751

So you need KDE 4.10. Does that work for you? I'll close this report as a duplicate of bug #309751.

*** This bug has been marked as a duplicate of bug 309751 ***